+ Post New Thread
Results 1 to 5 of 5
Windows 7 Thread, WMI Corruption in Technical; OSPPError.png Anyone ever have WMI go legs up on them? In my 15 years of working IT I never have ...
  1. #1
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    795
    Thank Post
    81
    Thanked 130 Times in 113 Posts
    Blog Entries
    8
    Rep Power
    31

    WMI Corruption

    OSPPError.png

    Anyone ever have WMI go legs up on them? In my 15 years of working IT I never have and of course the very first time I have to deal with it it hits my Windows 7 x64 base image. I first noticed it when trying to activate Office 2010 using the OSPP.vbs script; it was giving me an error code of -2147217406.. It was failing hard and so was another script I use for post-image related tasks. I then found this in the Event Log:
    Code:
    Windows Management Instrumentation ADAP failed to connect to namespace \\.\root\cimv2 with the following error 0x80041002
    Running the WMI Diagnostic utility was also filled with similar errors.
    Code:
    0x80041002 (WBEM_E_NOT_FOUND)
    After messing around with a couple potential fixes the only thing that cured it was stopping the WMI service and resetting the WMI repository using this command:
    Code:
    c:\windows\system32\wbem\winmgmt.exe /resetrepository
    You can test it by either running a script that calls to WMI, or using a built-in utility in Windows to connect.
    Code:
    c:\windows\system32\wbem\wbemtest.exe
    What bugs me is that I don't know what caused it. The only changes I made to image since the last update was these:

    Code:
    Image Revision:	2013/10/23
    	-Windows Updates
    	-Installed Java 7u40
    		-Added registry keys to disable sponsor in Java Update
    		-Removed Start Menu group
    	-Installed Windows Live Movie Maker 2012
    	-Installed Flash 11.9.900.117
    	-Installed Reader 11.0.04
    	-Installed Google Chrome 30.0.1599.101
    	-Updated OEM information
    I suspect it was one of the updates; the last time it was ran was 8/22. Fun times... I got to waste an entire morning ironing this out. Now to sysprep and resend this pig of an image back up to WDS.
    Last edited by Duke5A; 24th October 2013 at 04:51 PM.

  2. #2

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    You able to put the above into a word or pdf document - tried using a pdf writer ( PDF Creator ) etc but it is truncating the content that is inside code type boxes, arrggghhh

  3. #3


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,583
    Thank Post
    228
    Thanked 855 Times in 734 Posts
    Rep Power
    295
    check your path variable. ive seen quicktime break it by missing a ; out of path so wbem folder wasnt pathed and wmi died

  4. Thanks to sted from:

    mac_shinobi (24th October 2013)

  5. #4
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    795
    Thank Post
    81
    Thanked 130 Times in 113 Posts
    Blog Entries
    8
    Rep Power
    31
    Quote Originally Posted by mac_shinobi View Post
    You able to put the above into a word or pdf document - tried using a pdf writer ( PDF Creator ) etc but it is truncating the content that is inside code type boxes, arrggghhh
    @mac_shinobi
    WMI Corruption.docx

  6. Thanks to Duke5A from:

    mac_shinobi (24th October 2013)

  7. #5

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    Quote Originally Posted by Duke5A View Post
    Perfect thanks !!

SHARE:
+ Post New Thread

Similar Threads

  1. Corrupt Word/Excel files
    By ind13 in forum Office Software
    Replies: 5
    Last Post: 6th June 2008, 02:03 PM
  2. Restoring data from a corrupt sd card
    By timbo343 in forum Windows
    Replies: 4
    Last Post: 15th June 2006, 09:37 AM
  3. Recovering Files From a Corrupt Floppy
    By Preston in forum Windows
    Replies: 15
    Last Post: 27th April 2006, 03:39 PM
  4. GPO WMI Filters
    By Norphy in forum Windows
    Replies: 2
    Last Post: 9th March 2006, 09:28 AM
  5. school information is corrupted
    By beeswax in forum ICT KS3 SATS Tests
    Replies: 13
    Last Post: 31st January 2006, 12:56 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •