+ Post New Thread
Results 1 to 5 of 5
Windows 7 Thread, Show popup/large message at login screen using standard commands? in Technical; Hi, I have a SIMS script that installs the first time the computer is installed and turned on. Where its ...
  1. #1

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10

    Show popup/large message at login screen using standard commands?

    Hi,

    I have a SIMS script that installs the first time the computer is installed and turned on.

    Where its a silent script, unless you know its running you could accidently turn the computer off.

    We currently have a legal notice so everyone just clicks ok without reading so cant put the message there.

    Im after something obvious on the ctrl+alt+delete screen to show its doing something.

    Anyone found/use such a thing?

  2. #2

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,698
    Thank Post
    335
    Thanked 516 Times in 484 Posts
    Rep Power
    180
    Although it's a bit cheaty, any reason you couldn't have a different background which only gets changed once SIMs installed? If you want it pre-logon at least.

    Steve

  3. #3

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10
    Do you mean the OEM background image. Guess this could work,

    The only issue is that it needs a restart after changing the reg key before it changes from the default background and the GPO also changes the OEMBackground so would probably overwrite.

  4. #4

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,698
    Thank Post
    335
    Thanked 516 Times in 484 Posts
    Rep Power
    180
    Quote Originally Posted by dany2010 View Post
    Do you mean the OEM background image. Guess this could work,

    The only issue is that it needs a restart after changing the reg key before it changes from the default background and the GPO also changes the OEMBackground so would probably overwrite.
    Well not sure quite how you've got it, and not that I think this is a slick way but:

    PC starts up, script installs new background. Restarts.
    PC starts up, script installs SIMs, changes Background again. Restarts.
    PC starts up, original background + SIMs installed
    Magic!

    The GPO sets the location of the file, so you can just replace the file without the GPO being affected or should be able to.

    (On a side note, any reason you're not just installing SIMs through Solus/startup scripts etc? Seems a different way of doing it?)

    Steve

  5. #5

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10
    Sorry, its installed using a startup script rather than logging in automatically and installing.

    if exist "C:\Program Files (x86)\SIMS\SIMS .net\pulsar.exe" goto _end
    if exist "C:\Program Files\SIMS\SIMS .net\pulsar.exe" goto _end

    net use H: \\****Server removed****\simsroot /user:******Removed****** /persistent:yes
    "H:\sims\Setups\SIMSInfrastructureSetup.exe" /S
    "H:\sims\Setups\SIMSApplicationSetup.exe" /S
    "H:\sims\Setups\SIMSManualSetup.exe" /S
    "H:\sims\Setups\SIMSAMPARKSetup.exe" /S


    if exist "c:\Program Files (x86)" goto _x64


    :_x86
    copy "H:\connect.ini" "c:\Program Files\sims\sims .net\connect.ini" /y
    copy "H:\sims.ini" "c:\windows\sims.ini" /y
    net use H: /delete
    shutdown /r /t 90
    goto _end

    :_x64

    copy "H:\connectx64.ini" "c:\Program Files (x86)\sims\sims .net\connect.ini" /y
    copy "H:\simsx64.ini" "c:\windows\sims.ini" /y
    net use H: /delete
    shutdown /r /t 90
    goto _end


    :_end

    rem pause
    The sims install script starts first and then is set to resart the machine and then the discover script runs and then restarts the machine.

    On my machine which has everything default in the GPO it shows the ctrl+alt+delete login screen when its still installing. Same with the admin machines at the minuter. Justlooking into the gpo run startup scripts asynchronously but by default its supposed to be set.
    Last edited by dany2010; 3rd July 2013 at 10:25 AM.

SHARE:
+ Post New Thread

Similar Threads

  1. Windows 7 'Welcome' screen hang at login
    By ianh64 in forum Windows 7
    Replies: 38
    Last Post: 16th January 2012, 11:08 AM
  2. Machine hangs at CC3 login screen
    By Greenbeast in forum Windows
    Replies: 4
    Last Post: 20th September 2010, 01:58 PM
  3. Display message at login, maybe just once?
    By theeldergeek in forum Mac
    Replies: 10
    Last Post: 9th December 2009, 12:31 PM
  4. multiple domains at login screen
    By sandeep2504 in forum Windows Server 2000/2003
    Replies: 1
    Last Post: 24th November 2009, 10:08 AM
  5. Display network status at login screen
    By Alis_Klar in forum Wireless Networks
    Replies: 1
    Last Post: 4th November 2008, 03:57 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •