+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Windows 7 Thread, Lots of My Documents in Share Gotcha - More Help Needed in Technical; Please can someone give me a bit more help with this tip that is in the Windows 7 Gotchas Sticky: ...
  1. #1
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30

    Lots of My Documents in Share Gotcha - More Help Needed

    Please can someone give me a bit more help with this tip that is in the Windows 7 Gotchas Sticky:

    When viewing redirected folders share you may see many "My Documents"

    When Windows sets up a new redirected My Documents it creates a hidden desktop.ini file which means that when you browse the share/location from Windows you may see a huge amount of folders called "My Documents"/"Documents" rather then the folder name it should be (e.g. \\server\share\username as the path could look like \\server\share\documents)
    The folders are correctly named but when Windows sees the existance of the hidden desktop.ini in each directory it displays the folder as "My Documents"/"Documents" rather then the real folder name. This can happen with any special folder I believe such as Favourites.

    The solution:
    Remove the desktop.ini file in each my docs redirected folder. This can be done with script or using Group Policy Preferences. You can also redirect to a sub folder which hides the issue (e.g. redirect to \\server\share\username\documents\)
    I am currently using Windows Server 2003 and have mixed clients XP and Win 7. Where a user is new and first logs in on Win 7, the redirected folder is correctly named with the username in the share. The problem for me has started with a user that has been upgraded from XP to Win 7. Their share folder has been renamed My Documents in the share. Obviously if that happens to everyone, it will be a real nuisance to identify whose folder is whose. The redirected folder also seems to contain another My Documents folder. I have tried deleting the desktop.ini in the top level My Documents, but it looks like it changes back to being called My Documents again when the user logs in next time.

    What am I doing wrong? Do I need to remove all instances of desktop.ini at all levels within the folder?

  2. #2


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,647
    Thank Post
    229
    Thanked 865 Times in 743 Posts
    Rep Power
    297
    the best solution is to redirect their my docs to a my docs folder in their user area so say u:\my documents\word.doc but that can be a royal pita for existing users but its something id do for new ones. the easier "fix" is to use file server resource manager and dissalow anyone saving a file called desktop ini in your user folder (so d:\users or whatever) then do a search and delete of existing desktop.ini files

  3. Thanks to sted from:

    Andie (26th June 2013)

  4. #3

    Join Date
    Dec 2009
    Posts
    914
    Thank Post
    98
    Thanked 184 Times in 159 Posts
    Rep Power
    54
    You can add a column in explorer called 'filename' which ignores the my documents and will display the actual folder name.

    Short term solution

  5. Thanks to RTFM from:

    Andie (26th June 2013)

  6. #4

    Join Date
    Aug 2008
    Location
    norwich
    Posts
    44
    Thank Post
    1
    Thanked 7 Times in 7 Posts
    Rep Power
    14
    We stopped the desktop.ini file from being created (I think we did this by file screening - might not be available on server 2003 though?), did a search of the home directories on the server for desktop.ini and deleted them all.

  7. Thanks to cullingsh from:

    Andie (26th June 2013)

  8. #5

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    Do as RTFM suggests, or as I have previously written. I can't search as Edugeek's search is temporarily offline.

    I wouldn't recommend messing with ini files, as this can slow down logon speeds. Plus you'll be forever going round in circles as Windows will re-create them!

  9. #6
    denon101's Avatar
    Join Date
    Jul 2008
    Location
    Stuck in the server room......
    Posts
    395
    Thank Post
    54
    Thanked 37 Times in 35 Posts
    Rep Power
    21
    I deleted the desktop.ini files and then used File Server Resource Manager to create a rule to stop them being recreated. This works fine for us, there is no noticeable difference in logon speeds.

  10. Thanks to denon101 from:

    Andie (26th June 2013)

  11. #7

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,678
    Thank Post
    861
    Thanked 650 Times in 431 Posts
    Rep Power
    499
    You don't need to delete the desktop.ini file at all - ther is a GPO to stop this behaviour
    Been a while since I had to set it so will need to go off and find it now - though it'll be on here somewhere..

  12. #8

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,678
    Thank Post
    861
    Thanked 650 Times in 431 Posts
    Rep Power
    499
    Here we go:

    It's in two places so not sure which is which:

    Code:
    Computer Configuration/Administrative Templates/System/Folder Redirection
    or
    Code:
    User Configuration/Administrative Templates/System/Folder Redirection
    The setting is

    Code:
    Use localized subfolder names when redirecting Start Menu and My Documents
    And should be Disabled

  13. 2 Thanks to Gatt:

    Andie (26th June 2013), simpsonj (26th June 2013)

  14. #9
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30
    Quote Originally Posted by RTFM View Post
    You can add a column in explorer called 'filename' which ignores the my documents and will display the actual folder name.

    Short term solution
    Simple but brilliant! Thanks so much! Was a bit anxious about fiddling with system file deletes, although others have done it fine.

  15. #10
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30
    Quote Originally Posted by Gatt View Post
    Here we go:

    It's in two places so not sure which is which:

    Code:
    Computer Configuration/Administrative Templates/System/Folder Redirection
    or
    Code:
    User Configuration/Administrative Templates/System/Folder Redirection
    The setting is

    Code:
    Use localized subfolder names when redirecting Start Menu and My Documents
    And should be Disabled
    I have set this to Disabled in User Config, as that is where my folder redirection is set up. I shall feed back on the effects so that anyone else looking at this thread will know what to do as well.

  16. #11
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30
    Thanks to everyone for taking the time to help. Edugeeks are amazing!

  17. #12
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30
    Quote Originally Posted by Andie View Post
    I have set this to Disabled in User Config, as that is where my folder redirection is set up. I shall feed back on the effects so that anyone else looking at this thread will know what to do as well.
    The test did not go well, but I don't think it's necessarily the fault of this policy. Maybe I have something else set wrong somewhere. The policy on test resulted in the user not being able to access any of the Documents folders at all. I've done something wrong with permissions somewhere..... Will feed back at some future point when I've worked out what is going on.

  18. #13

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,678
    Thank Post
    861
    Thanked 650 Times in 431 Posts
    Rep Power
    499
    Are the Desktop.ini files still in place?
    It may be that thye need to be deleted for it to take effect
    It's been a long time since I dealt with this issue specifically that I cannto recall exactly what I had to do...

  19. #14
    Andie's Avatar
    Join Date
    Sep 2006
    Location
    Cambridgeshire
    Posts
    795
    Thank Post
    167
    Thanked 66 Times in 49 Posts
    Rep Power
    30
    Quote Originally Posted by Andie View Post
    The test did not go well, but I don't think it's necessarily the fault of this policy. Maybe I have something else set wrong somewhere. The policy on test resulted in the user not being able to access any of the Documents folders at all. I've done something wrong with permissions somewhere..... Will feed back at some future point when I've worked out what is going on.
    @Gatt, I started with a clean user as a test - not logged in and with no folder in the share. It looks like it is a problem with the clean user login not being able to carry out the folder and start menu redirection, not the policy you gave me as i have removed that policy and it is still not redirecting start menu and folders.... I guess I must have been working with existing users up till now, although i didn't think that was the case, and I've now uncovered a new problem. No doubt your policy will do what I need it to do once I've fixed the other issue. Meanwhile, back to the drawing board....

  20. #15
    ozydave's Avatar
    Join Date
    Jun 2007
    Posts
    256
    Thank Post
    80
    Thanked 34 Times in 23 Posts
    Rep Power
    31
    Quote Originally Posted by cullingsh View Post
    We stopped the desktop.ini file from being created (I think we did this by file screening - might not be available on server 2003 though?), did a search of the home directories on the server for desktop.ini and deleted them all.
    Ditto here

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •