+ Post New Thread
Results 1 to 5 of 5
Windows 7 Thread, No printers appearing in 'Devices' - Windows 7. Causing Microsoft Programs to hang. in Technical; This is an on-going mystery which I have been unable to solve as yet - [Win 2008 R2 Server] network ...
  1. #1

    Join Date
    Feb 2010
    Location
    Plymouth
    Posts
    2
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    No printers appearing in 'Devices' - Windows 7. Causing Microsoft Programs to hang.

    This is an on-going mystery which I have been unable to solve as yet - [Win 2008 R2 Server] network with Windows 7 clients.
    When various MS applications are launched (e.g. Microsoft Word) and also 'Smart Notebook' program, they hang at the start-up screen. Whenever this happens I have noticed that no printers are apparent in 'Devices' (via Control Panel). This appears to be an intermittent problem.
    I am assuming that the reason for these applications hanging is that one of the first thing these programs do is look for printers? As no printers are visible, then the applications hang? I have tried various 'fix-its' for this ongoing (intermittent) problem - such as a Microsoft Repair Tool (downloaded from their site) and also applying a Group Policy Update force. It maybe that the printers do not 'refresh' properly when the network refreshes at on-going intervals.
    Often I have been able to get the printers to 'come back' by stopping the print spooler and then restarting (on the client). Once the printers are visible then it seems I am able to launch the programs normally. This is my first post to Edugeek so any help would be appreciated. Thank You.

  2. #2
    AJWhite1970's Avatar
    Join Date
    Sep 2012
    Location
    Wiltshire
    Posts
    320
    Thank Post
    82
    Thanked 74 Times in 57 Posts
    Rep Power
    16
    Sounds like one of the numerous spooler bugs in Win7 SP1. I would start by installing most of these:-

    List of print related hotfixes post SP1 for Windows 7 SP1 and Windows Server 2008 R2 SP1. - The troubleshooters and problem solvers... - Site Home - TechNet Blogs

    I have the following installed site wide and all my printer quirks disappeared.

    KB2769359-x86, KB2647753-v2-x86, KB2616332-x86, KB2616471-x86, KB2636963-v2-x86, KB2737353-v2-x86

    Andrew

  3. Thanks to AJWhite1970 from:

    WMTech (18th January 2013)

  4. #3
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    789
    Thank Post
    79
    Thanked 129 Times in 112 Posts
    Blog Entries
    8
    Rep Power
    31
    I would bet it is a problem with one if the printer drivers. What happens if you try to print of a test page from every printer installed on the system? For me it was a HP P1606 driver that was causing a very similar issue.

  5. Thanks to Duke5A from:

    WMTech (18th January 2013)

  6. #4


    Join Date
    Sep 2008
    Posts
    1,748
    Thank Post
    320
    Thanked 258 Times in 211 Posts
    Rep Power
    119
    Got this problem on WinXp clients and as others have said it was related to a driver issue. I updated the to a universal driver on the server but as the old driver was present on the client I had to remove it as it was still causing print spool errors for users. Problem drivers for me seemed to be Kyocera KX ones.

  7. Thanks to penfold from:

    WMTech (23rd January 2013)

  8. #5

    Join Date
    Feb 2010
    Location
    Plymouth
    Posts
    2
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thank You for this!

    Quote Originally Posted by penfold View Post
    Got this problem on WinXp clients and as others have said it was related to a driver issue. I updated the to a universal driver on the server but as the old driver was present on the client I had to remove it as it was still causing print spool errors for users. Problem drivers for me seemed to be Kyocera KX ones.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 0
    Last Post: 20th September 2011, 10:10 AM
  2. No Internet Access in windows 7
    By Biker in forum Windows 7
    Replies: 15
    Last Post: 7th December 2010, 07:28 PM
  3. Replies: 9
    Last Post: 22nd November 2010, 10:47 AM
  4. Replies: 5
    Last Post: 21st January 2010, 02:46 PM
  5. Windows 2003 Server R2 - No printer ports !!
    By pmassingham in forum Windows
    Replies: 2
    Last Post: 1st September 2006, 03:16 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •