+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 39
Windows 7 Thread, RDP Initiating Remote Connection SLOW!!!! in Technical; LAN 100Mbps via Cisco switch to backbone of network tracert and ping responses seem fine....
  1. #16
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    LAN 100Mbps via Cisco switch to backbone of network tracert and ping responses seem fine.

  2. #17

    Join Date
    Jul 2009
    Posts
    267
    Thank Post
    6
    Thanked 43 Times in 37 Posts
    Rep Power
    16
    i know its random but try a different ethernet port 1)on the cisco swicth 2) any other switch?
    (eek running out of ideas) assuming your pc has no spyware / virii / nastys / enough RAM / network utilization is 99% lol

  3. #18

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    If it does the same with other domain accounts, you could try demoting the workstation and re-promoting to the domain. Failing that, it's imaging time I think!

  4. #19
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    One of this firsts things i did was remove the PC from the domain and re-added it, still no joy.

  5. #20

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    Delete bitmap cache on your pc, ensuring to close down Remote Desktop / Terminal Services ( as in the app you use ) before doing the below :

    <username> is the person(s) windows username

    If Windows 7 :

    Navigate to the below directory ( need hidden files and folders showing as AppData is a hidden directory, obviously )

    C:\Users\<username>\AppData\Local\Microsoft\Termin al Server Client

    Delete the folder named Cache

    Windows XP :


    C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Terminal Server Client

    Same again Delete the Cache Directory

    Shot in the dark but thought it worth a try

    Maybe check your Computer as far as

    1. Flushing and re-registering DNS ( through command prompt run as admin )
    2. Check hosts file and if need be reset to defaults
    3. Last resort but maybe reset tcp/ip stack and winsocks ?

    When you say a win 7 pro host, is this a windows 7 pc you are trying to rdp to or is the windows 7 pro host your pc ?
    Last edited by mac_shinobi; 23rd January 2013 at 05:12 PM.

  6. #21
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    thanks for this, unfortunatley still the same issue, Windows 7 is my PC

  7. #22

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    Quote Originally Posted by Matt_Brfc View Post
    thanks for this, unfortunatley still the same issue, Windows 7 is my PC
    Try this


    http://blog.tmcnet.com/blog/tom-keat...lem-solved.asp

    In any event, I discovered that Vista's (Windows 7 as well) Receive Window Auto-Tuning could have issues on some networks. I really didn't want to disable Receive Window Auto-Tuning due to it's QoS, bandwidth speed/throughput, and VoIP quality benefits, but I had no choice. I use Remote Desktop all the time to manage 30+ servers. After disabling Receive Window Auto-Tuning, the "slowness" problem with mouse-clicks, keystrokes, and screen redraws went away. Problem solved! Woo-hoo!

    Here is what you need to do if you have the same issue:


    - Run a command prompt (cmd.exe) as an Administrator
    - Type: netsh interface tcp set global autotuninglevel=disabled
    Disable the autotunning feature in Vista completely, and fit and lock the RWIN receive window to default value 65536 bytes.

    If you want to to re-enable it:
    - Type: netsh interface tcp set global autotuninglevel=normal

    In some cases you may need to use this command in addition to the above, but I didn't have to:
    - Type: netsh interface tcp set global rss=disabled

    Update! This command makes your network connection EVEN FASTER
    Type: netsh interface tcp set global autotuninglevel=highlyrestricted

    The reason is that this command will still "auto tune" your TCP connections, but not as drastically as 'normal' mode. It will allow the receive window to grow beyond the default value, but again it will do so very conservatively. In this mode, Vista will by default use RWIN (receive window) of 16,384 bytes with a scale factor of 2. I was browsing computers in my Network Neighborhood and trying to get to \\computername\c$ which was taking forever to load. I changed it to highlyrestricted and it was much faster. 'highlyrestricted' mode is my recommendation for the fastest network performance whether you are using Remote Desktop, Internet browsing, or doing SMB file copies across your network.

    Now, because Receive Window Auto-Tuning increases network utilization of high-BDP transmission paths, the use of Quality of Service (QoS) or application send rate throttling is important for networks that are operating at or near capacity. So I'd like to get this feature working, which will require some network topology examination. I did read that Windows Vista supports Group Policy-based QoS settings that allow you to define throttling rates for sent traffic on an IP address or TCP port basis. So perhaps I can just disable auto-tuning for the RDP port 3389 and leave it on for all other ports.

    I'm headed over to Microsoft's site which has some excellent resources on policy-based QoS. From my initial research it looks like you can configure some pretty nifty QoS policies. For example, you can specify a QoS policy with a DSCP value of 46 for a VoIP application, allowing routers to place those packets in a low-latency queue, or you can use a QoS policy to throttle a set of servers' outbound traffic to 512 KBps when sending from TCP port 443 (HTTPS port). In theory, I can set Remote Desktop to have "top" priority and give it all the bandwidth it needs. Heck, maybe I'll set just my IP address and my Remote Desktop port to have top priority on our network. To hell with the rest of my fellow co-workers! They don't need no stinkin' bandwidth. It's mine! All mine! Now that I solved the slowness problem with Remote Desktop, it's time to head over to Amazon to check out their top Bluray deals of the week!
    Last edited by mac_shinobi; 24th January 2013 at 12:38 PM.

  8. #23

    Join Date
    Jul 2007
    Location
    Moray, Scotland
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

  9. #24

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    @Matt_Brfc - Curious how you are getting on with this ?

  10. #25

    m25man's Avatar
    Join Date
    Oct 2005
    Location
    Romford, Essex
    Posts
    1,625
    Thank Post
    49
    Thanked 455 Times in 335 Posts
    Rep Power
    137
    Curious to know how you set up your LAN connections to the RDP server?

    Do you use NIC bonding on the RDP Servers?
    Do you use one NIC for LAN use by the RDP server and a second just for client incoming connections? A sort of in on one, out on the other sceanrio.
    The latter has proven to be a much faster solution in some places.
    Then there is the binding method Use Remote Desktop Services on multi-homed server: RDP, dual NIC

  11. Thanks to m25man from:

    mac_shinobi (25th January 2013)

  12. #26
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Some servers have 2 nics but the majority only have a single interface, still having issues with this although I have not had much time to investigate any further recently.

  13. #27
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Head Bashing! tried a whole range of things ranging from RDP config through to repairing the OS without much luck, cleared cached credentials and still no joy!! Arghh!

  14. #28
    Matt_Brfc's Avatar
    Join Date
    Dec 2011
    Location
    Lancashire
    Posts
    39
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    RDP is used on both servers and workstations, regardless of the platform or architecture this is apparent on al hosts.

  15. #29

    Join Date
    Jun 2013
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Matt,
    Were you ever able to resolve this bizzare issue?

    I have the same issue with a Win 7 Ent PC on our domain that appears to be setup in an identical manner to other PCs just like that do not exhibit the behavior. I have read a lot of articles and experimented with a lot of settings but at this point am not any closer to resolving outside of replacing it.

    Rob

  16. #30

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,729
    Thank Post
    3,252
    Thanked 1,049 Times in 971 Posts
    Rep Power
    364
    Just wondering if you tried the below ( as per my above post )

    Quote Originally Posted by Mac_Shinobi
    Here is what you need to do if you have the same issue:

    - Run a command prompt (cmd.exe) as an Administrator
    - Type: netsh interface tcp set global autotuninglevel=disabled
    Disable the autotunning feature in Vista completely, and fit and lock the RWIN receive window to default value 65536 bytes.

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. 3 Simultaneous Remote Connections To a Server
    By farquea in forum Windows Server 2000/2003
    Replies: 17
    Last Post: 29th July 2010, 12:57 AM
  2. Multiple Laptop connections - SLOW!
    By smitho1990 in forum Network and Classroom Management
    Replies: 7
    Last Post: 4th May 2010, 08:41 AM
  3. Synetrix connection slow
    By nicholab in forum London Grid for Learning (LGfL)
    Replies: 1
    Last Post: 6th March 2010, 11:25 PM
  4. Removing Remote Connection program
    By faza in forum How do you do....it?
    Replies: 6
    Last Post: 30th November 2009, 08:19 AM
  5. Remote Connection to Servers
    By faza in forum Wireless Networks
    Replies: 16
    Last Post: 2nd March 2007, 09:34 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •