+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
Windows 7 Thread, Machines not registering in Reverse DNS in Technical; This has me stumped but not sure whether I've resolved it yet or not. I set up reverse dns for ...
  1. #1
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,224
    Thank Post
    455
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65

    Machines not registering in Reverse DNS

    This has me stumped but not sure whether I've resolved it yet or not.

    I set up reverse dns for the ip range that we have when I started and it's been working quite happily. This summer we upgraded to Windows 7 and now no machine is registering the reverse DNS records.

    Have I missed something obvious in my setup that worked quite happily in XP but doesn't in 7 (because I don't remember setting anything specific)?

    Thanks

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    What server OS are you running? And I presume you're running Active Directory with DNS integrated? Or DNS on its own? Have you tried stopping and starting DNS (within DNS server)?

    If you open a command prompt on a workstation and enter:

    Code:
    ipconfig /registerdns
    do entries appear?

  3. #3
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,224
    Thank Post
    455
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    DNS is AD integrated, the few XP machines we still have are still registering in the Reverse Zones, All servers have been restarted this week.

    Tried the ipconfig command and it still doesn't appear for Windows 7 machines.

    Server OS is 1 Server 2003 machine and 2 2008 R2 machines.

  4. #4
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Is there already a client occupying the IP in the reverse lookups?

    The other thing to check is that your DNS proxy account (can be set in the DNS options) has permission to write to the reverse DNS zones.

  5. Thanks to Jamo from:

    Cache (2nd October 2012)

  6. #5
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,224
    Thank Post
    455
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    No other IP is occupying it, it's practically empty apart from my servers, static entries and Windows XP machines now.

    Will try and check the DNS Proxy account (although I think I just added the server to the DNS Proxy usergroup)

  7. #6

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    Are your servers replicating correctly?

    To my knowledge, there isn't any difference between XP or 7 how it handles DNS requests, but generally Secured DNS Updates are recommended. This basically means only computers belonging to the domain can update DNS records.

    From a 7 workstation, login as an admin, open up a command prompt and enter ipconfig /all

    It should display an IP from your DHCP Server, your DNS Server(s) and your Gateway. Does it all look correct?

  8. Thanks to Michael from:

    Cache (3rd October 2012)

  9. #7
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,224
    Thank Post
    455
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    Servers seem to be replicating correctly, no errors are being logged anywhere and the ipconfig appears normal.

    As an example that it definitely seems to be something to do with Windows 7 or along those lines, every day this week I have redeployed one computer from XP to Windows 7. In each case I've deleted the DNS records for the machine, redeployed it and then the Forward lookup is recreated, the reverse lookup isn't. In each case the machine had a reverse lookup record before it was reinstalled with windows 7.

  10. #8

    Join Date
    Nov 2007
    Location
    Nottingham
    Posts
    116
    Thank Post
    7
    Thanked 23 Times in 14 Posts
    Rep Power
    17
    We are getting the same issue, our reverse lookup is pretty much empty. On the DHCP Server properties ours is set to "Dynamically update DNS A and PTR Records only if requested by the DHCP Client" shoud this be on "Always dynamically update DNS A and PTR Records" ?

  11. #9
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    From MS

    By default, a Windows 2000 and newer statically configured machines will register their A record (hostname) and PTR (reverse entry) into DNS.

    If set to DHCP, a Windows 2000 or newer machine will request DHCP to allow the machine itself to register its own A record, but DHCP will register its PTR (reverse entry) record.
    Double check that the DHCP server has permissions to write to the reverse lookup zone, if in doubt test by allowing everyone full access, if that works then its permissions which are your issue. The Always update option basically just makes the DHCP server ALWAYS do the registering both on behalf of the client.

  12. #10

    Join Date
    Jun 2007
    Location
    London
    Posts
    894
    Thank Post
    64
    Thanked 171 Times in 140 Posts
    Rep Power
    55
    Have you added credentials to your DHCP servers to allow DNS dynamic updates? Create a user called e.g. DNSupdate & add them to the group DnsUpdateProxy. Open DHCP and, for each server, expand the server, right-click on IPv4, Advanced, Credentials, then add the authentication details for the account DNSupdate. You might need to restart DHCP.

  13. #11
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by timzim View Post
    Have you added credentials to your DHCP servers to allow DNS dynamic updates? Create a user called e.g. DNSupdate & add them to the group DnsUpdateProxy. Open DHCP and, for each server, expand the server, right-click on IPv4, Advanced, Credentials, then add the authentication details for the account DNSupdate. You might need to restart DHCP.
    Also, watch out if you have apples in the fleet as we do. They will register their own reverse DNS records and you can end up with endless apples stuck in the reverse lookup zones as the DNSProxy account doesn't have permissions to delete the entries!

  14. #12

    Join Date
    Jun 2007
    Location
    London
    Posts
    894
    Thank Post
    64
    Thanked 171 Times in 140 Posts
    Rep Power
    55
    Quote Originally Posted by Jamo View Post
    you can end up with endless apples stuck in the reverse lookup zones
    Could you fix this with the Heimlich Manoeuvre?

  15. #13
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by timzim View Post
    Could you fix this with the Heimlich Manoeuvre?
    Is that the removal of all Apples from the building cus I would LOVE that!

  16. #14
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,224
    Thank Post
    455
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    Don't know whether it's right or not, but it works.

    Have added the DC to the DNS Update Proxy group and created a standard user and added the credientials to the DHCP server.

    Ran the following command because another website said you needed to on Windows 2008 R2 DC's: dnscmd /config /enableednsprobes 0

    Enabled the dHCP server to register all records regardless and the DNS zones are repopulating.

    Will have to wait and see if it throws up any other problems I guess....

  17. #15
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    DNS is great when it works Good luck sounds like its sorted now, best thing to do is double check that records don't become stale now! (Give it double the DHCP lease time and double check that records aren't incorrect)

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Any way to freeze/lock the screen when register not taken in SIMS?
    By El_Nombre in forum How do you do....it?
    Replies: 9
    Last Post: 3rd May 2011, 04:17 PM
  2. XP Clients not appearing in DNS
    By GoldenWonder in forum Windows
    Replies: 5
    Last Post: 30th November 2010, 01:12 PM
  3. Stop OS X Server Registering in DNS
    By Zoom7000 in forum Mac
    Replies: 2
    Last Post: 2nd March 2009, 09:40 AM
  4. Clients not registering DNS
    By OutLawTorn in forum Windows
    Replies: 1
    Last Post: 7th May 2008, 03:42 AM
  5. am registers not showing in lesson monitor 6
    By philjones2000 in forum MIS Systems
    Replies: 2
    Last Post: 11th September 2007, 08:15 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •