+ Post New Thread
Results 1 to 9 of 9
Windows 7 Thread, Forcing Laptop To Use Wired Connection Over Wireless in Technical; I'm finding that when our laptops are plugged in with a network cable and the wireless is on, they are ...
  1. #1

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    5

    Forcing Laptop To Use Wired Connection Over Wireless

    I'm finding that when our laptops are plugged in with a network cable and the wireless is on, they are still choosing to use the wireless connection over the wired. How can i set it to prioritize the wired connection when available over wireless??

  2. #2
    soveryapt's Avatar
    Join Date
    Jan 2009
    Location
    Lancashire
    Posts
    2,402
    Thank Post
    648
    Thanked 277 Times in 244 Posts
    Rep Power
    78
    1. Click the Start Button
    2. Right Click "Network" and then left Click Properties
    3. From the "Network And Sharing Center" window click "Change Adapter Settings"
    4. On the "Network Connections" window, press the ALT key on your keyboard to being up the menu bar
    5. Click the "Advanced" menu and then "Advanced Settings"
    6. In the "Advanced Settings" window you will see the "Adapters and Bindings" tab and under "Connections" you will see the order they are in, you can use the arrows to the side to move the connection priority up and down.

    It will still connect all 3, unless you tell it to disable them....but at least traffic will go over the ethernet port first (when connected)

    (sourced from Set network device priority in Windows 7 - [H]ard|Forum)

  3. #3

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,689
    Thank Post
    334
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    If you run
    Code:
    netstat -rn | more
    It should show how your current priority list is set,

    e.g. (as mine doesn't have wireless, but same should apply)

    Code:
    ===========================================================================
    Interface List
     10 ..."BLANKED MAC"...... Realtek PCIe FE Family Controller
     21 ..."BLANKED MAC"...... VirtualBox Host-Only Ethernet Adapter
      1 ........................... Software Loopback Interface 1
     24 ......"BLANKED MAC"...... isatap.cable.virginmedia.net
     12 ..."BLANKED MAC"...... Teredo Tunneling Pseudo-Interface
     23 ..."BLANKED MAC"......   isatap.{517B8B23-0B7D-436F-964D-D14BFFDBBA09}
    ===========================================================================
    If you go to the network connections, go to properties, then ipv4 properties, then advanced

    there's a thing called "metrics". By default set to automatic.

    Changing automatic to a number = priority, (Don't think you can ever use 1 as that's default loopback)

    Any help?

    Steve

  4. #4

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    5
    i knew of the Metric way but that never worked for me. I just tried the way suggested by soveryapt but even with my wireless connection 2nd in the list, i turn it on and do speedtest and its clearly using my wireless connection because i switch it off and run the test again and get a massive speed increase!

  5. #5
    soveryapt's Avatar
    Join Date
    Jan 2009
    Location
    Lancashire
    Posts
    2,402
    Thank Post
    648
    Thanked 277 Times in 244 Posts
    Rep Power
    78
    Silly question, but you never know, it is windows after all, have you made the changes and then rebooted your machine to make sure that it's picked up those changes? If not, might be worth a shot.

  6. #6

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    Check the BIOS, there is often an option to disable the wifi when a CAT5 connection is present. Can't remember the common name for it though.

    Rob

  7. #7
    ADMaster's Avatar
    Join Date
    May 2012
    Posts
    326
    Thank Post
    5
    Thanked 33 Times in 28 Posts
    Rep Power
    23
    I have tried the method mentioned by soveryapt in the past but just don't trust it. I am in the habit of flipping the wireless switch when I plug in a cable.

  8. #8

    Join Date
    Aug 2012
    Location
    California
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have been disabling the wireless adapter, but never thought about a bios change, thanks for the thought.

  9. #9

    Join Date
    Apr 2010
    Posts
    2,036
    Thank Post
    83
    Thanked 187 Times in 154 Posts
    Rep Power
    83
    Found this that might be of use to someone in the future - How to bring harmony to your mixed wired and wireless networks - Spiceworks

SHARE:
+ Post New Thread

Similar Threads

  1. Prioritising wired network over wireless
    By LisaW in forum Wired Networks
    Replies: 8
    Last Post: 10th February 2012, 04:51 PM
  2. Turning a laptop into a thin client over wireless
    By mrbios in forum Thin Client and Virtual Machines
    Replies: 3
    Last Post: 26th May 2011, 01:33 PM
  3. Replies: 14
    Last Post: 26th November 2008, 10:10 AM
  4. Forcing WMP to exit once playback over
    By NickHoughton in forum How do you do....it?
    Replies: 6
    Last Post: 24th May 2008, 03:24 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •