I have a version of Joomla 1.6.5 hosted on a Win 2008 Server, IIS7.

I'd like to update it to 1.7 and then maybe to 2.5 but the "Extension Manager : Update" Page, never lists any updates.

When I press "Find Updates" it works for a while then returns this error.

Update: :Extension: Could not open http://www.jevents.net/updates/jevents-update.xml

I can access http://www.jevents.net/updates/jevents-update.xml directly from a browser so I know the page is available, but why can't my Joomla Install open the page?

Could it be the proxy we use for our school? Do i need to config our Joomla to use this proxy?

Any suggestions welcome?

Thank you