+ Post New Thread
Results 1 to 3 of 3
Web Development Thread, Help needed: Odd CSS issue on Safari (IE7, Firefox are OK) in Coding and Web Development; I am working on a new school website (we are supposed to launch it in the next day or two). ...
  1. #1

    Join Date
    Dec 2006
    Location
    US
    Posts
    302
    Thank Post
    64
    Thanked 17 Times in 16 Posts
    Rep Power
    19

    Help needed: Odd CSS issue on Safari (IE7, Firefox are OK)

    I am working on a new school website (we are supposed to launch it in the next day or two). Our site loads properly in both IE7 and Firefox. A few minutes ago, someone emailed that it does not load properly on Mac computers.

    I found a website called BrowsrCamp that shows a screenshot of the site from a Mac and it looks very different.

    I attached screenshots, both from IE7 and BrowsrCamp. Does anyone have ideas on how to correct this issue? If you have a Mac, the address of the new site is: dev.claridenschool. org

    Thanks!


    Screenshots
    IE7: dev.claridenschool.org/ie7.gif
    Safari: dev.claridenschool.org/safari.jpg

  2. #2
    ctaylor2's Avatar
    Join Date
    Nov 2008
    Location
    Bolsover
    Posts
    20
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I think you need to shorten the width of your navigational list items - the last nav link is spilling onto another row and then the main content is pushed off centre.

  3. #3

    Join Date
    Jan 2007
    Location
    Lowestoft, Suffolk
    Posts
    84
    Thank Post
    6
    Thanked 4 Times in 4 Posts
    Rep Power
    17
    If you download Safari for Windows and you can see the faulty layout for yourself. It's wrong here on Safari for Windows.

    What I noticed is Safari seems to have stopped with 16 of 22 items downloaded.

    Can you try it without the
    <span class="preload1"></span>
    <span class="preload2"></span>

    and the Javascript slideshow, because that's missing in Safari. I suspect that's causing the problem.



SHARE:
+ Post New Thread

Similar Threads

  1. Odd VNC Issue
    By netadmin in forum Windows
    Replies: 3
    Last Post: 23rd December 2008, 09:01 PM
  2. Firefox and Safari difference
    By jkmoch in forum EduGeek Joomla 1.0 Package
    Replies: 1
    Last Post: 16th April 2008, 09:19 PM
  3. CSS Issue with eg_simple
    By theJonson in forum EduGeek Joomla 1.0 Package
    Replies: 2
    Last Post: 12th April 2008, 10:12 PM
  4. Replies: 4
    Last Post: 17th March 2008, 04:01 PM
  5. IE7 css problem
    By netadmin in forum Web Development
    Replies: 19
    Last Post: 14th March 2007, 10:41 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •