+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26
Web Development Thread, PHP & IIS in Coding and Web Development; Although I have installed PHP on IIS6, I found Zend Core very good....
  1. #16

    Join Date
    May 2008
    Posts
    56
    Thank Post
    33
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Although I have installed PHP on IIS6, I found Zend Core very good.

  2. #17
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,530
    Thank Post
    815
    Thanked 380 Times in 317 Posts
    Blog Entries
    12
    Rep Power
    80
    Just install xamp, takes 10mins and does all the permission stuff for you

  3. #18
    mattmoo's Avatar
    Join Date
    Jun 2008
    Location
    Leicester
    Posts
    124
    Thank Post
    5
    Thanked 8 Times in 7 Posts
    Rep Power
    13
    I can fix this for your if you have RemoteDesktop accessible?

    I have done this on 3 seperate occasions with different setups, its usually something similar thats not set properly.

    Send me a PM if you want me to give it a go

  4. #19

    Join Date
    Apr 2007
    Location
    York
    Posts
    548
    Thank Post
    8
    Thanked 4 Times in 4 Posts
    Rep Power
    19
    Was there ever a solution to this?
    Trying to install Joomla to test and get a 404 when I view any of the PHP Files.
    PHP Extension allowed in IIS.

  5. #20
    Cools's Avatar
    Join Date
    Jan 2009
    Location
    Bedfordshire
    Posts
    498
    Thank Post
    24
    Thanked 62 Times in 57 Posts
    Rep Power
    24
    [ame="http://www.youtube.com/watch?v=17aAuMVippQ"]YouTube - How to Install PHP5 on Windows 2003 with IIS6 Web Server[/ame]

  6. #21
    Cravon's Avatar
    Join Date
    Jun 2007
    Location
    Holy Terra
    Posts
    43
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    All i did was install PHP v.5, restarted (just incase), then went to IIS - Web Service Extensions, started/allowed the PHP: hypertext processor, checked the properties - required file location, making sure it had C:\location php waht installed to\php-cgi.exe and it was allowed, restarted the server to make doubley sure i had not missed a service and it worked.

    hope that helps

  7. #22

    Join Date
    Apr 2007
    Location
    York
    Posts
    548
    Thank Post
    8
    Thanked 4 Times in 4 Posts
    Rep Power
    19
    Thanks.
    I've allowed PHP in IIS. WHat should be the required fields in the properties?
    I currently have php5ts.dll pointing to C:/Program Files
    What do you mean by the php-cgi.exe?

  8. #23

    Join Date
    Apr 2006
    Posts
    382
    Thank Post
    23
    Thanked 95 Times in 61 Posts
    Rep Power
    44
    If it helps anyone: I have vague memories of having a horrendous time getting PHP (5.2.5) working on as IIS6 machine. This was installing ISAPI, not CGI, by the way.

    If memory serves I'd followed all the guides to the letter and kept getting 404 errors, but eventually found one that mentioned quote marks:

    Open IIS Manager. Right click on the Web Site and select Properties. From the Home Directory tab click the Configuration button. Click Add to add an Application Extension. Enter "c:\PROGRAM FILES\PHP\PHP5ISAPI.DLL" (wrapped in double quotes) as Executable and PHP as Extension. Leave the rest as default and click Ok

    And that did the trick.

  9. #24
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,497
    Thank Post
    101
    Thanked 84 Times in 71 Posts
    Blog Entries
    46
    Rep Power
    37
    i always found it a lot easier to install on a 2000 server

  10. #25

    Join Date
    Apr 2007
    Location
    York
    Posts
    548
    Thank Post
    8
    Thanked 4 Times in 4 Posts
    Rep Power
    19
    Quote Originally Posted by theriver View Post
    If it helps anyone: I have vague memories of having a horrendous time getting PHP (5.2.5) working on as IIS6 machine. This was installing ISAPI, not CGI, by the way.

    If memory serves I'd followed all the guides to the letter and kept getting 404 errors, but eventually found one that mentioned quote marks:

    Open IIS Manager. Right click on the Web Site and select Properties. From the Home Directory tab click the Configuration button. Click Add to add an Application Extension. Enter "c:\PROGRAM FILES\PHP\PHP5ISAPI.DLL" (wrapped in double quotes) as Executable and PHP as Extension. Leave the rest as default and click Ok

    And that did the trick.
    Thanks but when I try with the quotes it says that specific characters are not allowed.
    When installing PHP, which web server do I need to select?

  11. #26

    Join Date
    Mar 2009
    Location
    Birmingham
    Posts
    71
    Thank Post
    26
    Thanked 8 Times in 8 Posts
    Rep Power
    12
    Heres good article on how install PHP on IIS step by step.

    Part 1
    Part 2

    He basically is setting up moodle on IIS7. Works for me.

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •