+ Post New Thread
Results 1 to 8 of 8
Web Development Thread, LDAP and Joomla 1.5.26753356785334 in Coding and Web Development; Hi, Does anyone use Joomla 1.5 and has LDAP working that they can point me in the right direction with... ...
  1. #1

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,835
    Thank Post
    24
    Thanked 91 Times in 71 Posts
    Rep Power
    50

    LDAP and Joomla 1.5.26753356785334

    Hi,

    Does anyone use Joomla 1.5 and has LDAP working that they can point me in the right direction with... the documentation isn't very good and theres loads of different theories about how to connect.... most don't distinguish between windows and novell.

    Got my smoothwall to talk happily with windows LDAP server but Joomla doesn't play nicely. No matter what setting I put in I just get a blank screen, when I log in with a user account created on Joomla it lets me in.

    A bad password also gives me a blank screen.

    Only trying 1.5 because LDAP support seems to be better... have to switch to legacy mode most of the time due to lack of new modules.

  2. #2

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,835
    Thank Post
    24
    Thanked 91 Times in 71 Posts
    Rep Power
    50
    If anyones interested, I managed to sort it out.

    First my Vertrigo installation didn't have LDAP so I got php_ldap.dll and uncommented it in php.ini

    Then I used the settings below.

    Hope this helps somone as I spent ages working it out. Now lets hope the Helpdesk Component works in 1.5

    Host IP ADDRESS
    Port 389
    LDAP V3 Yes
    Negotiate TLS No
    Do not follow referrals No
    Authorization Method Bind and Search
    Base DN CN=Users,DC=mydomain,DC=co,DC=uk
    Search String sAMAccountName=[search]
    Users DN Leave Blank

    --------------------------------------------------------------------------------

    Connect username cn=LDAPACCESS,cn=Users,DC=mydomain,DC=co,DC=uk
    Connect password password

    --------------------------------------------------------------------------------

    Map: Full Name DisplayName
    Map: E-mail mail
    Map: User ID sAMAccountName

  3. Thanks to Simcfc73 from:

    Atte (4th December 2009)

  4. #3
    mkd
    mkd is offline

    Join Date
    Mar 2008
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Thumbs down Hello , I am MKD

    I have developed a site for our Company's intranet purpose, and it is set as home page. It is built with Joomla 1.5 on wamp server. Now i want to site windows authentication using LDAP plugin. But when i am enabling it, total site is becoming blank, I have also tried with the specifications given by simcfc73 but none worked out. I will be very thankful, if any one can solve this issue.




    Thanks,
    mkd

  5. #4

    Join Date
    Mar 2009
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    LDAP Windows Server 2008 and Joomla 1.5.9

    Hello, I am having this issue and I need help. After I fill out all the information on the LDAP plugin... When a user tries to logs in... I receive a blank page. Absolutely nothing on it.

    This is the info I have:
    Host: IP ADDRESS of my windows 2008 server
    Port: 636
    LDAP v3: YES
    Negotiate TLS: NO
    Follow referals: NO
    Authorisation Methos: Bind and Search
    Base DN: ou="ad_users",dc="COMPANY",dc="com"
    Search String: sAMAccountName=[search]
    User DN: blank
    Connect Username: cn="USER",cn="Builtin",dc="COMPANY",dc="com"
    Connect Password: *****
    Map: Full Name fullName
    Map: E-mail email
    Map: User ID uid

    I dont know much about LDAP, I am using this Base DN and Port because those are used by other application and they work there. The other applications is a IM server (OpenFire)

    Thanks in advance

  6. #5
    jmair's Avatar
    Join Date
    Aug 2007
    Posts
    274
    Thank Post
    58
    Thanked 9 Times in 9 Posts
    Rep Power
    16
    I struggled with this issue and then found the greatest piece of software.

    JDiagnostic

    It's a diagnostic and easy setup wizard for joomla 1.5 and your AD.

  7. #6
    Fontayne56's Avatar
    Join Date
    Dec 2008
    Posts
    130
    Thank Post
    17
    Thanked 5 Times in 4 Posts
    Rep Power
    13

    Yes JDiagnostic is a fab package but.....

    Yes JDiagnostic is a fab package. It helped me out. I used the tools to check my settings work, and they do !!

    BUT !!

    I cant get the auto account creation working. I have checked the "User - Joomla!" plugin is enabled and has the parameter set to enable Auto account creation.

    I have run through the JDiagnostic tools and i'm being Authorised.

    When a user name a password is entered just come up with "Username and password do not match or you do not have an account yet".

    What steps can i try from here.

    HELP

    Many Thanks

  8. #7
    apeo's Avatar
    Join Date
    Sep 2005
    Location
    Lost
    Posts
    1,612
    Thank Post
    95
    Thanked 115 Times in 111 Posts
    Rep Power
    42
    Authentication - LDAP is first in the queue (order number 0), enabled and Access Level of public?

  9. 2 Thanks to apeo:

    Fontayne56 (19th June 2009), wesleyw (1st December 2011)

  10. #8

    Join Date
    Jun 2011
    Location
    Nocaragua
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi guys im trying to connect joomla 1.5.22 with active directory in windows 2008 server standar, i put the configuration in this post in my LDAP and send me and error "Please enter a valid email". This is my configuration

    Port: 636
    LDAP v3: YES
    Negotiate TLS: NO
    Follow referals: NO
    Authorisation Methos: Bind and Search
    Base DN: ou="ad_users",dc="COMPANY",dc="com"
    Search String: sAMAccountName=[search]
    User DN: blank
    Connect Username: cn="USER",cn="Builtin",dc="COMPANY",dc="com"
    Connect Password: *****
    Map: Full Name fullName
    Map: E-mail email
    Map: User ID uid

    And remove the validation of email in joomla.php but nothing still the same error, pleaseeee helpde me!

SHARE:
+ Post New Thread

Similar Threads

  1. External Joomla to internal LDAP
    By MK-2 in forum Web Development
    Replies: 5
    Last Post: 12th December 2007, 11:01 AM
  2. Apache2 & LDAP
    By jasonyates in forum How do you do....it?
    Replies: 4
    Last Post: 6th November 2007, 10:03 AM
  3. PHP and LDAP on IIS
    By srochford in forum Windows
    Replies: 2
    Last Post: 31st October 2007, 09:05 AM
  4. ldap on php
    By browolf in forum Web Development
    Replies: 11
    Last Post: 8th May 2007, 09:33 AM
  5. DNS LDAP query
    By SpuffMonkey in forum Wireless Networks
    Replies: 1
    Last Post: 5th February 2007, 04:26 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •