+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Web Development Thread, IIS & Apache with Joola install in Coding and Web Development; I'm trying to get IIS and apache with Joomla working in harmony together. So far i've got them both running ...
  1. #1
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18

    IIS & Apache with Joola install

    I'm trying to get IIS and apache with Joomla working in harmony together. So far i've got them both running but apache is on a different port. Ideally i'd like to have apache running on port 80 so have run through a document on how to disable the default "feature" of IIS listening on port 80 for all IP addresses and added a new IP address to the network card specifically for the apache server which pings fine so i know is active.

    As it stands

    1. IIS is no longer listening to port 80 on all IP addresses
    2. I have the latest WAMP installation
    3. I have installed the EduGeek Joomla package onto this with the default settings so my site is currently http://localhost:8075

    I want to change this to a more relevant name like http://cvhsintranet so thought that by changing the following would sort this out for me

    1. Edited the listen port in the httpd.conf file from "8075" to "serveripaddress:80"
    2. Edited the servername in the httpd.conf file from localhost:8075 to serveripaddress:80
    3. Add relevant DNS details to point cvhsintranet to the specified IP address
    4. Changed the hostname in the Joomla configuration.php file from "localhost" to the server IP

    This has not worked though. Can anyone tell me where i've gone wrong?

    Cheers

  2. #2

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    3,978
    Thank Post
    484
    Thanked 1,330 Times in 721 Posts
    Rep Power
    425
    What happens when you try and access the site? Do see anything at all?

  3. #3
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18
    That was a quick response!

    Taking the DNS entry part out of the equation, i am browsing to http://serveripaddress/administrator/index.php but all i get is a blank page with the text "No web site is configured at this address"

  4. #4

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,374
    Thank Post
    625
    Thanked 951 Times in 653 Posts
    Blog Entries
    2
    Rep Power
    318
    Have you restarted Apache since you changed the config files? The "No web site is configured at this address" is usually served by IIS.

  5. #5

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,215
    Thank Post
    2,766
    Thanked 935 Times in 875 Posts
    Rep Power
    343
    Quote Originally Posted by randle
    I'm trying to get IIS and apache with Joomla working in harmony together. So far i've got them both running but apache is on a different port. Ideally i'd like to have apache running on port 80 so have run through a document on how to disable the default "feature" of IIS listening on port 80 for all IP addresses and added a new IP address to the network card specifically for the apache server which pings fine so i know is active.

    As it stands

    1. IIS is no longer listening to port 80 on all IP addresses
    2. I have the latest WAMP installation
    3. I have installed the EduGeek Joomla package onto this with the default settings so my site is currently http://localhost:8075

    I want to change this to a more relevant name like http://cvhsintranet so thought that by changing the following would sort this out for me

    1. Edited the listen port in the httpd.conf file from "8075" to "serveripaddress:80"
    2. Edited the servername in the httpd.conf file from localhost:8075 to serveripaddress:80
    3. Add relevant DNS details to point cvhsintranet to the specified IP address
    4. Changed the hostname in the Joomla configuration.php file from "localhost" to the server IP

    This has not worked though. Can anyone tell me where i've gone wrong?

    Cheers
    You say that Apache is on a different port but when you are altering the httpd.conf file you are altering it from localhost:8075 to serverip:80 which im presuming puts it back to port 80 so surely you would need to change that to serverip:8075 or netbiosname:8075.

    Also when you alter DNS ( not sure if this is possible but wouldn't you need to alter it so that the cvhsintranet points to serverip:8075 or netbiosname:8075 or hostname:8075 so that it points it to the correct ip address on the correct port ?

    and also in step 4 :

    4. Changed the hostname in the Joomla configuration.php file from "localhost" to the server IP

    wouldn't you need to change it from hostname to server IP:8075

    The above is presuming you still want it on port 8075 instead of port 80

    Unless im missing something

  6. #6

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    3,978
    Thank Post
    484
    Thanked 1,330 Times in 721 Posts
    Rep Power
    425
    Am I to understand you want to run both ISS / Apache on port 80? And from what you have said above you have configured IIS to only run port 80 on a single IP address? You have then added a new IP address to the server which apache is running on?

    If you you should have 2 different ip address to access the same server eg 10.0.01 - ISS and 10.0.0.2 - Apache.

    What happens when you browse to these IP addesses via your web browser. Once can access each site via IP then you can worry about DNS.

  7. #7

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    143
    Why do you need IIS and apache on the same server?? We do have this on our web server, Apache is on port 80, and IIS on port 8080, with a reverse proxy setup through apache to display the content from IIS through apache. The only reason I have this is our website is ASP, and it's difficult to get ASP working on Apache.

    If yours is for simelar reasons, I suggest reading about reverse proxying in Apache as a potential solution.

    Mike.

  8. #8
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18
    @webman: Yes i always restart apache after every change i make

    @gecko: I used the command CSCRIPT ADSUTIL.VBS SET W3SVC/DisableSocketPooling TRUE to stop IIS from listening on port 80 for all IP adresses so thought that as long as i specify an IP address, i should be able to use port 80. I want to use this port rather than 8075.

    I'm not so bothered about DNS at the moment as i can't get the first part working yet. I just added that in my list as it's what i will need to do once it's up and running.

    I wasn't sure what needed changing in Joomla aswell as the httpd.conf file so wanted to know what i need to specify in the global configuration section. If i can get this to work on port 80 would i just need to change the hostname to serverip?

    @SYSMAN_MK: Yes you are right.

    My setup on the webserver currently is:

    Two NIC's - One for Admin network and the other for Curriculum.
    Two IP addresses each for Helpdesk and current intranet running from IIS so both can run on port 80

    I have added a third IP address for the apache server hoping i can do a similar thing!!

    I have tried browsing to the IP addresses i have for both the helpdesk and intranet but both display "No web site is configured at this address." although if i type in helpdesk or intranet they do go to the relevant sites fine.

  9. #9

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    3,978
    Thank Post
    484
    Thanked 1,330 Times in 721 Posts
    Rep Power
    425
    Humm I have the same setup so it does work.

    In you apache httpd.conf check the following

    Code:
    Listen 10.0.0.1:80
    Listen 80
    Code:
    #server config
    ServerName 10.0.0.1:80
    Where 10.0.0.1 is your new IP Adress for Apache

    Which WAMP package are you using BTW?

  10. #10
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18
    The first listen line has a # in front of it. I thought this was a comment line so haven't changed this IP address. Should i take the # out then?
    Code:
    #Listen 12.34.56.78:80
    Listen 80
    Note: I haven't added the relevant IP address on the line with the # as i thought this was just a comment

    ServerName has been set to
    Code:
    servername serverip:80
    I'm using WampServer2.0a is this an issue with this version?
    Last edited by randle; 9th January 2008 at 04:31 PM.

  11. #11

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    3,978
    Thank Post
    484
    Thanked 1,330 Times in 721 Posts
    Rep Power
    425
    Try taking out the # and using the IP address rather than the server name for now. Then see if you can browse the site via the IP address

  12. #12
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18
    I've already tried it without the # but seems to make no difference.

    This is a list of the exact things i've changed. Maybe i've changed something i shouldn't!!

    httpd.conf

    From To

    #Listen 12.34.56.78:80 Listen serverip:80
    Listen 8075 Listen 80
    ServerName localhost:8075 ServerName serverip:80

    -------------------------------------------------------------------------------------

    configuration.php

    From To

    $mosConfig_host = 'localhost' $mosConfig_host = 'serverip'
    $mosConfig_live_site = 'http://localhost:8075' $mosConfig_live_site = 'http://svrip:80'

    Is this right?

    Should i use an older version of WAMP?

  13. #13

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    3,978
    Thank Post
    484
    Thanked 1,330 Times in 721 Posts
    Rep Power
    425
    Right using the information in your previous post try the following:

    httpd.conf

    Listen serverip:80
    Listen 80

    ServerName serverip:80


    configuration.php

    $mosConfig_host = 'localhost';
    $mosConfig_live_site = 'http://serverip';

    Also make sure the following is correct is the joomla configuration.php

    $mosConfig_absolute_path = 'path/to/website/root'; (eg with apache it could be C:/apache2triad/htdocs/mysite)
    $mosConfig_cachepath = 'path/to/website/root/cache'; (eg with apache it could be C:/apache2triad/htdocs/mysite/cache)

  14. #14
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18
    Ok i've changed the files to how you say but when browsing to http://serverip/administrator/index.php i just get a page with
    No web site is configured at this address.
    As mentioned by a previous poster, this page looks like it's being served from IIS!!! I have disabled the socket pooling feature in IIS so it shouldn't be serving this IP address on port 80!!

  15. #15

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,374
    Thank Post
    625
    Thanked 951 Times in 653 Posts
    Blog Entries
    2
    Rep Power
    318
    IIS is a pain in the arse. How about this:

    Run IIS on a high port other than 80
    Use mod_proxy (Reverse proxy functionality) in Apache (on port 80) to serve the IIS content?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Changing From II6 > Apache
    By FN-GM in forum Web Development
    Replies: 6
    Last Post: 2nd December 2007, 01:00 AM
  2. Moving from Apache to IIS
    By lovelldr in forum Windows
    Replies: 7
    Last Post: 3rd August 2007, 11:51 AM
  3. Apache Permissions
    By CyberNerd in forum *nix
    Replies: 7
    Last Post: 28th April 2006, 01:20 PM
  4. Apache Question.
    By in forum Web Development
    Replies: 6
    Last Post: 27th April 2006, 09:29 AM
  5. Apache + IIS On the same box?
    By in forum Windows
    Replies: 25
    Last Post: 7th March 2006, 03:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •