IE10 uses compatibility mode by default on local intranet sites.

This breaks HTML5 video playback (test by bringing up the console via F12 and checking the "Browser Mode").

You can either modify your page headers (see here, rather than me regurgitating: IE10 renders in IE7 mode. How to force Standards mode? )

Or add a GPO setting via Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Compatibility View > Turn on Internet Explorer Standards mode for local intranet.