+ Post New Thread
Results 1 to 5 of 5
Web Development Thread, PHP version? in Coding and Web Development; Just a quick question, our host is currently using php 5.2.13 and states that it has no plans to upgrade. ...
  1. #1

    rush_tech's Avatar
    Join Date
    Jul 2006
    Location
    Nottingham
    Posts
    1,414
    Thank Post
    111
    Thanked 265 Times in 201 Posts
    Rep Power
    194

    PHP version?

    Just a quick question, our host is currently using php 5.2.13 and states that it has no plans to upgrade.
    I've been reading on php.net and I quote

    Code:
    "The PHP development team announces the immediate availability of PHP 5.4.7 and PHP 5.3.17. These releases fix over 20 bugs. All users of PHP are encouraged to upgrade to PHP 5.4.7, or at least 5.3.17."
    
    Now I'm sure that updates issued fix bugs\security issue etc should they be using at least 5.3.17?

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,216
    Thank Post
    893
    Thanked 1,773 Times in 1,529 Posts
    Blog Entries
    12
    Rep Power
    461
    I would have thoguht they would use 5.3 at least

  3. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341
    A lot of hosts are 1 or 2 versions behind, rather than using flagship versions.

  4. #4

    ZeroHour's Avatar
    Join Date
    Dec 2005
    Location
    Edinburgh, Scotland
    Posts
    5,693
    Thank Post
    948
    Thanked 1,355 Times in 828 Posts
    Blog Entries
    1
    Rep Power
    451
    I would get a new host tbh, unless they are retrofitting the patches there are issues and they could even use php safe_mode lol.
    As a rule, we upgrade generally when new builds come out but I generally go over the changelogs before patching as well.
    Php 5.3 runs faster then 2 generally and more and more php packages only support that build now. Php 5.4 is still a bit new and I know there are some compatibility issues currently so 5.3 is the best option currently.

    Also php 5.2 is no longer supported:
    http://php.net/releases/5_2_16.php
    http://php.net/releases/5_2_17.php

    They released 17 to fix a huge hole (which your not patched against)
    Last edited by ZeroHour; 8th October 2012 at 01:08 PM.

  5. Thanks to ZeroHour from:

    rush_tech (8th October 2012)

  6. #5

    rush_tech's Avatar
    Join Date
    Jul 2006
    Location
    Nottingham
    Posts
    1,414
    Thank Post
    111
    Thanked 265 Times in 201 Posts
    Rep Power
    194
    I can understand that maybe not 5.4 but surly 5.3! I have joomla installed and plugins are now moving to not working with 5.2 akeeba backup being one of them, also the phpmail function is not working since the upgrade to 2.5.7. Just to test this I took a backup and installed it on my personal host which uses 5.3.3 and the phpmail function works.

SHARE:
+ Post New Thread

Similar Threads

  1. HTML5 Version of PHP Motion
    By IKWeb in forum General Chat
    Replies: 5
    Last Post: 16th November 2011, 01:05 PM
  2. PHP version on CLEO webservers..
    By dgsmith in forum CLEO
    Replies: 9
    Last Post: 16th May 2011, 09:49 AM
  3. PHP Versions
    By frosty in forum Web Development
    Replies: 8
    Last Post: 23rd November 2010, 02:06 PM
  4. [PHP] PHP Form Generator
    By _Bat_ in forum Web Development
    Replies: 1
    Last Post: 25th March 2009, 11:39 AM
  5. updating the version of php in apache2triad
    By beeswax in forum Coding
    Replies: 10
    Last Post: 25th June 2008, 03:28 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •