+ Post New Thread
Results 1 to 15 of 15
Virtual Learning Platforms Thread, facility to moodle in Technical; i work at a secondary school and we are having an issue with this block on our moodle 2.2 installation ...
  1. #1

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5

    facility to moodle

    i work at a secondary school and we are having an issue with this block on our moodle 2.2 installation

    i can add students onto the site using the block but when it comes to adding groups to a course we cannot click on the 'ok' button. we were not sure if it was the javascript for the block so we downloaded the block again but again had no luck

    does anyone have any ideas? or can you point my in the direction of the current programmer who's looking after this block?

  2. #2

    Join Date
    Dec 2007
    Location
    Preston
    Posts
    362
    Thank Post
    14
    Thanked 84 Times in 77 Posts
    Rep Power
    30
    According to Moodle.org the maintainer is Mark Coyles - see here Moodle Plugins Directory: Facility To Moodle 2

  3. Thanks to secretlife from:

    Marci (2nd July 2012)

  4. #3
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    That would be me... what browser are you working in? What minor version of Moodle? Can't replicate the issue here using IE8 or 9 / FFox / Chrome / Safari...
    Last edited by Marci; 2nd July 2012 at 03:55 PM.

  5. #4

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5
    i have managed to solve the issue now, by creating the directory 'C:\inetpub\wwwroot\blocks\course_creator_admin\js ' and adding the 'mochikit_essentials-min.js' into this directory.
    we had the problem on IE9, Chrome, Firefox and Safari.
    we are still unsure as to why this folder is needed for this file as it is already located in the facility to moodle js folder, any ideas? as when we go to add in new blocks or modules i have to remove it and add it back in each time :/

    also while i have you here, are you also the maintainer for the Network Drive access (SMBWebClient fork)? is there any way of setting this up for windows? we are currently struggling
    we are running Moodle 2.2, on windows 2008 r2 using IIS and MYSQL.

  6. Thanks to cyberrant from:

    Marci (2nd July 2012)

  7. #5

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5
    thats moodle 2.2.2+

  8. Thanks to cyberrant from:

    Marci (2nd July 2012)

  9. #6
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    I'll have a ratch thru the source tomorrow and see if I can spot anything, but not getting that issue here. Do you have the course_creator_admin block installed? If not it'll be a mistake in the source somewhere pointing to the wrong location... *oops*

  10. #7
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    And yes to the second query, however I don't have a windows test environment... Will see what I can do.

  11. #8

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5
    nope :/ no installed. but i added in the file structure and the .js file and it seems to be working now. just causing me an issue when i go to add anything else to the site. thanks for the help i will go through my site's coding and see if i can find where the location is being forwarded in from

  12. Thanks to cyberrant from:

    Marci (2nd July 2012)

  13. #9
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    Heh - definitely my fault then somewhere... Just do a find for course_creator_admin on the facility_to_moodle folder in Dreamweaver or similar and correct the path back to the right one. I'll sort it on the plugin database tomorrow.

  14. #10

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5
    cheers for the help and if you get anywhere with Network Drive access please let me know

  15. #11
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    Line 205 of block_facility_to_moodle.php is the one that needed correcting... (new version is available on the Moodle Plugins Database - corrected a few other issues also, so recommend just downloading this new version and overwriting the old).

    Have just msg'd you regarding Network Drive Access issue.
    Last edited by Marci; 3rd July 2012 at 09:10 AM.

  16. #12

    Join Date
    May 2007
    Location
    Southampton
    Posts
    93
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    15
    Just wondering, is the parent view block being updated to work with Moodle 2? Right now that is about the only thing keeping us from upgrading our setup

  17. #13

    Join Date
    Jul 2012
    Location
    lincolnshire
    Posts
    23
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    5
    thats great, and i see that you've updated it for 2.3, that may come in handy depending on when we move for progesso, cheers

    i do have one more question though - the helpdesk block : Moodle.org: Old modules and plugins

    is there any chance you can help me with updating the code of it for moodle 2.2 or 2.3? as it is the last block i need for my current site?

  18. #14
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    885
    Thank Post
    84
    Thanked 233 Times in 192 Posts
    Rep Power
    82
    Just wondering, is the parent view block being updated to work with Moodle 2? Right now that is about the only thing keeping us from upgrading our setup
    Eh? It already has been... Moodle Plugins Directory: Parental Portal

    is there any chance you can help me with updating the code of it for moodle 2.2 or 2.3? as it is the last block i need for my current site?
    Afraid not... just don't have the time to take on any more rewrites outside of my day job.
    Last edited by Marci; 3rd July 2012 at 01:12 PM.

  19. Thanks to Marci from:

    nutso (4th July 2012)

  20. #15

    Join Date
    May 2007
    Location
    Southampton
    Posts
    93
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    15
    [QUOTE=Marci;848542]Eh? It already has been... Moodle Plugins Directory: Parental Portal

    Oops, sorry! I hadn't seen a mention of it and the Facility to Moodle listing on moodle.org still says about alpha version available on request so I wasn't expecting to see it there. Thanks for your work!

SHARE:
+ Post New Thread

Similar Threads

  1. Odd Facility to Moodle integration issue
    By tonyd in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 10th October 2011, 11:59 AM
  2. Facility to Moodle Integration Block
    By ceebster in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 28th June 2011, 04:03 PM
  3. Save straight to Moodle from Office!
    By Ric_ in forum Virtual Learning Platforms
    Replies: 7
    Last Post: 10th May 2010, 11:57 AM
  4. Connect to Moodle with File DSN
    By themaverickman in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 9th July 2007, 02:47 PM
  5. Moodle or not to Moodle
    By alan-d in forum Web Development
    Replies: 5
    Last Post: 20th January 2006, 11:56 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •