+ Post New Thread
Results 1 to 3 of 3
Virtual Learning Platforms Thread, Moodle - slow upload of files in Technical; Hello all I was wondering whether you could help me with something? My Moodle box is an IIS7 server with ...
  1. #1
    rh91uk's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Posts
    876
    Thank Post
    137
    Thanked 132 Times in 114 Posts
    Rep Power
    35

    Moodle - slow upload of files

    Hello all

    I was wondering whether you could help me with something? My Moodle box is an IIS7 server with 64gb of RAM and 24 cores running 2k8r2!

    We have just moved this over and all the moodledata files seem to be in tact! However on some coursres which have a lot of data in, the "add a resource" file window takes forever to come up/files to upload, however course with hardly any data in is fine.

    Link to the storage array which holds all Moodle data and mySQL data is not a problem either, with a 10gb link and all other websites load fine.

    Any assistance would be appreciated

    Kind regards

    Richard

  2. #2


    Join Date
    Dec 2005
    Location
    In the server room, with the lead pipe.
    Posts
    4,630
    Thank Post
    275
    Thanked 777 Times in 604 Posts
    Rep Power
    223
    Quote Originally Posted by rh91uk View Post
    My Moodle box is an IIS7 server
    Quote Originally Posted by rh91uk View Post
    an IIS7 server
    Quote Originally Posted by rh91uk View Post
    IIS7
    (I'm kidding)

    Have you gone through and checked the links to migrated resources are all valid (and file permissions are correct). It sounds like it's trying to resolve something and eventually timing out.

    For example, in a course that you know is slow, go through all linked content and check it's properly linked and accessible.

    Also, use Chrome's Inspect Element (from Right-Click menu) and then the network tab to work out which parts are slow:

    Screen shot 2012-01-19 at 10.35.25.pngScreen shot 2012-01-19 at 10.35.25.png

  3. #3

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,802
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    Could be a PHP error (my moodle took ages to fix all of them).

    Have you checked the PHP error logs?

    Plus IIS7 doesn't help

SHARE:
+ Post New Thread

Similar Threads

  1. Uploading a file is very slow
    By gianzack in forum Home Access Plus+
    Replies: 3
    Last Post: 7th December 2011, 10:22 AM
  2. Moodle Not Uploading Files
    By flexyjerkov in forum Windows
    Replies: 3
    Last Post: 1st March 2010, 12:53 PM
  3. Student uploading of files from client to server
    By gdoyle in forum Windows Server 2000/2003
    Replies: 7
    Last Post: 5th January 2010, 05:10 PM
  4. Rename a batch of files all at once.
    By Kyle in forum How do you do....it?
    Replies: 10
    Last Post: 19th November 2009, 06:31 AM
  5. Replies: 4
    Last Post: 15th November 2006, 03:19 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •