Every time I try to install Moodle under Lighttpd/PHP5/MySQL on Linux I get the error:

Code:
Setting up of database session failed.

Please notify server administrator.
I have also tried installing on another machine and migrating to the *nix box but no luck. This was with Moodle 2.1.1+ and 2.1.1.

Any ideas what could be the cause of this?

Cheers