+ Post New Thread
Results 1 to 2 of 2
Virtual Learning Platforms Thread, Moodle 2.1 LDAP enrolment error in Technical; Please save me from tearing my hair out! We have a Moodle set up, which was running version 2.0.3 on ...
  1. #1

    Join Date
    Jan 2011
    Location
    Sheffield
    Posts
    10
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Moodle 2.1 LDAP enrolment error

    Please save me from tearing my hair out!
    We have a Moodle set up, which was running version 2.0.3 on Win2008r2SP1 with IIS and SQL.
    We have been using LDAP authentication and enrollment fine (using samaccountname as the userID).
    Part of the summer work was to upgrade to version 2.1.1 and implement HTTPS, which both went fine.

    Now it seems that LDAP Enrolment has been broken.
    Authentication still works, and enrolment works if I run the CLI PHP sync script.
    But it does not run on log in!
    Or perhaps rather it does run, but incorrectly, as I have it set to unenrol users from a course if they are removed from the AD groups. What happens in that case is that when a user logs in they are unenrolled from all their courses if they were enrolled in them via LDAP. (perhaps it sees the groups but believes they are not in it?)

    I've rolled back the version of Moodle and undone all the changes made, but its still broken, nothing has changed with AD etc and I've triple checked all the settings in Moodle.
    Thoughts or ideas would be appreciated!

  2. #2

    Join Date
    Feb 2013
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hey climo,

    Did you ever fix this issue?

    Having exactly the same issue on 2.5 (latest from git)



SHARE:
+ Post New Thread

Similar Threads

  1. [Moodle] Course creator LDAP user group
    By FN-GM in forum Virtual Learning Platforms
    Replies: 14
    Last Post: 4th May 2012, 03:10 PM
  2. moodle ldap default values if not set by AD
    By russdev in forum Virtual Learning Platforms
    Replies: 12
    Last Post: 8th June 2010, 12:46 PM
  3. Moodle and Secure LDAP?
    By gshaw in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 13th June 2009, 12:11 AM
  4. Moodle Error log for LDAP integration
    By apearce in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 19th November 2008, 01:36 PM
  5. Moodle LDAP Enrolment
    By Mike_R in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 6th December 2006, 03:33 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •