+ Post New Thread
Results 1 to 10 of 10
Virtual Learning Platforms Thread, Moodle - a required parameter (id) is missing in Technical; Moodle 1.7, and material provided by NWGfL (GCSE English Online, especially for 1.7). When I try to restore a course ...
  1. #1

    beeswax's Avatar
    Join Date
    Jul 2005
    Location
    England
    Posts
    2,284
    Thank Post
    285
    Thanked 225 Times in 153 Posts
    Rep Power
    130

    Moodle - a required parameter (id) is missing

    Moodle 1.7, and material provided by NWGfL (GCSE English Online, especially for 1.7). When I try to restore a course from this CD Rom I get the above message. To be honest, the Moodle.org site doesn't help here. Anyone here encountered this problem?
    I get the impression that v.1.8 will smooth out a lot of the problems with 1.7.

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,800
    Thank Post
    110
    Thanked 582 Times in 503 Posts
    Blog Entries
    1
    Rep Power
    223

    Re: Moodle - a required parameter (id) is missing

    Are you sure these backups were done with 1.7?

  3. #3

    beeswax's Avatar
    Join Date
    Jul 2005
    Location
    England
    Posts
    2,284
    Thank Post
    285
    Thanked 225 Times in 153 Posts
    Rep Power
    130

    Re: Moodle - a required parameter (id) is missing

    When I called asking for the material, they asked me which version of Moodle I had so that they could package it correctly.
    I wonder if I'm doing something wrong in trying to restore these files as if from backup? It's the way I did it with 1.5.

  4. #4

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,800
    Thank Post
    110
    Thanked 582 Times in 503 Posts
    Blog Entries
    1
    Rep Power
    223

    Re: Moodle - a required parameter (id) is missing

    Perhaps they are SCORM Modules?

  5. #5
    daveyboy's Avatar
    Join Date
    Jun 2005
    Location
    Bath / Bristol
    Posts
    271
    Thank Post
    37
    Thanked 18 Times in 16 Posts
    Rep Power
    21

    Re: Moodle - a required parameter (id) is missing

    How big is the file you are trying to restore?

    I seem to remember a limit somewhere.

  6. #6

    beeswax's Avatar
    Join Date
    Jul 2005
    Location
    England
    Posts
    2,284
    Thank Post
    285
    Thanked 225 Times in 153 Posts
    Rep Power
    130

    Re: Moodle - a required parameter (id) is missing

    I'm going to have tyo get back to you on this as I'm at home now.

  7. #7
    daveyboy's Avatar
    Join Date
    Jun 2005
    Location
    Bath / Bristol
    Posts
    271
    Thank Post
    37
    Thanked 18 Times in 16 Posts
    Rep Power
    21

    Re: Moodle - a required parameter (id) is missing

    Maybe this is whats causing your problem: -







    Maybe - if you are trying to restore a file larger than 2MB.
    As I recall, I SSH'ed the file into the correct folder on the server and it went through okay.

    But - Thats a maybe.
    Attached Images Attached Images

  8. #8

    beeswax's Avatar
    Join Date
    Jul 2005
    Location
    England
    Posts
    2,284
    Thank Post
    285
    Thanked 225 Times in 153 Posts
    Rep Power
    130

    Re: Moodle - a required parameter (id) is missing

    they are scorm modules (1.3 2004) - one of the packages is 61.7Mb as well. I'll have to do a different search.

  9. #9

    beeswax's Avatar
    Join Date
    Jul 2005
    Location
    England
    Posts
    2,284
    Thank Post
    285
    Thanked 225 Times in 153 Posts
    Rep Power
    130

    Re: Moodle - a required parameter (id) is missing

    after a lot of heaving and puffing I've finally managed to get the content sorted.
    I had to go to the server with the cd rom and copy it to the site that way. Then I had to create a course, then under the Format section, where it has a dropdown with Social, Weekly, Topic formats and more I chose the Scorm format. After Saving Changes, I added myself as Admin (Moodle 1.7 takes you this route automatically). Then it allowed me to continue to actually add the Scorm material. I was making a fundamental mistake at this point after the coursework had been located. I was choosing Unzip, rather than Choose to upload and unzip the content. You only do that when you're restoring from backup.
    It's still not fully working, icons are missing, but that's a minor gripe and I've emailed the company who produced the cd rom asking where they are.
    thanks for all the help chaps, it did help me find a solution.
    By the way, the documentation for uploading scorm content can be found with the Scorm module in the Modules section of the Moodle site. I couldn't find any other clear documentation by doing a search.

  10. #10
    daveyboy's Avatar
    Join Date
    Jun 2005
    Location
    Bath / Bristol
    Posts
    271
    Thank Post
    37
    Thanked 18 Times in 16 Posts
    Rep Power
    21

    Re: Moodle - a required parameter (id) is missing


SHARE:
+ Post New Thread

Similar Threads

  1. Missing Wiki articles
    By contink in forum Comments and Suggestions
    Replies: 5
    Last Post: 15th January 2008, 08:54 PM
  2. missing apostrophe
    By beeswax in forum Comments and Suggestions
    Replies: 0
    Last Post: 7th January 2008, 05:52 AM
  3. Moodle Evangelist Required
    By GrumbleDook in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 16th January 2007, 09:45 PM
  4. Missing Netlogon Service
    By BKGarry in forum Windows
    Replies: 0
    Last Post: 30th June 2006, 09:42 AM
  5. What am I missing now?
    By indiegirl in forum ICT KS3 SATS Tests
    Replies: 16
    Last Post: 30th March 2006, 03:40 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •