+ Post New Thread
Results 1 to 5 of 5
Virtual Learning Platforms Thread, issue with themes after moodle 2.0 upgrade in Technical; Upgraded to 2.0 from 1.9. Users had already applied custom themes to their own courses. If they are given the ...
  1. #1

    Join Date
    Jan 2011
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    issue with themes after moodle 2.0 upgrade

    Upgraded to 2.0 from 1.9. Users had already applied custom themes to their own courses. If they are given the ability to change the course theme, it shows up with no theme applied and no way to change it. gives error of "Coding error detected, it must be fixed by a programmer: Default theme standard not available or broken!"

    If the ability to change course theme is denied - generic site theme applies to all courses.



    what is the best way to get around this? thanks

  2. #2

    Join Date
    Dec 2007
    Location
    Preston
    Posts
    369
    Thank Post
    14
    Thanked 86 Times in 79 Posts
    Rep Power
    31
    Moodle 1.9 themes don't work in Moodle 2.0 - end of. If you've upgraded you should be set with the "standard" theme as any customised ones you have on your Moodle will need upgrading to 2.0 before they will display properly.

  3. #3

    Join Date
    Jan 2011
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    thanks for your reply. i guess our biggest hurdle with the themes - if we have it where the users can change their course themes - then no theme is applied to the page and there is no place to change it that I can find. if we deny that access - the standard moodle site-wide theme is applied.

  4. #4

    GrumbleDook's Avatar
    Join Date
    Jul 2005
    Location
    Gosport, Hampshire
    Posts
    10,074
    Thank Post
    1,384
    Thanked 1,889 Times in 1,170 Posts
    Blog Entries
    19
    Rep Power
    614
    Custom themes are generally broken in Moodle 2.0 ... I had a fantastic thanks to Dan H but it just didn't take. There are new guides to creating themes which I would recommend people have a look at before upgrading. There may also be issues with modules you have used in certain courses so I would always test it thoroughly on a test bed first.

  5. #5
    gshaw's Avatar
    Join Date
    Sep 2007
    Location
    Essex
    Posts
    2,726
    Thank Post
    176
    Thanked 229 Times in 211 Posts
    Rep Power
    69
    Moodle 2.0 is a big upgrade and needs to be planned for appropriately. As well as the themes and custom modules (especially book as that's not in 2.0 yet) you might find that files in your courses aren't showing after you upgrade. There also seems to be a few bugs with the file picker from what I've read so unless you have a burning need to get to 2.0 I'd leave it until summer and try to start with a fresh install if possible...



SHARE:
+ Post New Thread

Similar Threads

  1. Clicker 5 upgrade issue
    By Little-Miss in forum Educational Software
    Replies: 18
    Last Post: 22nd September 2010, 12:51 PM
  2. Moodle 1.9.9 upgrade nightmare
    By palmer_eldritch in forum Virtual Learning Platforms
    Replies: 11
    Last Post: 10th August 2010, 08:52 PM
  3. Moodle Themes
    By apoth0r in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 9th March 2010, 04:47 PM
  4. Moodle Themes
    By danIT in forum Virtual Learning Platforms
    Replies: 10
    Last Post: 16th March 2009, 01:08 PM
  5. How flexible is moodle for creating themes?
    By HodgeHi in forum EduGeek Moodle
    Replies: 2
    Last Post: 23rd February 2009, 07:44 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •