+ Post New Thread
Results 1 to 6 of 6
Virtual Learning Platforms Thread, Moodle Windows Share Web Client in Technical; Hi I am having difficulty getting the smb windows share web client working. It shows a blank window. I enabled ...
  1. #1

    Join Date
    Feb 2008
    Posts
    345
    Thank Post
    52
    Thanked 4 Times in 3 Posts
    Rep Power
    14

    Moodle Windows Share Web Client

    Hi I am having difficulty getting the smb windows share web client working. It shows a blank window. I enabled debugging and get errors

    Deprecated: Function split() is deprecated in /var/www/blocks/smb_web_client/class_smbwebclient.php on line 251 Deprecated: Function split() is deprecated in /var/www/blocks/smb_web_client/class_smbwebclient.php on line 252 Deprecated: Function split() is deprecated in /var/www/blocks/smb_web_client/class_smbwebclient.php on line 252 Deprecated: Function split() is deprecated in

    Please can anybody help?


    Thanks

  2. #2

    Join Date
    Nov 2009
    Location
    Manchester
    Posts
    1,114
    Thank Post
    6
    Thanked 221 Times in 200 Posts
    Rep Power
    56
    Have you been on the moodle page for the plugin and read a lot of the posts, there are alot of fixes and tweaks there that may not have been updated in the latest download.

    Are you using SSL? If not is the SMB web client told not to use SSL? I think that causes blank windows.

  3. #3

    Join Date
    Feb 2008
    Posts
    345
    Thank Post
    52
    Thanked 4 Times in 3 Posts
    Rep Power
    14
    Hi Yes been on the moodle site. I am not running ssl, I have changed this in the config file and still no joy.

    Thanks

  4. #4

    Join Date
    Nov 2009
    Location
    Manchester
    Posts
    1,114
    Thank Post
    6
    Thanked 221 Times in 200 Posts
    Rep Power
    56
    What are your running your server on?

    Also what version of PHP are you using?

    Im running PHP 5.2 and the split function is apparently removed in 5.3 and above, whether this would stop it working I couldnt be sure, an idea though.
    Last edited by Achandler; 16th September 2010 at 12:45 PM. Reason: Extra researched done!

  5. #5

    Join Date
    Feb 2008
    Posts
    345
    Thank Post
    52
    Thanked 4 Times in 3 Posts
    Rep Power
    14
    Hi Ubuntu 10.04 php, I am running php5.

    Thanks for your help

  6. #6

    Join Date
    Nov 2009
    Location
    Manchester
    Posts
    1,114
    Thank Post
    6
    Thanked 221 Times in 200 Posts
    Rep Power
    56
    Which version of PHP 5? On the moodle server you can check under Site Administration --> Server --> PHP Info

    I've looked into it a little more to, on the moodle plugin area, Jon Witts posts this:


    "OK... So some progress...

    The problem is with PHP 5.3 not Ubuntu 10.04 specifically.

    I have added the changes from the patch on smbwebclient's sourceforge page and things seem to be working again. We had to edit class_smbwebclient.php and class_smbwebclient_moodle.php to get the depreciated errors to clear. We are still left with a warning for line 171 of class_smbwebclient_moodle.php though.

    We have had to set the authentication method to SMB_AUTH_ARG in config_smb_web_client.php

    If we use domain level DFS shares for the home drives; make sure you use FQDN for your DFS share name in LDAP.

    I will email Guy the changed files so that he can get them added to a newer version."



    Although not totally related, he changing the fucntion with the class file to remove the defunct errors. It would appear the client is in need of some work for 5.3. If it helps you I believe that you need to use either preg_split or explode in place of the split function within the php file.
    Last edited by Achandler; 16th September 2010 at 12:54 PM.



SHARE:
+ Post New Thread

Similar Threads

  1. Moodle SMB Web Client
    By Hightower in forum Virtual Learning Platforms
    Replies: 15
    Last Post: 21st July 2010, 11:55 AM
  2. Moodle & SMB Web Client Problem
    By Marc in forum Virtual Learning Platforms
    Replies: 28
    Last Post: 23rd November 2009, 12:16 PM
  3. Moodle: SMB Web Client Issues
    By tdibb in forum Virtual Learning Platforms
    Replies: 10
    Last Post: 29th July 2009, 01:19 PM
  4. Moodle: SMB Web Client - HTTPS...
    By fabled-aesop in forum Virtual Learning Platforms
    Replies: 14
    Last Post: 17th March 2009, 05:27 PM
  5. Moodle & Windows Share Web Client
    By clodhopper in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 12th March 2009, 11:43 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •