+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
Virtual Learning Platforms Thread, How to increase file upload size on Moodle - Server 2008 in Technical; I know that there have been some threads mentioning this, but I am keen to know specifically how to do ...
  1. #1

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755

    How to increase file upload size on Moodle - Server 2008

    I know that there have been some threads mentioning this, but I am keen to know specifically how to do this on Server 2008R2. The Moodle FAQs only mention it for IIS, but surely if the rest of it, that they have titled '"XP and Server 2003" applied to Server2008 it would say so?
    Bit worried about breaking it

  2. #2
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    you need to alter the php.ini file

    Code:
    post_max_size = 1024M
    upload_max_filesize = 1024M
    that should do it - as far as i know it is not server specific

    you will need to restart iis after the change

    HTH

    Mark

  3. #3

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Is that really all? Because the FAQs seem to mention a lot more than that
    We have done that but cant upload big files - could anything else be stopping it?

  4. #4
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    You will need to change your 'Maximum uploaded file size' in moodle also

    Administration > Security > Site policies

    Ours is currently set at server limit

    HTH

    Mark

  5. #5

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Quote Originally Posted by sister_annex View Post
    You will need to change your 'Maximum uploaded file size' in moodle also

    Administration > Security > Site policies

    Ours is currently set at server limit

    HTH

    Mark
    Ours is set as that as well. It is a server issue? Can I increase the server upload allowance and if so, where?

  6. #6
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    Server limit pulls the info from the php.ini file. AFAIK that should be it and works fine for us here.

    It may be a course setting - that also has the ability to restrict file upload sizes.

    There is a course upload limit (default).

    Administration > Courses > Course Default Settings

    Is it a WAMP setup or do you use IIS?

    Mark

  7. #7

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Note to self: DON'T listen to teachers! I was informed that the error mentioned file size...it doesnt..
    The error, when I was finally told it, is more likely to be a timeout.
    I have increased the timeout to 900 seconds and will now go away and see if it works.
    Thanks

  8. #8
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    haha, typical!

    No Problems - it may help someone else in the future

    Mark

  9. #9

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Spoke too soon - still doesnt work but now getting at 404 error
    Any ideas?

  10. #10
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    hmmmm 404 is usually File or Site not Found...

    I am presuming that it has been working fine up until this point or is this a test case?

    Timeouts tend to happen on large files usually >1Gb

    Have you checked file permissions on the directory that contains your moodledata?

    I am struggling at this point. Sorry

  11. #11

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    situation as follows:
    Uploads of 24MB or above are getting the 404 error. Anything less than this is fine, which is why it was thought to be a file size error.
    I have increased the file size and the timeout with no success
    any ideas?

  12. #12
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    603
    Thank Post
    101
    Thanked 141 Times in 122 Posts
    Rep Power
    51
    hmmm, tbh not really sure, and the box of straws that i'm clutching at are getting thin on the ground!

    the only things I can thing of is possibly Quotas(maybe), if it is IIS that you're running i dont think there are file size restrictions, if it is Apache there may well be but i know very little about apache. other than that I really dont know.

    A quick google come up with this, but not sure how helpful it would be - but it seems to be similar to the error you are getting
    http://moodle.org/mod/forum/discuss.php?d=144597

    sorry I cant be of more help

    Mark

  13. #13

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Found this:
    Adjusting File Size Limit in IIS 7

    The problem is that in IIS 7 on Windows 2008 Server, the web application will reject any file that is larger than 30 MB. This is a default limitation of IIS. You can increase the maximum file size by adding the following code to <system.webServer> in the web.config file:

    <security>
    <requestFiltering>
    <requestLimits maxAllowedContentLength=”2000000000″ />
    </requestFiltering>
    </security>

    Does anyone think this will work, and if so, where do I find the file to alter?

  14. #14

    witch's Avatar
    Join Date
    Nov 2005
    Location
    Dorset
    Posts
    11,209
    Thank Post
    1,454
    Thanked 2,515 Times in 1,752 Posts
    Rep Power
    755
    Can anyone help me? Or am I ..

  15. #15

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,250
    Thank Post
    404
    Thanked 630 Times in 575 Posts
    Rep Power
    185
    Quote Originally Posted by witch View Post
    Found this:
    Adjusting File Size Limit in IIS 7

    The problem is that in IIS 7 on Windows 2008 Server, the web application will reject any file that is larger than 30 MB. This is a default limitation of IIS. You can increase the maximum file size by adding the following code to <system.webServer> in the web.config file:

    <security>
    <requestFiltering>
    <requestLimits maxAllowedContentLength=”2000000000″ />
    </requestFiltering>
    </security>

    Does anyone think this will work, and if so, where do I find the file to alter?
    Web.config is usually for ASP applications.

    Found this on Moodle.

    Modifying the IIS 7.0/7.5 configuration (Windows Server 2008, Windows Server 2008 R2)

    First increase activity and request time outs (allows large files to succeed on slow connections)
    FastCGI Settings > Edit (Right-click on PHP application)
    Set Process Model > Activity Timeout to '3600' (one hour)
    Set Process Model > Request Timeout to '3600' (one hour)Next set 'Maximum allowed content length'

    Request Filtering > Edit Feature Settings:
    Set 'Maximum allowed content length' to your desired file size (in bytes) e.g. '536870912' for 512MB (default is approximately 28.6MB)

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Moodle / Server 2008 / IIS7 / MS SQL Server 2008 Express
    By Kamran7860 in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 23rd November 2010, 06:03 AM
  2. Maximum Zip file size in Moodle?
    By bensewell in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 27th July 2010, 10:47 AM
  3. [Gentoo] Virtualbox increase HD size
    By RabbieBurns in forum *nix
    Replies: 4
    Last Post: 19th March 2010, 02:09 AM
  4. Moodle SMB Web client 0 byte file size issue
    By mwnci in forum Virtual Learning Platforms
    Replies: 7
    Last Post: 25th February 2010, 09:06 AM
  5. Moodle file upload limit
    By Wildebeaste in forum Educational Software
    Replies: 5
    Last Post: 24th September 2007, 01:54 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •