+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
Virtual Learning Platforms Thread, Moodle & LDAP in Technical; Guys Have moodle running on Ubuntu Server - using LAMP. Managed to bind AD to moodle using LDAP. Running the ...
  1. #1
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Moodle & LDAP

    Guys

    Have moodle running on Ubuntu Server - using LAMP.

    Managed to bind AD to moodle using LDAP.

    Running the script auth_ldap_sync_users.php to import users.

    I get the following error, but struggling to find and answers

    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    Configuring temp table
    Creating temp table mdl_extuser
    Connecting to ldap...
    Did not get any users from LDAP -- error? -- exiting

    Just wondered if you guys can help?

    Thanks


    Chris

  2. #2
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Right

    Got rid of that error by examing the file listed - just removed the #

    now just have this

    Configuring temp table
    Creating temp table mdl_extuser
    Connecting to ldap...
    Did not get any users from LDAP -- error? -- exiting

    is this because Moodle can't find my users?


    Thanks


    Chris

  3. #3
    clarky2k3's Avatar
    Join Date
    Nov 2007
    Location
    Northumberland
    Posts
    317
    Thank Post
    35
    Thanked 47 Times in 39 Posts
    Rep Power
    24
    Have you installed and enabled the php extension php_ldap?

  4. #4
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    572
    Thank Post
    98
    Thanked 126 Times in 111 Posts
    Rep Power
    46
    can you login with an LDAP account without running the file??

  5. #5
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by clarky2k3 View Post
    Have you installed and enabled the php extension php_ldap?
    i thought i had - i have run phpinfo.php -

    /etc/php5/apache2/conf.d/ldap.ini - this is listed in the Additional .ini files parsed

    is this correct?

  6. #6
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by sister_annex View Post
    can you login with an LDAP account without running the file??
    no - so that makes me think back to clarky2k3 post about enabling the php extension

  7. #7
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    572
    Thank Post
    98
    Thanked 126 Times in 111 Posts
    Rep Power
    46
    in your php.ini you need to uncomment the php_ldap extension then restart apache (unless you have already done this)

    to check goto http://<yourmoodlesite>/admin/phpinfo.php then do a find for ldap and see if a) it is listed and b) the top row states enabled

  8. Thanks to sister_annex from:

    ceebster (25th June 2010)

  9. #8
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks sister_annex

    Would there me a reason why that php_ldap extension is missing from my PHP.ini file.

    There is only one of these files on my server and that is in /etc/php5/apache2/

    Thanks

    Chris

  10. #9
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    found this in my php.ini

    ldap
    LDAP Support enabled
    RCS Version $Id: ldap.c 293036 2010-01-03 09:23:27Z sebastian $
    Total Links 0/unlimited
    API Version 3001
    Vendor Name OpenLDAP
    Vendor Version 20421
    SASL Support Enabled

  11. #10
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    572
    Thank Post
    98
    Thanked 126 Times in 111 Posts
    Rep Power
    46
    OK LDAP is enabled by the looks of it,

    when you try to login to your moodle site (with an LDAP account) do you get an error and if so could you paste it here??

  12. #11
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Silly question coming up - i assume it would be one of my users that have put into the specific OU that i have added to the LDAP file config

    or

    Any AD user?


    Chris

  13. #12
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    572
    Thank Post
    98
    Thanked 126 Times in 111 Posts
    Rep Power
    46
    how have you setup your moodle LDAP Auth settings??

  14. #13
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    is there a config file i can post - showing you my settings? if so not sure of the location

  15. #14
    ceebster's Avatar
    Join Date
    May 2009
    Location
    The World
    Posts
    103
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0

  16. #15
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    572
    Thank Post
    98
    Thanked 126 Times in 111 Posts
    Rep Power
    46

    Post Try This....

    Try the settings in here just replace the relevant ones

    for MSAD use the IP address of the LDAP Server also take note of the settings further down

    on a windows computer do a run ldp.exe (from runn command) this should help with getting the distinguished names of the locations you want
    Attached Files Attached Files

  17. Thanks to sister_annex from:

    Tricky_Dicky (1st February 2011)

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Moodle & ldap enrollment
    By Oops_my_bad in forum Virtual Learning Platforms
    Replies: 9
    Last Post: 1st February 2010, 07:10 PM
  2. Moodle Ldap Help
    By acerf1 in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 30th November 2009, 11:58 AM
  3. Moodle & LDAP, What a nightmare!
    By SkreeM1980 in forum Virtual Learning Platforms
    Replies: 5
    Last Post: 23rd January 2009, 01:28 PM
  4. Moodle and LDAP
    By ahunter in forum Virtual Learning Platforms
    Replies: 6
    Last Post: 31st October 2008, 11:12 AM
  5. Moodle LDAP
    By zag in forum Virtual Learning Platforms
    Replies: 6
    Last Post: 17th July 2008, 10:12 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •