+ Post New Thread
Results 1 to 8 of 8
Virtual Learning Platforms Thread, Moodle Fatal Error in Technical; Hello folks, I'm having problems with an installation of Moodle (created from a backup of the database and moodledata). When ...
  1. #1
    Wildebeaste's Avatar
    Join Date
    Oct 2006
    Location
    Nottinghamshire
    Posts
    64
    Thank Post
    12
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Moodle Fatal Error

    Hello folks,

    I'm having problems with an installation of Moodle (created from a backup of the database and moodledata).

    When any user logs on, they are met with a blank page. Nothing at all - page source is also empty. If they then use the browser 'back' button and click on the 'Portal' crumb on the top-left they are in and Moodle works fine.

    I've turned the debugging on, and there are several errors, with this bringing up the rear:

    Fatal error: Cannot access empty property in .../moodle/enrol/database/enrol.php on line 42

    Can anyone suggest a solution? There are several pages on the Interweb referring to this but no solution that I can find.

    Thanks.

  2. #2

    rush_tech's Avatar
    Join Date
    Jul 2006
    Location
    Nottingham
    Posts
    1,386
    Thank Post
    109
    Thanked 261 Times in 197 Posts
    Rep Power
    192
    Anyone got any idea?

  3. #3
    paulgarratt83's Avatar
    Join Date
    Feb 2009
    Posts
    37
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    12
    Having checked the enrol.php file it might have something to do with roles. Do you still have the old moodle running. If so copy the enrol.php. Otherwise did you have another type of enrolment turned on.

    Only other thing I can think of it that there was another type of role created on the old version i.e. student2 and that it is trying to apply the settings to the user but can't find it.

    Hope this helps

  4. Thanks to paulgarratt83 from:

    rush_tech (2nd March 2010)

  5. #4

    Join Date
    Dec 2007
    Location
    Preston
    Posts
    359
    Thank Post
    14
    Thanked 82 Times in 75 Posts
    Rep Power
    29
    Did you by any chance switch on "external database" in site admin>courses>enrolments? This can bring up this error if it's enabled but not configured.

  6. Thanks to secretlife from:

    rush_tech (2nd March 2010)

  7. #5

    Join Date
    Mar 2010
    Location
    Dover
    Posts
    11
    Thank Post
    0
    Thanked 4 Times in 4 Posts
    Rep Power
    9

    Check the file permissions

    It would be worth checking the file permissions. Is your moodle hosted on Linux?

  8. Thanks to nathanfriend from:

    rush_tech (2nd March 2010)

  9. #6

    rush_tech's Avatar
    Join Date
    Jul 2006
    Location
    Nottingham
    Posts
    1,386
    Thank Post
    109
    Thanked 261 Times in 197 Posts
    Rep Power
    192
    Cheers for the replies guys I'll take a look at those when I get a chance

  10. #7

    rush_tech's Avatar
    Join Date
    Jul 2006
    Location
    Nottingham
    Posts
    1,386
    Thank Post
    109
    Thanked 261 Times in 197 Posts
    Rep Power
    192
    Quote Originally Posted by secretlife View Post
    Did you by any chance switch on "external database" in site admin>courses>enrolments? This can bring up this error if it's enabled but not configured.
    Your a star that did the trick unticked the external database(which wasn't configured) all OK now

  11. #8

    Join Date
    Dec 2007
    Location
    Preston
    Posts
    359
    Thank Post
    14
    Thanked 82 Times in 75 Posts
    Rep Power
    29
    oh thanks Glad it's sorted.

SHARE:
+ Post New Thread

Similar Threads

  1. C000021a {FATAL SYSTEM ERROR}
    By russdev in forum Windows 7
    Replies: 10
    Last Post: 3rd May 2009, 11:07 AM
  2. Replies: 0
    Last Post: 10th October 2008, 12:10 PM
  3. Moodle - undefined variable error
    By damienharrison in forum Virtual Learning Platforms
    Replies: 5
    Last Post: 26th September 2007, 10:15 AM
  4. Erratic [Non Fatal] Crash
    By DaveP in forum Wireless Networks
    Replies: 7
    Last Post: 7th February 2007, 10:58 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •