+ Post New Thread
Results 1 to 7 of 7
Virtual Learning Platforms Thread, Moodle Database issues. in Technical; Basically I took over a moodle isntallation that's about 6 years old. From time to time moodle will go down ...
  1. #1
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    594
    Thank Post
    100
    Thanked 42 Times in 40 Posts
    Rep Power
    19

    Moodle Database issues.

    Basically I took over a moodle isntallation that's about 6 years old.

    From time to time moodle will go down and it will come up with the error message

    "Error: Database Connection Failed"

    I'll restart the server and everything is all good. Are there any logs I can view to see if there is anything that happens just prior to the issue? It seems to happen every two weeks or so so I'm thinking there is something setting it off and I'm not 100% wau fait ith Moodle so want to make sure the issue isn't there.

  2. #2
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    985
    Thank Post
    58
    Thanked 165 Times in 117 Posts
    Rep Power
    68
    it might be your hitting the maximum number of allowed concurrent connections to the database.

  3. #3
    barney's Avatar
    Join Date
    Jan 2009
    Location
    Surrey
    Posts
    53
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We periodically hit this problem. admin/dbperformance.php says max connections is 151. I want to change this so I'm looking in xampp/mysql/bin/my.ini but I can't see any connections sections.

  4. #4


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Quote Originally Posted by barney View Post
    We periodically hit this problem. admin/dbperformance.php says max connections is 151. I want to change this so I'm looking in xampp/mysql/bin/my.ini but I can't see any connections sections.
    it should be /etc/my.cnf
    add soemthing like "max_connections = 500 " and do a "service mysqld restart"

  5. #5
    barney's Avatar
    Join Date
    Jan 2009
    Location
    Surrey
    Posts
    53
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks CyberNerd but it's Windows...I have added the following to the bottom of the my.ini

    [Connections]
    Max_Connections = 500

    Will see what happens

  6. #6


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    For what it's worth, mine is just under a [mysqld] heading, not [connections].

  7. #7
    barney's Avatar
    Join Date
    Jan 2009
    Location
    Surrey
    Posts
    53
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Sweet. Thanks

SHARE:
+ Post New Thread

Similar Threads

  1. Moodle & Google Apps integration by Moodle Rooms - anyone using it?
    By morganw in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 1st April 2011, 12:51 PM
  2. Moodle: SMB Web Client Issues
    By tdibb in forum Virtual Learning Platforms
    Replies: 10
    Last Post: 29th July 2009, 12:19 PM
  3. CLEO Moodle down (and other issues)
    By SimpleSi in forum CLEO
    Replies: 17
    Last Post: 11th February 2009, 09:15 AM
  4. Replies: 4
    Last Post: 28th February 2007, 09:37 AM
  5. Moodle Database won't connect
    By StewartKnight in forum *nix
    Replies: 6
    Last Post: 20th January 2006, 01:23 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •