+ Post New Thread
Results 1 to 6 of 6
Virtual Learning Platforms Thread, Moodle LDAP problem in Technical; Hi, I was wondering if anyone can help with this? - http://moodle.org/mod/forum/discuss....128370#p564375 I have attached my configs Many Thanks...
  1. #1

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,957
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448

    Moodle LDAP problem

    Hi,

    I was wondering if anyone can help with this? - http://moodle.org/mod/forum/discuss....128370#p564375

    I have attached my configs

    Many Thanks
    Last edited by FN-GM; 24th July 2009 at 02:23 PM.

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    Your host url is wrong. Should be in the format 'ldap://127.0.0.1'
    You have not filled out the attribute fields.

  3. Thanks to Geoff from:

    FN-GM (24th July 2009)

  4. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,957
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448
    Your host url is wrong. Should be in the format 'ldap://127.0.0.1'
    It used to be like that actually but someone told me otherwise, i will try that now

    You have not filled out the attribute fields.
    Do you mean the ones at the bottom, they all dont need to be filled in.

    Thanks

    Zak

    EDIT:

    Your host url is wrong. Should be in the format 'ldap://127.0.0.1'
    Changing this doesn't make a difference
    Last edited by FN-GM; 24th July 2009 at 02:08 PM.

  5. #4

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    Here are my working settings.
    Attached Images Attached Images

  6. Thanks to Geoff from:

    FN-GM (24th July 2009)

  7. #5

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,957
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448
    Thanks Geoff

    Does these feilds need to be changed in Microsoft Server 2008 AD?

    User attribute
    Member attribute
    Member attribute uses dn

    Thanks

    EDIT: I changed these and it works wooo hoo


    On question Geoff, what do they mean?
    Last edited by FN-GM; 24th July 2009 at 02:18 PM.

  8. #6

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    The first two are the ldap fields moodle needs to use to find the usernames and the group memberships. The last one tells moodle that the group membership list is a bunch of LDAP paths rather than names.

SHARE:
+ Post New Thread

Similar Threads

  1. Moodle, LDAP course enrolling
    By IT_Man_Dan in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 5th November 2009, 03:27 PM
  2. Moodle LDAP Auth
    By FN-GM in forum Virtual Learning Platforms
    Replies: 36
    Last Post: 9th April 2009, 11:55 AM
  3. Moodle and LDAP
    By ahunter in forum Virtual Learning Platforms
    Replies: 6
    Last Post: 31st October 2008, 11:12 AM
  4. Moodle LDAP
    By zag in forum Virtual Learning Platforms
    Replies: 6
    Last Post: 17th July 2008, 10:12 AM
  5. Moodle and LDAP
    By GrumbleDook in forum Virtual Learning Platforms
    Replies: 10
    Last Post: 28th March 2007, 04:02 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •