+ Post New Thread
Results 1 to 10 of 10
Virtual Learning Platforms Thread, Setting Up Moodle in Technical; Hi All I am in the process of setting up Moodle. I have uploaded the files etc, and run the ...
  1. #1

    Join Date
    Jan 2009
    Location
    Essex / Macclesfield
    Posts
    272
    Thank Post
    28
    Thanked 8 Times in 6 Posts
    Rep Power
    13

    Setting Up Moodle

    Hi All

    I am in the process of setting up Moodle.

    I have uploaded the files etc, and run the installer, all good. Now when I get to the 3rd screen in the installer it askes for the SQL database info. I have an issue, its set to local host, yet my SQL database is on another server, is there anyway I can change this, also my admin username is no root, again can i change this?

    Hope someone can help.

    This is the screen I am @ :-

    Now you need to configure the database settings where most Moodle data will be stored. This database will be created automatically by the installer with the settings specified below.

    Type: fixed to "mysql" by the installer
    Host: fixed to "localhost" by the installer - NEED TO CHANGE THIS
    Name: database name, eg moodle
    User: fixed to "root" by the installer - NEED TO CHANGE THIS
    Password: your database password
    Tables Prefix: optional prefix to use for all table names


    TIA
    IKWeb

  2. #2


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    Yep, you can change the hostname and username no problem.

    You'll need to make sure your remote mysql server allows incoming connections but other than that it should be fine.

  3. #3

    Join Date
    Jan 2009
    Location
    Essex / Macclesfield
    Posts
    272
    Thank Post
    28
    Thanked 8 Times in 6 Posts
    Rep Power
    13
    Hi Kim

    Thanks for your fast update, do you know what file this info is stored in, I have looked in some of the Config.php files and not had much joy.

    Thanks again.

  4. #4


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    That's rather odd, I've set up a couple of moodles today and not noticed that it was locked.

    Which version of moodle are you using?

  5. #5

    Join Date
    Jan 2009
    Location
    Essex / Macclesfield
    Posts
    272
    Thank Post
    28
    Thanked 8 Times in 6 Posts
    Rep Power
    13
    I downloaded 1.9.5+ from the Moodle site this morning.

  6. #6


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    Are you on windows or linux?

  7. #7

    Join Date
    Jan 2009
    Location
    Essex / Macclesfield
    Posts
    272
    Thank Post
    28
    Thanked 8 Times in 6 Posts
    Rep Power
    13
    Hi

    Sorry I should have said, its running on a windows box, this is a screen dump of what I get.


  8. #8


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    Holding my hands up, never seen this before but I've never installed it on windows before.

    Some more info to help others, IIS or Apache?

  9. Thanks to kmount from:

    IKWeb (16th July 2009)

  10. #9

    Join Date
    Jan 2009
    Location
    Essex / Macclesfield
    Posts
    272
    Thank Post
    28
    Thanked 8 Times in 6 Posts
    Rep Power
    13
    Its running on IIS, if there is anyone else who may read this post that can help, it would be very welcome.

    Many thanks for all your help with this kim.

  11. #10

    Join Date
    Nov 2008
    Location
    UK
    Posts
    8
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I followed the install instructions here: Windows installation - MoodleDocs I think the important thing is that you do a manual install and not the Windows Installer.

    I even managed to get the NTLM SSO working in the end!



SHARE:
+ Post New Thread

Similar Threads

  1. Setting up moodle - Dont know where to start
    By Half-Dead in forum Virtual Learning Platforms
    Replies: 23
    Last Post: 17th September 2012, 04:00 AM
  2. Setting network save setting in Kar2ouche
    By Little-Miss in forum Windows
    Replies: 3
    Last Post: 12th December 2011, 04:44 PM
  3. Moodle & Google Apps integration by Moodle Rooms - anyone using it?
    By morganw in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 1st April 2011, 01:51 PM
  4. Setting up a quiz in Moodle
    By Clara in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 16th May 2009, 11:36 AM
  5. Setting Up Moodle - Initial Problems
    By Half-Dead in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 27th January 2009, 06:36 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •