+ Post New Thread
Results 1 to 12 of 12
Virtual Learning Platforms Thread, Moodle Upload limit 60mb but over 500k hangs in Technical; We're stuck with uploading files into Moodle via the usual system - here's a cut and paste of where we ...
  1. #1
    Grumbletweezer's Avatar
    Join Date
    Jul 2008
    Location
    Chesterfield
    Posts
    6
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Moodle Upload limit 60mb but over 500k hangs

    We're stuck with uploading files into Moodle via the usual system - here's a cut and paste of where we are so far:
    -------------------------------
    We've been though the stuff in the FAQs to get out Moodle uploading large files and set our limit to 60mb. When I try to up load a file (either through the course main page Files link or through Add an activity) files below about 500k go straight up - very fast- and appear in the file list on Moodle. Files over that cause the main course Files link upload to just sit there, doing it via Add an activity causes the upload window to go blank.

    I've made sure the course limit is set to 60mb and, in both cases, the upload window says the limit is 60mb. Is there some other place in settings we've missed that might cause this problem?

    We're on version 1.9.4+
    ------------------------------------
    Our htaccess file currently has
    php_value post_max_size 70M
    php_value upload_max_filesize 60M
    AcceptPathInfo on
    I came across another setting which was at "Server limit" and I changed to 60MB. And also a "Module > Assignment > Maximum assignment size" which was 1Mb, I set that to 60Mb. But it didn't fix things. The Maximum size on the "upload a file" dialog says 60Mb. So I tried to upload a 2.mb file, got "Page cannot be displayed", in an inelegant IE error box. A 21kb file worked fine. Prompted by a moodle.org forum post, I double-checked in the database, table mdl_config, and the settings there are fine: 62914560 for both maxbytes and assignment_maxbytes. Likewise I have confirmed via the builtin phpinfo page that the php.ini values (from htaccess) have been applied. (Some people urge you to restart the server. I don't know how I can do this anyway, and the FAQ explicitly says that it is not necessary).
    -------------------------------------------------------------------

    It's also been suggested: You may also want to check what max_execution_time is set to and increase that. But we haven't tried that yet.

    ----------------------------------------------------


    Does anything leap out at anyone here that might be the cause.

    Grumbs

  2. #2

    Join Date
    Apr 2006
    Location
    UK
    Posts
    939
    Thank Post
    39
    Thanked 70 Times in 54 Posts
    Rep Power
    29
    I presume you have also set 'Maximum Uploaded File Size' setting under:

    http://YOUR-URL/moodle/admin/setting...n=sitepolicies

    To: Server Limit

    -----

    Aside to that I have had this problem before where the internet connection times out after a certain length of time during a file upload, its as if it detects inactivity and doesn't continue uploading the file.

  3. Thanks to danIT from:

    Grumbletweezer (28th March 2009)

  4. #3


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    make sure you set the upload_max_filesize in the php.ini

  5. Thanks to CyberNerd from:

    Grumbletweezer (28th March 2009)

  6. #4
    mb2k01's Avatar
    Join Date
    Jan 2007
    Posts
    1,138
    Thank Post
    189
    Thanked 230 Times in 195 Posts
    Rep Power
    92
    Quote Originally Posted by CyberNerd View Post
    make sure you set the upload_max_filesize in the php.ini
    Will this enable moodle uploads past 60mb?
    Can it be set to a specific value of say 300MB?

    I too have found the 60MB a bit of a drag and counter-productive, but if we could specific something larger (rather than having it endless) it would be good!

  7. Thanks to mb2k01 from:

    Grumbletweezer (28th March 2009)

  8. #5


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    AFAIK there are 3 places where limits can be set; the php.ini, the .htaccess file and in moodle itself. If you set the upload_max_filesize to something very high, you may need to tune other parameters to prevent timeouts. take a look here:
    PHP File Upload Configuration

  9. 2 Thanks to CyberNerd:

    Grumbletweezer (28th March 2009), mb2k01 (27th March 2009)

  10. #6
    alan-d's Avatar
    Join Date
    Aug 2005
    Location
    Sutton Coldfield
    Posts
    2,414
    Thank Post
    360
    Thanked 256 Times in 187 Posts
    Rep Power
    75
    If you have made changes to Apache did you restart the Apache service?

  11. Thanks to alan-d from:

    Grumbletweezer (28th March 2009)

  12. #7


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Quote Originally Posted by mb2k01 View Post
    I too have found the 60MB a bit of a drag and counter-productive, but if we could specific something larger (rather than having it endless) it would be good!
    Thinking about it, I might be tempted to keep the 60mb limit.
    I doubt you really want lots of staff uploading 300mb files - this is a webserver after all and I'm sure the kids aren't going to be too happy if they have to spend all evening downloading oversized files !
    The limit might actually be beneficial and give you a bit more control.

    what you could do is use sftp to upload the larger files such as the scorm applications, it's a bit tricky finding the course in the moodledata directory unless you have a particular file to search for, but once you've found the course it's dead easy to use sftp (of smb/cifs if you have a windowz server) to upload the files.

  13. #8
    Grumbletweezer's Avatar
    Join Date
    Jul 2008
    Location
    Chesterfield
    Posts
    6
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by danIT View Post
    I presume you have also set 'Maximum Uploaded File Size' setting under:

    http://YOUR-URL/moodle/admin/setting...n=sitepolicies

    To: Server Limit

    -----

    Aside to that I have had this problem before where the internet connection times out after a certain length of time during a file upload, its as if it detects inactivity and doesn't continue uploading the file.
    That was set at 60mb - setting it to server limit made no difference :O(

    When we try to upload the 500k+ files my screen goes blank immediately - it doesn't feel like a time out.

    Grumbs
    Last edited by Grumbletweezer; 28th March 2009 at 02:10 PM.

  14. #9
    Grumbletweezer's Avatar
    Join Date
    Jul 2008
    Location
    Chesterfield
    Posts
    6
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by alan-d View Post
    If you have made changes to Apache did you restart the Apache service?
    I don't think we can do that - this is just some fairly bog-standard web space.

  15. #10
    rosswilson's Avatar
    Join Date
    Feb 2008
    Location
    Cheshire
    Posts
    47
    Thank Post
    15
    Thanked 10 Times in 10 Posts
    Rep Power
    15

    Custom PHP Settings Banned

    Quote Originally Posted by Grumbletweezer View Post
    I don't think we can do that - this is just some fairly bog-standard web space.
    In that case they may also not allow you to modify any of PHP's settings through the .htaccess file. I have come across hosts like this; I had to contact their technical support team to resolve the issue.

    EDIT: This could mean that your settings aren't being applied. Can you create a phpinfo() file and see what the max file upload sizes are? Simply create a .php text file with the following contents:

    Code:
    <?php
    
    phpinfo();
    
    ?>
    Regards,

    Ross Wilson
    Last edited by rosswilson; 28th March 2009 at 03:28 PM.

  16. Thanks to rosswilson from:

    Grumbletweezer (29th March 2009)

  17. #11
    Grumbletweezer's Avatar
    Join Date
    Jul 2008
    Location
    Chesterfield
    Posts
    6
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just to say that we still haven't got to the bottom of this, but we've switched to using FTP in the mean time. Thanks for all your suggestions so far :O)

  18. #12
    apoth0r's Avatar
    Join Date
    Apr 2007
    Location
    Northants
    Posts
    1,221
    Thank Post
    151
    Thanked 180 Times in 132 Posts
    Rep Power
    51
    As the main face of the VLE to staff, I ask any larger files be put on the shared area for me to evaluate and upload via FTP. Keeps things under control because I hate the idea of too much being uploaded for their own 'shared area' kind of use, because that is what most of them think

SHARE:
+ Post New Thread

Similar Threads

  1. Flowol 3 hangs on opening some mimics
    By MrLudwig in forum Educational Software
    Replies: 3
    Last Post: 18th February 2009, 12:45 AM
  2. Moodle - CLEO MIS Upload Tool
    By alan-d in forum Virtual Learning Platforms
    Replies: 2
    Last Post: 27th November 2008, 02:05 PM
  3. Moodle file upload limit
    By Wildebeaste in forum Educational Software
    Replies: 5
    Last Post: 24th September 2007, 01:54 PM
  4. Moodle crashes on mass user upload
    By monkey_boy in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 24th April 2007, 05:41 PM
  5. Tempermental notebook - hangs, sometimes
    By speckytecky in forum How do you do....it?
    Replies: 2
    Last Post: 20th February 2007, 01:21 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •