Out of the box, Frog 3 will not work properly in Internet Explorer in the 'Metro' (or whatever they call it now) environment. When you double tap on an icon, it zooms in instead of double clicking.

To fix it, you need to edit some settings in Internet Explorer in 'Desktop' mode.

Create a text file and place it somewhere on the device (I called mine style.css and put it in the Windows folder). In that file enter the text:

Code:
body {
-ms-touch-action: manipulation !important;
}
Go to Tools -> Internet Options -> Accessibility. Add the style.css file in the box. Save it all and try the site again in Internet Explorer. Double tap should now work.