+ Post New Thread
Results 1 to 10 of 10
Virtual Learning Platforms Thread, Frog and I Am Learning widget - IE8 - only works for admins in Technical; Hi, Wondering if anyone else has come across this one. We have a Frog VLE and I Am Learning. I'm ...
  1. #1
    S.C.'s Avatar
    Join Date
    Nov 2012
    Location
    Cramlington
    Posts
    56
    Thank Post
    2
    Thanked 7 Times in 7 Posts
    Rep Power
    5

    Frog and I Am Learning widget - IE8 - only works for admins

    Hi,

    Wondering if anyone else has come across this one.

    We have a Frog VLE and I Am Learning. I'm trying to use their IAL widget, which users click to be logged straight into IAL. This works fine for admins, but doesn't work for teachers or students. The school computers are on RM CC4, some XP, some Win7, all IE8.

    The weird thing is the widget is visible, but the mouse pointer doesn't even change to a link.

    We think it might be a permission setting in IE, having eliminated other variables. Has anyone else had this problem?

    Bit of history: I built IAL's first SSO widget from Frog, so we have the functionality. My concern is that the new official widget is written in a different way and ours might stop working at some point.

    Our Network Manager is looking into the issue, but it feels like a needle-in-a-haystack. I'm hoping to save him some time if possible.

  2. #2

    Join Date
    Sep 2009
    Location
    in my happy place!
    Posts
    44
    Thank Post
    1
    Thanked 14 Times in 12 Posts
    Rep Power
    12
    Our works, we using the one marked version 17 - I noticed that the widget store has two version neither of which I've bothered using as the version 17 works fine for us.

    windows 7 ie9 but we used to have CC4 and IE8 and I haven't changed the widget since 25/Jan/2011

  3. Thanks to frogwoman from:

    S.C. (29th November 2012)

  4. #3
    S.C.'s Avatar
    Join Date
    Nov 2012
    Location
    Cramlington
    Posts
    56
    Thank Post
    2
    Thanked 7 Times in 7 Posts
    Rep Power
    5
    Updating to the new widget solved my problem.

    Many thanks frogwoman

  5. #4

    Join Date
    Oct 2006
    Location
    Liverpool, UK
    Posts
    45
    Thank Post
    0
    Thanked 10 Times in 5 Posts
    Rep Power
    17
    Ours miserably fails for any users using Chrome/Safari due to the pop-up blocking in both browsers. Kerboodle widget is also affected but the Google ones work fine!

  6. #5
    S.C.'s Avatar
    Join Date
    Nov 2012
    Location
    Cramlington
    Posts
    56
    Thank Post
    2
    Thanked 7 Times in 7 Posts
    Rep Power
    5
    Have you tried contacting iamlearning? I've always found them to be very helpful. The widget (as far as I know) is built in FDP code, so they might be able to send you the code for you to adapt?

    Graham

  7. #6
    mthomas08's Avatar
    Join Date
    Jun 2008
    Posts
    1,608
    Thank Post
    132
    Thanked 165 Times in 146 Posts
    Rep Power
    62
    Quote Originally Posted by john316 View Post
    Ours miserably fails for any users using Chrome/Safari due to the pop-up blocking in both browsers. Kerboodle widget is also affected but the Google ones work fine!
    Another good thing I am glad we stuck to IE, we found all sorts of compatibility problems when using sharepoint on safari/chrome back when we was using sharepoint. Frog is a bit more fussy with compatibility but roll on FrogOS which is built for other browsers

  8. #7
    S.C.'s Avatar
    Join Date
    Nov 2012
    Location
    Cramlington
    Posts
    56
    Thank Post
    2
    Thanked 7 Times in 7 Posts
    Rep Power
    5
    Just an update. The widget passed my attempts at testing, but I have had to withdraw after reports from teachers saying it isn't working. Will call IAL in the morning and ask for advice.

    i think a big part of the problem is the way Frog are building widgets. Widgets made by others in the Widget Store are pages with an FDP brick in them, but the IAL and Kerboodle widgets appear as weird links, which you can't add via the Frog2 editor. Doubly annoying, but at least with regular FDP widgets you can see the code and attempt a fix yourself.

  9. #8
    round2it's Avatar
    Join Date
    May 2009
    Location
    UK
    Posts
    991
    Thank Post
    193
    Thanked 143 Times in 101 Posts
    Rep Power
    36
    Make sure compatibility mode is turned. This is how I got it working
    Turn off compatibility view (GP)
    For all of your reference. If we have schools who have an issue in Frog where:

    The widget is 'inactive in Internet Explorer (i.e. cannot be clicked on), but works fine in firefox

    The issue is most probably because the web browser (IE) is trying to use compatibility mode. The school can stop this from happening by changing a setting in their 'Group Policy' configuration (the technical teams in school will know about this).


    Hope this helps
    Last edited by round2it; 8th June 2013 at 05:12 PM.

  10. #9
    round2it's Avatar
    Join Date
    May 2009
    Location
    UK
    Posts
    991
    Thank Post
    193
    Thanked 143 Times in 101 Posts
    Rep Power
    36
    how did you get on

  11. #10

    Join Date
    Oct 2006
    Location
    Liverpool, UK
    Posts
    45
    Thank Post
    0
    Thanked 10 Times in 5 Posts
    Rep Power
    17
    Did anybody ever find a solution for this long term?

SHARE:
+ Post New Thread

Similar Threads

  1. Printer Script only runs for Admin users
    By Tyiell in forum Windows Server 2000/2003
    Replies: 4
    Last Post: 13th July 2010, 11:22 AM
  2. Shockwave only works for Admin users
    By kearton in forum Windows
    Replies: 4
    Last Post: 18th September 2009, 02:32 PM
  3. Frog and MyBB/other...
    By Cue in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 31st March 2009, 08:33 AM
  4. Replies: 8
    Last Post: 17th September 2008, 08:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •