+ Post New Thread
Results 1 to 6 of 6
Virtual Learning Platforms Thread, email from moodle in Technical; ubuntu 10.04.1 moodle 2.2.2+ postfix Having trouble sending mail from moodle server. We used to have a zimbra server on ...
  1. #1

    Join Date
    Aug 2008
    Location
    Durham
    Posts
    44
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    email from moodle

    ubuntu 10.04.1 moodle 2.2.2+ postfix
    Having trouble sending mail from moodle server. We used to have a zimbra server on site but have now switched to gmail and after reading the guidance at Email setup gmail - MoodleDocs (and failing to make that work) I decided to go back to letting moodle send its own mail and re-installed postfix. It seems that it's still trying to relay via our old zimbra server but I can't find this in any settings to switch it off. Where next?
    thanks!
    Carol

    extract from mail log:

    Oct 4 09:49:10 moodle postfix/pickup[29848]: F2DE51401CE: uid=33 from=<AAB7wQAAA==02d5850b849a258bec9f30f3efab9baa@ >
    Oct 4 09:49:10 moodle postfix/cleanup[30702]: F2DE51401CE: message-id=<cdb14cb66390272cfa3721f48ec9b92c@moodle.wolsin ghamschool.net>
    Oct 4 09:49:11 moodle postfix/qmgr[23021]: F2DE51401CE: from=<AAB7wQAAA==02d5850b849a258bec9f30f3efab9baa@ >, size=791, nrcpt=1 (queue active)
    Oct 4 09:49:11 moodle postfix/smtp[30705]: F2DE51401CE: to=<vleadmin@wolsinghamschool.net>, relay=zimbra.wolsingham.internal[10.0.0.6]:25, delay=0.07, delays=0.01/0.01/0.04/0.01, dsn=5.1.7, status=bounced (host zimbra.wolsingham.internal[10.0.0.6] said: 501 5.1.7 Bad sender address syntax (in reply to MAIL FROM command))
    Oct 4 09:49:11 moodle postfix/cleanup[30702]: 100F81401D9: message-id=<20121004084911.100F81401D9@moodle.wolsinghamsc hool.net>
    Oct 4 09:49:11 moodle postfix/bounce[30706]: F2DE51401CE: sender non-delivery notification: 100F81401D9
    Oct 4 09:49:11 moodle postfix/qmgr[23021]: 100F81401D9: from=<>, size=2944, nrcpt=1 (queue active)
    Oct 4 09:49:11 moodle postfix/qmgr[23021]: F2DE51401CE: removed
    Oct 4 09:49:11 moodle postfix/error[30707]: 100F81401D9: to=<AAB7wQAAA==02d5850b849a258bec9f30f3efab9baa@>, relay=none, delay=0.01, delays=0/0/0/0, dsn=5.1.3, status=bounced (bad address syntax)
    Oct 4 09:49:11 moodle postfix/qmgr[23021]: 100F81401D9: removed

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    You need to change the 'relayhost' setting in /etc/postfix/main.cf. Either comment it out (in which case postfix will send mail directly) or change it to a working relay that you have access to (your LEA SMTP server or whatever).

  3. #3

    Join Date
    Aug 2008
    Location
    Durham
    Posts
    44
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks very much Geoff and sorry for slow response to your very fast response (I had an old email address registered with this account)
    I had another look in postfix config and definitely nothing there but helpful to know I was looking in the right file!
    I think we may have a redirect set up somewhere on our network. Is there a way to find out from my server?
    Carol

  4. #4

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    from your log file your postfix installation is currently trying to relay via zimbra.wolsingham.internal (IP 10.0.0.6). That server is bouncing the mails because vleadmin@wolsinghamschool.net doesn't exist as far as it's concerned.

  5. #5

    Join Date
    Aug 2008
    Location
    Durham
    Posts
    44
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    thanks, that makes sense. Pardon my ignorance of Postfix but could this happen if there was nothing in the postfix config to make it happen?

  6. #6

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    Well that depends, perhaps the better starting point is to ask what you actually want to happen?

SHARE:
+ Post New Thread

Similar Threads

  1. Problem with SMTP email out from Moodle via Live@Edu domain
    By UKDarkstar in forum Virtual Learning Platforms
    Replies: 13
    Last Post: 10th October 2010, 06:45 PM
  2. Hide Staff emails from students with exchange 2003
    By bilbo in forum Network and Classroom Management
    Replies: 19
    Last Post: 8th March 2009, 11:14 AM
  3. Archive old email from exchange?
    By JamesC in forum How do you do....it?
    Replies: 4
    Last Post: 4th July 2008, 12:18 AM
  4. BSF - Email from Steve Moss
    By Face-Man in forum BSF
    Replies: 95
    Last Post: 26th January 2007, 05:03 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •