+ Post New Thread
Results 1 to 8 of 8
Thin Client and Virtual Machines Thread, poor audio quality hyper-v rdp win 7 in Technical; Hi Am wondering what could be the cause for poor quality audio over rdp running on a Win 7 virtual ...
  1. #1
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0

    poor audio quality hyper-v rdp win 7

    Hi

    Am wondering what could be the cause for poor quality audio over rdp running on a Win 7 virtual machine.

    Seems that however much RAM or CPU i allocate to the virtual machine I still get the poor audio.

    The audio on an XP VM seems much more acceptable.

    Is this a know Win7 Vm issue?

    Thanks

  2. #2
    Axel's Avatar
    Join Date
    Apr 2008
    Posts
    239
    Thank Post
    32
    Thanked 43 Times in 32 Posts
    Rep Power
    21
    Duxbuz

    Is this on your Wyse or Axel terminals, if the the Axel's, press: cont alt i when connected

    This will pop up a window which amongst other things lists the codec the application uses (see attached). Compare on both XP and W7. The client offers the codecs it supports, the server ultimately chooses which one to use, but this
    may give you a clue as to what's going on.

    You may/will find that different applications use different codecs, so for same session, running Itunes may use different codec to Mediaplayer etc. The "cont alt i" is a realtime snapshot as to
    what resources are being used at that point in time.

    codec.JPG

    You can control which codecs the terminal offers by selecting high, medium or low quality

    audioq.JPG

  3. #3
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    thanks for helpful response.

    Both win7 and winXp have the setting 'High' for audio.

    i seem to have a PCM 16bit stereo 44khz format within the Win7 connection

    and the WinXp connection has PCM 16bits, stereo, 22Khz

    I am still getting a juttering audio stream on the Win7 connection.

    My only solution thus far is to use WinXP

    Cheers

  4. #4
    Axel's Avatar
    Join Date
    Apr 2008
    Posts
    239
    Thank Post
    32
    Thanked 43 Times in 32 Posts
    Rep Power
    21
    Do you have a physical W7 machine to connect the terminal to, to check it is the VM causing the problem, as opposed
    to W7...?

  5. #5
    jamesfed's Avatar
    Join Date
    Sep 2009
    Location
    Reading
    Posts
    2,192
    Thank Post
    134
    Thanked 340 Times in 287 Posts
    Rep Power
    84
    When you are saying Audio what audio is it that you are playing?

    RDP can do audio remoting for things like WMA (where the endpoint does all the hard work) but only if the endpoint (your client) supports it.

    So main question - what are you using for your endpoints?

  6. #6
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Ye I would think its the VM, as a direct RDP to the physical server is ok, the WinXP VM is better than the WIN7 VM which is awful.

    Am wondering if this is a fixable issue, ie. do i increase the RAM, or is there something else that needs altering in the hyper-v manager etc

    Endpoints will be Axel M80 and Wyse T50

  7. #7
    jamesfed's Avatar
    Join Date
    Sep 2009
    Location
    Reading
    Posts
    2,192
    Thank Post
    134
    Thanked 340 Times in 287 Posts
    Rep Power
    84
    Have you tried testing from a full blood Windows PC (rdping into your VM from a full PC) - that would indicate if its an issue with the thin client.

  8. #8
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Thanks for responses.

    story so far.

    Seems that its a culmination of the thinclient and the VM that is causing the poor quality of service.

    if i log directly into physical rdp server from a thinclient i can use audio AND video really well, youtube being my test, as i cannot install the actual old 32bit software on a 64bit machine, so basically youtube runs fine.

    if i log into the VM with a thick client, i.e a laptop or ipad i get decent video and audio using the user software, but neither ipad or laptop can run youtube very well on the VM. This is with minimal 'experience' settings enabled on the RDP client, e.g bitmap caching, visual styles.

    So the main problem seems to be with the thinclient AND the VM being used together.

    Any ideas how I could get the most performance out of the 2 elements?

    Thanks

SHARE:
+ Post New Thread

Similar Threads

  1. What MP3 player has the best audio quality?
    By Dos_Box in forum AV and Multimedia Related
    Replies: 14
    Last Post: 17th August 2012, 03:26 AM
  2. RDP USB drive permissions hyper-v 2008 r2...
    By denzal2k4 in forum Windows Server 2008
    Replies: 4
    Last Post: 13th September 2011, 02:03 PM
  3. Audio accelerator over RDP
    By Liam in forum How do you do....it?
    Replies: 0
    Last Post: 3rd February 2011, 02:02 PM
  4. Replies: 1
    Last Post: 20th July 2010, 11:36 AM
  5. No audio in Win 7 with bootcamp on iMac
    By reggiep in forum Mac
    Replies: 3
    Last Post: 16th March 2010, 01:38 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •