+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
Thin Client and Virtual Machines Thread, How To: setup an ubuntu virtual server for thin clients to use rdesktop into windows in Technical; Right, i followed the guide got it working with the default options (not RDP setup etc). I could PXE boot ...
  1. #16

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    Right, i followed the guide got it working with the default options (not RDP setup etc). I could PXE boot no issues and got to an Ubuntu login screen.

    I then did this:

    gedit /var/lib/tftpboot/ltsp/i386/lts.conf which created a conf file for my thin clients to use. I kept it fairly simple and added the following lines in:

    [default]
    RDP_OPTIONS = "-f -a 16"
    RDP_SERVER = TS_IP_Address_goes_here
    SCREEN_02 = rdesktop

    Then ran this: sudo ltsp-update-image ltsp-update-sshkeys

    and rebooted. Now when booting it gets stuck on the Ubunut boot screen

    I decided to sue Ubuntu Desktop not server edition. Any thoughts please?
    Last edited by FN-GM; 20th June 2012 at 02:45 PM.

  2. #17

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    Fixed it. I need to read more

    I am using these options but when i boots i just get a black screen with the cursor. Any ideas please?

    [DEFAULT]
    SOUND = True
    NBD_SWAP = True
    SCREEN_04 = ldm
    SCREEN_07 = xfreerdp
    RDP_OPTIONS = "--no-nla --ignore-certificate -z --gdi sw -f 172.16.0.12"
    SCREEN_08=xterm

    I havent done this though:

    sudo gedit /opt/ltsp/i386/usr/share/ltsp/xinitrc
    add this line below . /usr/share/ltsp/ltsp-client-functions
    export HOME=${HOME:-/root}

    Plase can you clarify this. What is it we add to the file? Both . /usr/share/ltsp/ltsp-client-functions & export HOME=${HOME:-/root} ?

    Also i didnt do the NAT stuff do i need to do this please?

    Thanks
    Last edited by FN-GM; 20th June 2012 at 03:46 PM.

  3. #18

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    I have done this now, Pretty obvious really when i read it again but i still have the issue. I also ran sudo ltsp-update-image and still get it.

    Thanks

    sudo gedit /opt/ltsp/i386/usr/share/ltsp/xinitrc
    add this line below . /usr/share/ltsp/ltsp-client-functions
    export HOME=${HOME:-/root}

  4. #19
    atamakosi's Avatar
    Join Date
    Jun 2011
    Posts
    101
    Thank Post
    5
    Thanked 11 Times in 9 Posts
    Rep Power
    14
    sorry if my instructions weren't all too clear. tried to get them all written out before my mind totally shut off after looking at the terminal for days.

    the ol' "white cursor on black background" bug. That is the most common issue i've dealt with using ltsp and it has to do with lts.conf settings i believe. To check a few things though we should ctrl + alt + f8 into xterm so we can see if you have a valid IP and can ping the terminal server. (if not familiar with linux, ifconfig will pull up your ip info) So are you using a virtual machine as well? and did you change the IP to your terminal server? (you should be able to use FQDN as well if you like)

    you could remove splash and see more details on boot if you modify the default file here /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default just delete quiet and splash, i believe. these will come back when you update image so don't worry about having to go back later to put them in.

    the reason we added "export HOME=${HOME:-/root}" to the xinitrc file was, according to the nice people at LTSP, without a default HOME location the client could cause the issue we are seeing. This should be added in newer versions so this will be unnecessary in the future.

  5. #20

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    When you say terminal server do you mean the Ubuntu LTSP or my Windows one please? The LTSP server is Virtual.
    Last edited by FN-GM; 20th June 2012 at 10:07 PM.

  6. #21
    atamakosi's Avatar
    Join Date
    Jun 2011
    Posts
    101
    Thank Post
    5
    Thanked 11 Times in 9 Posts
    Rep Power
    14
    the server that you want students to log in to. in my case ubuntu is just used to load the remote desktop client to connect to our Windows terminal server. so they are actually logging in to windows not ubuntu.

  7. #22

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    Quote Originally Posted by atamakosi View Post
    the server that you want students to log in to. in my case ubuntu is just used to load the remote desktop client to connect to our Windows terminal server. so they are actually logging in to windows not ubuntu.
    Same with me.

    I did change the IP to my terminal server in the config file.

    I am unable to troubleshoot this until the morning. I am not infront of the machines. By that time you will be asleep probably. Is there anything else you can suggest to try and keep me going a little longer please?

    EDIT: Just remembered i could ping the ThinClient from my machine when it was booted.
    Last edited by FN-GM; 20th June 2012 at 10:21 PM.

  8. #23
    atamakosi's Avatar
    Join Date
    Jun 2011
    Posts
    101
    Thank Post
    5
    Thanked 11 Times in 9 Posts
    Rep Power
    14
    sounds like you've got the thin client going then. congrats! you just need to setup the xfreerdp session properly. I would recommend testing the settings in RDP_OPTIONS. first thing i would do is remove it completely and see what the results are on the thin client machine. you can specify the windows server in a separate line if you like (RDP_SERVER = IP_OR_FQDN_OF_SERVER) one simple thing is not to forget the quotes around the RDP_OPTIONS line, otherwise you'll get a syntax error but it won't tell you. also in comparison to my original setup where i had rdesktop use screen 2, the new version or xfreerdp did not like that screen at all. using screen 7 or 8 worked for me. (i'm assuming some screens might be reserved in this version but haven't seen the documentation to say yay or nay.)

    but yes, sounds like it is only a matter of figuring the lts.conf file settings for freerdp for your setup. (did you say if you were running virtual ubuntu ltsp server?) the basic settings you need for xfreerdp are --no-nla and --ignore-certificates to at least get you to the rdp session. -gdi is a graphics setting and -f is full screen. you can find the entire list of options for lts.conf here but it looks a little outdated as it references rdesktop. i'm sure i've got more tips but that is all i can think of right now.

  9. Thanks to atamakosi from:

    FN-GM (20th June 2012)

  10. #24

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,846
    Thank Post
    877
    Thanked 1,680 Times in 1,460 Posts
    Blog Entries
    12
    Rep Power
    444
    Thanks i will i have a play around. I wish i knew more about Linux, it would really help right now

  11. #25
    atamakosi's Avatar
    Join Date
    Jun 2011
    Posts
    101
    Thank Post
    5
    Thanked 11 Times in 9 Posts
    Rep Power
    14
    also this might help with your question about changing the splash screen during boot. You can install an app called plymouth manager that should allow you to customize the theme for splash using a .png file under 500kb for your logo or you can change it to text if you like. there are even some default themes that you might like (such as ones that emulate win7 or osX lol).

    to get plymouth try from terminal using:
    sudo apt-get install plymouth-manager
    or
    wget https://launchpad.net/plymouth-manag....5.0-1_all.deb
    sudo dpkg -i plymouth-manager_1.5.0-1_all.deb

    might be missing some dependencies if you are like me so had to run this afterwards:
    sudo apt-get -f install

    that will fetch missing dependencies. You can then run plymouth from the 'start' menu for a gui or you can use it in terminal if you are brave.

    also i can't seem to replicate the issue where it drops the connection to the terminal server after going to standby on the machine i'm testing today. so maybe it was a first week kind of deal and sorted itself?
    Last edited by atamakosi; 21st June 2012 at 01:32 AM.

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Backing Up Hyper-V Virtual Servers - FOR FREE !! with the VSS Writer
    By burgemaster in forum Windows Server 2008 R2
    Replies: 3
    Last Post: 12th March 2012, 10:52 PM
  2. Replies: 6
    Last Post: 11th July 2007, 03:32 PM
  3. Configuring remote users for thin client servers
    By tosca925 in forum Thin Client and Virtual Machines
    Replies: 4
    Last Post: 18th March 2007, 10:08 AM
  4. Good practice for server set up for thin clients
    By tosca925 in forum Thin Client and Virtual Machines
    Replies: 2
    Last Post: 17th March 2007, 06:01 PM
  5. MS Virtual Server for free?
    By Norphy in forum Windows
    Replies: 20
    Last Post: 4th April 2006, 01:54 PM

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •