+ Post New Thread
Results 1 to 11 of 11
Thin Client and Virtual Machines Thread, Thinstation. I have the old Error, no valid session type! in Technical; Hello I have the old Error, no valid session type! I am just about giving up with this for now, ...
  1. #1
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0

    Thinstation. I have the old Error, no valid session type!

    Hello

    I have the old Error, no valid session type!

    I am just about giving up with this for now, but i wondered if there was a live CD that booted to give me options for RDP etc

    I had an image but it just booted into ICEWM with nothin much but an option to burn to HD

    Anyone know a direct link to a Thinstation liveCD that will give me a session with RDP etc

    Thanks

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    you need to define a session type in the thinstation.conf.network
    (or thinstation.conf.buildtime or thinstation.conf.user-) depending how you are running it.

  3. #3
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Well I saw the part about:
    # IMPORTANT: Make sure you minimum have a SESSION_0. Otherwise you will get an error
    # on boot. You may have additional sessions: SESSION_1, SESSION_2 ...
    SESSION_0 is on ctrl-alt-F3

    So i uncommented/enabled this as above.

    I am just wondering where this file should reside. Currently I have it in the Thinstation folder under /boot/x86/

  4. #4


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    Quote Originally Posted by duxbuz View Post
    I am just wondering where this file should reside. Currently I have it in the Thinstation folder under /boot/x86/
    It depends how your running it.
    We boot from a PXE server so the file lives in the ftfp root directory.
    I've not run from hard disk or CD so I'm not soo sure where it looks.

  5. #5


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    my Session0 (for citrix) is:

    ICA_USE_SERVER_KEYBOARD=Off
    ICA_BROWSER_PROTOCOL=HTTPonTCP
    ICA_SERVER=172.16.90.1
    ICA_ENCRYPTION=Basic
    ICA_COMPRESS=On
    ICA_AUDIO=On
    ICA_SMARTCARD=Off
    ICA_AUDIO_QUALITY=high
    ICA_PRINTER=Off
    ICA_SEAMLESS_WINDOW=Off
    ICA_WFCLIENT_CDMALLOWED=On
    ICA_WFCLIENT_DRIVEPATHU=/mnt/usbdevice
    ICA_WFCLIENT_DRIVEENABLEDU=Yes
    ICA_WFCLIENT_DRIVEREADACCESSU=0
    ICA_WFCLIENT_DRIVEWRITEACCESSU=0



    SESSION_0_TYPE=ica
    SESSION_0_ICA_APPLICATION_SET="Desktop"
    SESSION_0_TITLE=Citrix

  6. #6
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Running from WDS server, so folders structure:

    \\ourserver\REMINST\Boot\x86\Thinstation

    Should it be a .network file in this case?

  7. #7


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    yes thinstation.conf.network
    It resides in the same directory as the pxelinux.0 etc.

  8. #8
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    THanks.

    Must still be missing something.

    I changed the session section like so:
    # IMPORTANT: Make sure you minimum have a SESSION_0. Otherwise you will get an error
    # on boot. You may have additional sessions: SESSION_1, SESSION_2 ...
    SESSION_0 is on ctrl-alt-F3
    #SESSION_1 is on ctrl-alt-F4
    # ... etc.


    SESSION_0_TYPE=icewm


    # The -a option here specifies the color depth
    # Note certain servers support certain color depths, wrong settings with this
    # May cause your connection to fail.
    SESSION_0_TITLE="Big Bad Server Donald"
    SESSION_0_TYPE=rdesktop
    SESSION_0_SCREEN=1
    SESSION_0_SCREEN_POSITION=2
    SESSION_0_RDESKTOP_SERVER=x.x.x.x
    SESSION_0_RDESKTOP_OPTIONS="-u user -p password -a 16"
    SESSION_0_AUTOSTART=Off

  9. #9


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    SESSION_0_TYPE=icewm


    # The -a option here specifies the color depth
    # Note certain servers support certain color depths, wrong settings with this
    # May cause your connection to fail.
    SESSION_0_TITLE="Big Bad Server Donald"
    SESSION_0_TYPE=rdesktop
    Its one or the other, you can't have icewm and rdesktop as Session0. Make Icewm session1

  10. #10
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Thanks, noticed that.

    Changed it to:
    # Individual Session Settings, override defaults
    #
    # IMPORTANT: Make sure you minimum have a SESSION_0. Otherwise you will get an error
    # on boot. You may have additional sessions: SESSION_1, SESSION_2 ...
    # SESSION_0 is on ctrl-alt-F3
    #SESSION_1 is on ctrl-alt-F4
    # ... etc.


    #SESSION_0_TYPE=icewm


    # The -a option here specifies the color depth
    # Note certain servers support certain color depths, wrong settings with this
    # May cause your connection to fail.
    SESSION_0_TITLE="Big Bad Server Donald"
    SESSION_0_TYPE=rdesktop
    SESSION_0_SCREEN=1
    SESSION_0_SCREEN_POSITION=2
    SESSION_0_RDESKTOP_SERVER=x.x.x.x
    SESSION_0_RDESKTOP_OPTIONS="-u user -p password -a 16"
    SESSION_0_AUTOSTART=Off


    with:


    NET_USE_DHCP=On
    #NET_IP_ADDRESS=192.168.0.1
    #NET_MASK=255.255.255.0
    #NET_GATEWAY=192.168.0.254
    #NET_DHCP_DELAY=30
    NET_FILE_ENABLED=On
    NET_FILE_METHOD=tftp
    #NET_FILE_USER=needed_for_scp_only
    #NET_FILE_ALTERNATE=192.168.0.4
    #NET_DNS1=192.168.0.2
    #NET_DNS2=192.168.0.3
    #NET_DNS_SEARCH=cartoons.org.nz

    Same issue, but the boot aborted message now has 'menu - ' appended on it

  11. #11
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Am still not managing to get past this error 'No valid session type'


SHARE:
+ Post New Thread

Similar Threads

  1. Thinstation: "Error, no valid session type!!!"
    By thaolv in forum Thin Client and Virtual Machines
    Replies: 15
    Last Post: 25th April 2012, 08:25 PM
  2. Thinstation - No Valid Session Type
    By Cache in forum Thin Client and Virtual Machines
    Replies: 4
    Last Post: 20th October 2011, 07:09 PM
  3. Thinstation with VMWare View - No valid session type
    By dribblecastle in forum Thin Client and Virtual Machines
    Replies: 0
    Last Post: 27th July 2011, 06:35 PM
  4. No school like the old school
    By Jawloms in forum General Chat
    Replies: 16
    Last Post: 8th February 2011, 04:49 PM
  5. "well you have the whole of the summer to sort it"
    By Benji1 in forum General Chat
    Replies: 16
    Last Post: 14th July 2006, 08:17 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •