+ Post New Thread
Results 1 to 14 of 14
Thin Client and Virtual Machines Thread, Keyboard problem with ThinStation in Technical; I have a converted a room full of aging W2k PCs to Thinstation to use with the new Citrix farm ...
  1. #1

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Keyboard problem with ThinStation

    I have a converted a room full of aging W2k PCs to Thinstation to use with the new Citrix farm I setup. However on a couple of PCs I'm having a problem with the keyboard repeat rate. Specifically, when connected to the Terminal Server. When I hit a key, I get 3 characters instead of one.

  2. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,590
    Thank Post
    109
    Thanked 762 Times in 593 Posts
    Rep Power
    180

    Re: Keyboard problem with ThinStation

    @Geoff: You could hold the key down for less time :P

    I have had problems trying to use PS2 keyboards with USB adapters over Citrix... it seems that random letters would get missed or added. Have you also tried changing the keyboards around?

  3. #3

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Keyboard problem with ThinStation

    Yes, I've checked it's not a keyboard problem. Also, when I CTRL-ALT-F2 to the local text console on Thinstation my keyboard behaves. This leads me to believe it's either a problem with X or the ICA client.

  4. #4

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,590
    Thank Post
    109
    Thanked 762 Times in 593 Posts
    Rep Power
    180

    Re: Keyboard problem with ThinStation

    Could be a dodgy NIC or other problem with the communication to the server. If you have identical hardware that behaves then it is unlikely to be X or the ICA client because all your Thinstation clients will have the same versions/config.

  5. #5

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Keyboard problem with ThinStation

    I have 3 different types of PC in the room. It's only one type of PC that's affected. So one set of identical hardware has the problem. The rest (with different configurations) do not.

  6. #6

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Keyboard problem with ThinStation

    Well, I've pulled on of the machines out. The NIC is a Dlink DFE-530TX (Rhine driver). The motherboard is a ASUS ME-99VM. I'm going to try a bios update first.

  7. #7

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Keyboard problem with ThinStation

    I've traced this back to being a intermittent network fault.

  8. #8

    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    i have same problem

    60 machines/terminals connecting in a server and three machines have this problem, when hit a key appear 3 characters, already changed keyboards, and this terminals with problems like same others...i going to see what have of different....

  9. #9


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    I've seen this too, It was also a network fault

  10. #10

    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    keyboard rate

    Quote Originally Posted by CyberNerd View Post
    I've seen this too, It was also a network fault
    I changed keyboard rate and keyboard speed in server properties, dont work, changed network adapter with other i know work and still dont work, changed memories and still dont work....only 3 terminals...

    say about network fault? how i fix it?

    Thanks,

  11. #11

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    It was a cabling fault for me.

  12. #12

    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Geoff View Post
    It was a cabling fault for me.
    I removed one of three terminals with problem and put in another room with other closed local network with other cables and switches and problems still appear...

    I think is hardware problem, i compiled my image (nbi) and maybee need insert a module/driver...strange is I use keyboard normal in other 57 terminals and 3 have this **** problem...

    Thanks again,

  13. #13

    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    i found the problem

    I go to local and opened the three machines/terminals and see all are Sis530 motherboards....return to my office room and look my build.conf to see my configuration of my image(NBI) and I not include SIS modules and packages...

    solution,...compiled new image with all SIS stuff and new splash screen

    All working fine now...

    Thanks for everyone...

  14. #14

    Join Date
    Mar 2009
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have this same problem with a Sis530. My build.conf has:

    Code:
    module 	serial #
    module 	acpi #
    module 	pcspkr #
    module 	sis-agp #
    module 	8139too #
    module 	8139cp #
    module 	snd-cmipci #
    module 	usb-hid #
    module 	usb-storage #
    module 	usb-cdrom #
    module 	ide-cd #
    module 	isofs #
    module 	vfat #
    package 	sound-esd #
    package 	sound-nasd #
    package 	xorg6-sis #
    package 	xorg6-vesa #
    package 	keymaps-es #
    package 	xterm #
    package 	ssh #
    package 	nx #
    package 	icewm #
    package 	www #
    Can you help me please? I need other module or package?

    Sorry for my bad english.

    Spanish: Por si alguien habla espaņol y me puede ayudar estaria aun mas agradecido. Como ven el ingles no es lo mio

    Thanks,

SHARE:
+ Post New Thread

Similar Threads

  1. ThinStation
    By lee_sri in forum Thin Client and Virtual Machines
    Replies: 16
    Last Post: 28th October 2010, 08:01 AM
  2. WDS and thinstation problem
    By Andi in forum Windows
    Replies: 3
    Last Post: 30th July 2008, 12:48 PM
  3. office keyboard problem
    By strawberry in forum Windows
    Replies: 4
    Last Post: 7th September 2007, 09:56 AM
  4. FFS! Apple keyboard problem
    By Ric_ in forum Mac
    Replies: 3
    Last Post: 28th August 2006, 09:32 PM
  5. Thinstation Via EPIA M10000 problem
    By CyberNerd in forum Thin Client and Virtual Machines
    Replies: 6
    Last Post: 15th August 2006, 10:44 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •