+ Post New Thread
Results 1 to 10 of 10
Thin Client and Virtual Machines Thread, Virtual RM CC4 Machine on apple mac in Technical; Hello I am trying to set up a virtual RM CC4 machine on an apple mac in VirtualBox. This is ...
  1. #1

    Join Date
    May 2011
    Location
    United Kingdom
    Posts
    494
    Thank Post
    121
    Thanked 16 Times in 16 Posts
    Rep Power
    9

    Virtual RM CC4 Machine on apple mac

    Hello

    I am trying to set up a virtual RM CC4 machine on an apple mac in VirtualBox. This is my first few steps into the virtualised world. I have tried making an XP VM and then pxe booting it but its having none of it.

    Has anyone done this before? Have any guidance on how to do it? or possibly a guide? Is it possible to pxe boot a virtual machine from a physical RM network?

    I have looked at the physical to virtual tools but it takes an age to make an image. Is there a better way?

    Thanks in advance.

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    I would firstly concentrate on just vanilla Windows, as RM CC4 is just Windows + RM bits = RM CC4 and CC3 for that matter.

    As to whether it's possible, I'm not actually sure if I'm honest!

  3. #3
    Chris_'s Avatar
    Join Date
    Jul 2010
    Location
    UK
    Posts
    682
    Thank Post
    131
    Thanked 113 Times in 96 Posts
    Rep Power
    44
    When I build a CC4 client in a virtual machines I had to set the guest OS type as Vista 32bit. I understand that this is because the WinPE bit of the build requires the VistaPE drivers.

  4. Thanks to Chris_ from:

    tj2419 (2nd October 2011)

  5. #4

    Join Date
    May 2011
    Location
    United Kingdom
    Posts
    494
    Thank Post
    121
    Thanked 16 Times in 16 Posts
    Rep Power
    9
    Quote Originally Posted by Chris_ View Post
    When I build a CC4 client in a virtual machines I had to set the guest OS type as Vista 32bit. I understand that this is because the WinPE bit of the build requires the VistaPE drivers.
    Yer we have to do that when importing network drivers into the RMMC. Have you done it through virtual box before?

  6. #5
    Chris_'s Avatar
    Join Date
    Jul 2010
    Location
    UK
    Posts
    682
    Thank Post
    131
    Thanked 113 Times in 96 Posts
    Rep Power
    44
    Quote Originally Posted by tj2419 View Post
    Yer we have to do that when importing network drivers into the RMMC. Have you done it through virtual box before?
    I haven't done it with Virtual Box, only VMware.

    When you are configuring the vm properties, do you set the OS type as Windows Vista 32bit?

    Screenshot-Create_New_Virtual_Machine-4.jpg
    Attached Images Attached Images

  7. #6


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,919
    Thank Post
    226
    Thanked 2,676 Times in 1,973 Posts
    Rep Power
    787
    Which operating system is the guest VM going to be running in VirtualBox?

    The virtual NIC used by VirtualBox for both Vista and 7 is an Intel Pro/1000 MT so it doesn't matter that much which OS type you select. However, I would select the correct one for the OS you are going to using in the VM.

    You need to install the VirtualBox Extension Pack if you want to PXE boot the VM.
    Last edited by Arthur; 2nd October 2011 at 10:59 PM.

  8. Thanks to Arthur from:

    tj2419 (3rd October 2011)

  9. #7

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    3,921
    Thank Post
    1,193
    Thanked 1,064 Times in 755 Posts
    Rep Power
    329
    @Chris_:

    I set the OS as it states and this would be windows 7 also increased the memory to 2Gb and increased the CPU to 2, network settings as bridged which should pick up the host machines network card and Set the IDE controller in the storage settings to point to our default RM build iso and Bob's your uncle.

    VirtualBoxRM.jpg

  10. 2 Thanks to bossman:

    Chris_ (3rd October 2011), tj2419 (3rd October 2011)

  11. #8

    Join Date
    May 2011
    Location
    United Kingdom
    Posts
    494
    Thank Post
    121
    Thanked 16 Times in 16 Posts
    Rep Power
    9
    Quote Originally Posted by bossman View Post
    @Chris_:

    I set the OS as it states and this would be windows 7 also increased the memory to 2Gb and increased the CPU to 2, network settings as bridged which should pick up the host machines network card and Set the IDE controller in the storage settings to point to our default RM build iso and Bob's your uncle.

    VirtualBoxRM.jpg
    I have installed the extension pack and that now allows me to pie boot but is failing to find the host as the network driver is missing. Any advice on how to find the correct network driver for a macbook pro 13" 2011 model? or iMac 2011.

    BOSSMAN: DId you pie boot it or did you just directly use a copy of the build image iso?

    Thanks Guys

  12. #9

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    3,921
    Thank Post
    1,193
    Thanked 1,064 Times in 755 Posts
    Rep Power
    329
    @tj2419:
    Directly booted from the image which I pointed the CDrom settings at.

  13. Thanks to bossman from:

    tj2419 (3rd October 2011)

  14. #10

    Join Date
    May 2011
    Location
    United Kingdom
    Posts
    494
    Thank Post
    121
    Thanked 16 Times in 16 Posts
    Rep Power
    9
    Quote Originally Posted by bossman View Post
    @tj2419:
    Directly booted from the image which I pointed the CDrom settings at.
    Legend looks like it's working Cheers Bossman.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 10
    Last Post: 20th September 2011, 10:32 AM
  2. Clear IE addons for all users on RM CC4?
    By gsk in forum How do you do....it?
    Replies: 0
    Last Post: 6th January 2011, 11:46 AM
  3. Run Virtual Mac on a Mac
    By HallX in forum Mac
    Replies: 21
    Last Post: 22nd November 2010, 09:40 AM
  4. Installing Quark Xpress 8 on rm cc4 networks.
    By radioguyana in forum General Chat
    Replies: 0
    Last Post: 10th November 2010, 06:06 PM
  5. Replies: 3
    Last Post: 21st September 2010, 09:53 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •