+ Post New Thread
Results 1 to 6 of 6
Thin Client and Virtual Machines Thread, Windows 2008 R2 Remote Desktop Double Login in Technical; We have set up a 2008 r2 remote desktop farm, using a dedicated RD Broker for load balancing everything works ...
  1. #1

    Join Date
    Jul 2007
    Location
    Bingley
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Windows 2008 R2 Remote Desktop Double Login

    We have set up a 2008 r2 remote desktop farm, using a dedicated RD Broker for load balancing everything works fine except that user have to log on twice if using any other client other than windows 7. this still is the case when we have installed RD7 connection up date on our stripped down xp clients

  2. #2
    joe90bass's Avatar
    Join Date
    Oct 2007
    Location
    S Wales
    Posts
    1,349
    Thank Post
    322
    Thanked 107 Times in 96 Posts
    Rep Power
    50
    Have you got the option for never remember password or something along those lines set (at home so can't check!)?
    If I remote in from my home Vista PC to one of our Remote Desktop servers I have to enter them twice. We don't in school from a Thin Client though.

  3. #3
    Axel's Avatar
    Join Date
    Apr 2008
    Posts
    239
    Thank Post
    32
    Thanked 43 Times in 32 Posts
    Rep Power
    21
    As a thin client manufacturer I can confirm that we had to do a specific development to support Microsoft's broker to avoid having to log in twice. Essentially you are currently logging once into the broker, then again into the actual server - If you are using Axel terminals you may need to update your firmware depending how old they are. If you're not, all I can offer is you will need to look at the thin-client end - not the server end...

  4. #4

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Yeah I have not managed to get around this problem myself, If you just want to login to the Remote Desktop (Not RemoteApps) then what you can do is make an .rdp file and put in all the details, change the gateway to "remote.yourdomain.sch.uk" and then save that and it will work fine (straight through login or/ just your password).

    If you type in your DOMAIN\USERNAME and select to say it is a private computer, again it only asks you at the first login screen!

    James.

  5. #5

    Join Date
    Oct 2005
    Posts
    62
    Thank Post
    7
    Thanked 20 Times in 17 Posts
    Rep Power
    21
    Quote Originally Posted by mtagg View Post
    We have set up a 2008 r2 remote desktop farm, using a dedicated RD Broker for load balancing everything works fine except that user have to log on twice if using any other client other than windows 7. this still is the case when we have installed RD7 connection up date on our stripped down xp clients
    As someone else has said, the problem is caused by the way that the session broker and network load balancer work together. When you connect to the farm, the load balancer will connect you to one of the servers. You then have to login for the session broker to know who you are and where to place your session. If it decides to place your session on a different server to the one that network load balancer connected you to, you get a second login prompt.

    To resolve this, you need to get the client to handle the authentication. For XP clients, you will need to enable Network Level Authentication and you will need SP3 installed with Remote Desktop Client at least v6.1 to do that.

    To check if Network Level Authentication is enabled, open the remote desktop client, right-click in the title bar and choose About. If it says Network Level Authentication Not Supported, you will need to enable it as follows:

    - Browse to HKLM\SYSTEM\CurrentControlSet\Control\Lsa

    - Locate Security Packages and add tspkg to the bottom of the list

    - Browse to HKLM\System\CurrentControlSet\Control\SecurityProv iders

    - Locate Security Providers and add , credssp.dll at the end

    - Restart the computer

    - Now check that Network Level Authentication is enabled as above

    In the RDP file that you use to connect, make sure you've got the following settings:

    authentication level:i:0
    prompt for credentials:i:0
    promptcredentialonce:i:1
    enablecredsspsupport:i:1

  6. #6

    Join Date
    Oct 2010
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    If the remote computers are running windows XP, look into the NLA mentioned by PeterH. In general, look into 'SSO' (Single Sign On, or Single Session Sign On).

    I am testing it right now for my RemoteApp users. I recommend making the Registry changes to a 'vanilla' XP install (I used a virtual machine initially) - export each of the settings, then combine them into a single Registry file. Once done you can easily run the .reg file either manually or via a script onto the computers.

    As a note, SP3 does need to be installed which will take care of the RDP 6.1 item as well.

SHARE:
+ Post New Thread

Similar Threads

  1. Remote Desktop Timeout before login
    By Nick_Parker in forum Thin Client and Virtual Machines
    Replies: 5
    Last Post: 30th September 2011, 09:53 AM
  2. Remote Desktop Server 2008 R2
    By pettit87 in forum Windows Server 2008 R2
    Replies: 1
    Last Post: 27th October 2010, 12:57 AM
  3. Server 2008 remote desktop problems.
    By boomam in forum Windows Server 2008
    Replies: 7
    Last Post: 23rd March 2009, 09:38 AM
  4. 2008 TS Remote Apps - 60 second login
    By gjames in forum Windows Server 2008
    Replies: 11
    Last Post: 11th November 2008, 09:50 AM
  5. Remote Desktop Double Login
    By mitchell1981 in forum Windows
    Replies: 2
    Last Post: 5th July 2007, 08:17 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •