+ Post New Thread
Results 1 to 8 of 8
Thin Client and Virtual Machines Thread, XEN Pool with Sun 7110 NFS in Technical; ...
  1. #1

    Join Date
    Jul 2007
    Location
    Nottingham
    Posts
    196
    Thank Post
    19
    Thanked 7 Times in 7 Posts
    Rep Power
    16

    XEN Pool with Sun 7110 NFS



    I'm trying to get my new Sun X4150's setup with XEN Server 5.5 connecting to a Sun 7110 using NFS.

    I've setup the NIC Bonding Ok, created the Server Pool Ok but when I add the NFS storage for the server pool (through XEN Center or CLI) the master server connects Ok but any other server lists the connection as broken. Run a repair and it returns and error of “Unable to detect an nfs service on this target” for all the servers except the master which remains connected.

    What am I missing? Or is this configuration not supported?

  2. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,592
    Thank Post
    109
    Thanked 769 Times in 598 Posts
    Rep Power
    181
    Firstly, it works fine for me so it must be possible It's FAST too

    Have you configured the storage NICs as it says to in the manual? IIRC you have to do this on each host manually (I may be wrong though because the last time I did it was after I un-broke a host).

  3. #3

    Join Date
    Jul 2007
    Location
    Nottingham
    Posts
    196
    Thank Post
    19
    Thanked 7 Times in 7 Posts
    Rep Power
    16
    Thanks, Ric.

    I presume you're talking about the other-config:management_purpose="Storage" configuration for the NICs. I've checked and this was set on ETH0 and BOND0 on each host (BOND0 includes both ETH0 and ETH1) so I've added the configuration to ETH1 aswell.

    Ran:
    xe pbd-unplug uuid=[NFS UUID]
    No Errors returned

    xe pbd-plug uuid=[NFS UUID]
    Error Code: SR_BACKEND_FAILURE_108
    Error Parameters: , Unable to detect an NFS service on this target.,

    Tried destroying the SR and recreating it, same problem. Have tried creating the SR with the following advanced options:

    *(rw,no_root_squash,async)

    Still no go, are you using bonded NICs too?

  4. #4

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,592
    Thank Post
    109
    Thanked 769 Times in 598 Posts
    Rep Power
    181
    I am using a bond. You only need to do the storage config thing to the bond - not the interfaces it comprises of.

    Make sure you can ping the 7110 too.

  5. Thanks to Ric_ from:

    dan400007 (29th June 2009)

  6. #5

    Join Date
    Jul 2007
    Location
    Nottingham
    Posts
    196
    Thank Post
    19
    Thanked 7 Times in 7 Posts
    Rep Power
    16
    Sorted.

    Nothing wrong with the configuration, just the order in which it was done.

    If I configure the Bond before the storage the configuration fails, but configure the storage first and then the Bond and all works fine.

    Learnt lots in the process of elimination which is always a good thing.

  7. #6
    linescanner's Avatar
    Join Date
    Oct 2006
    Location
    East Anglia
    Posts
    297
    Thank Post
    51
    Thanked 71 Times in 48 Posts
    Rep Power
    29
    Quote Originally Posted by dan400007 View Post
    Sorted.

    Nothing wrong with the configuration, just the order in which it was done.

    If I configure the Bond before the storage the configuration fails, but configure the storage first and then the Bond and all works fine.

    Learnt lots in the process of elimination which is always a good thing.
    Dan

    If you get stuck on anything else give me a bell. I have an engineer here that has worked with a load of the other S7000 guys here to go over best practice etc...

  8. Thanks to linescanner from:

    dan400007 (6th July 2009)

  9. #7
    Duke's Avatar
    Join Date
    May 2009
    Posts
    1,017
    Thank Post
    300
    Thanked 174 Times in 160 Posts
    Rep Power
    57
    Is that an open offer Andy?

    I never did figure out NFS with VMware, anyone got any ideas on THIS problem before my trial runs out?

    Cheers,
    Chris

  10. #8
    linescanner's Avatar
    Join Date
    Oct 2006
    Location
    East Anglia
    Posts
    297
    Thank Post
    51
    Thanked 71 Times in 48 Posts
    Rep Power
    29
    Quote Originally Posted by Duke View Post
    Is that an open offer Andy?

    I never did figure out NFS with VMware, anyone got any ideas on THIS problem before my trial runs out?

    Cheers,
    Chris
    To you sir always.

    Rick is out on site today. Will drop you his Mobile number in a PM

SHARE:
+ Post New Thread

Similar Threads

  1. Sun Storage 7110
    By Ric_ in forum Hardware
    Replies: 663
    Last Post: 17th August 2012, 07:34 AM
  2. Sun Storage 7110 Performance
    By Ric_ in forum Hardware
    Replies: 64
    Last Post: 7th November 2011, 07:52 PM
  3. Sun 7000 - NFS with ESX How-To?
    By Duke in forum Hardware
    Replies: 0
    Last Post: 12th June 2009, 02:33 PM
  4. Xenserver 5 and SUN 7110 SAN
    By cookie_monster in forum Thin Client and Virtual Machines
    Replies: 9
    Last Post: 1st June 2009, 06:06 PM
  5. Sun 7110, CIFS share for MSI's
    By cookie_monster in forum Hardware
    Replies: 3
    Last Post: 14th May 2009, 11:33 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •