+ Post New Thread
Results 1 to 10 of 10
Thin Client and Virtual Machines Thread, Citrix - Pass-through Authentication not working in Technical; I have configured the Authentication Method in Access Management Console > Web Interface > Site > Config.xml to be 'Pass-through ...
  1. #1
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18

    Citrix - Pass-through Authentication not working

    I have configured the Authentication Method in Access Management Console > Web Interface > Site > Config.xml to be 'Pass-through (Default)' and I have created a custom install of the ICAClient and included PNa and the Web Interface, again set with Pass-through set.

    I've then logged onto the terminal server that I need the PNA Client installing on, installed the PNA Client and rebooted.

    I logon as my admin account and it logs me straight onto Citrix as my icons appear.

    I logon as test account and I get the Citrix PNA login box, and it does not pass through my details and let me logon.


    Any help would be greatly appreciated.


    Dan

  2. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,582
    Thank Post
    107
    Thanked 761 Times in 592 Posts
    Rep Power
    179
    Obvious things to check would be that the application sets are available to the test account and that the browser server is correctly configured in the test account's profile.

  3. #3
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18
    Quote Originally Posted by Ric_ View Post
    Obvious things to check would be that the application sets are available to the test account
    The application set is available to the test account, as i can manually put in my user name and password into the PNA box and login.

    Quote Originally Posted by Ric_
    the browser server is correctly configured in the test account's profile.
    Browser server?


    [15:06] quick update: Just been having a play around, and it only works for me when I’m logged on to the ‘console’ of the terminal server. If I login normally it doesn’t pass-through my details.

    Dan
    Last edited by DanW; 29th October 2008 at 03:13 PM.

  4. #4

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,582
    Thank Post
    107
    Thanked 761 Times in 592 Posts
    Rep Power
    179
    The 'Browser Server' is the server that contains the details of the published desktops/applications. If the details of this are not present in the PNAgent then things won't work. A convention appears to be to set up DNS aliases of ICA pointing to your Citrix servers so that round robbin can be used to avoid outages.

  5. #5
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18
    the browser server is correct.

  6. #6
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18
    i've attached two screenshots

    as you can see when logged in as the test user, the logon mode box is greyed out.

    but me logged onto the console the logon box says passthrough.


    if i logon as myself, but not onto the console i get the same as the test user account.
    Attached Images Attached Images

  7. #7

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,582
    Thank Post
    107
    Thanked 761 Times in 592 Posts
    Rep Power
    179
    Not in front of a Citrix box at the moment but is there a policy that setting to be forced/changed?

  8. #8
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18
    Quote Originally Posted by Ric_ View Post
    Not in front of a Citrix box at the moment but is there a policy that setting to be forced/changed?
    policy for which setting?

  9. #9

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,582
    Thank Post
    107
    Thanked 761 Times in 592 Posts
    Rep Power
    179
    Quote Originally Posted by DanW View Post
    policy for which setting?
    the pass-thru auth setting?

  10. #10
    DanW's Avatar
    Join Date
    Oct 2007
    Posts
    246
    Thank Post
    35
    Thanked 12 Times in 12 Posts
    Rep Power
    18
    there is no policy in the AMC or PSC although there is a setting in the icaclient.adm file.

    I tried setting, but to no avail (rebooted a few times and ran gpupdate)


    Dan

SHARE:
+ Post New Thread

Similar Threads

  1. PASS
    By Andi in forum MIS Systems
    Replies: 0
    Last Post: 22nd August 2008, 12:45 PM
  2. PASS - W3Insights
    By detjo in forum Educational Software
    Replies: 1
    Last Post: 19th February 2008, 10:56 AM
  3. PASS Use
    By dave.81 in forum MIS Systems
    Replies: 2
    Last Post: 18th October 2007, 07:56 AM
  4. Anyone use PASS 4 Windows?
    By dave.81 in forum MIS Systems
    Replies: 2
    Last Post: 29th March 2007, 12:16 PM
  5. Pass through authentication with Dansguardian based webfiltr
    By NetworkGeezer in forum How do you do....it?
    Replies: 16
    Last Post: 9th May 2006, 12:11 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •