+ Post New Thread
Results 1 to 2 of 2
Thin Client and Virtual Machines Thread, P2V Linux boot problem in Technical; Trying to convert a Linux box to a hyper-v vm I imaged the Linux machine using acronis as the VM ...
  1. #1

    Join Date
    May 2010
    Posts
    1,053
    Thank Post
    106
    Thanked 87 Times in 64 Posts
    Rep Power
    49

    P2V Linux boot problem

    Trying to convert a Linux box to a hyper-v vm

    I imaged the Linux machine using acronis as the VM harddrive is smaller then I
    restored the image fine to the vm, but it boots to a flashing cursor.
    The only way I can get this to boot is by using supergrub, once booted I tried update-grub but it still won't boot..

    Anyone had any similar experience ?

    At this rate it would be just easier to reinstall Linux....

  2. #2

    Join Date
    May 2010
    Posts
    1,053
    Thank Post
    106
    Thanked 87 Times in 64 Posts
    Rep Power
    49
    I fixed this, turns out my Linux machine was in UEFI mode, I had to convert to legacy then it booted

    For future reference :

    Download gparted

    boot VM with the iso attached and boot from the iso

    assuming the VM disk is GPT create a 1MB partition using gparted with an unformatted filesystem with a bios_grub flag) on the VM drive

    reboot

    then attach Linux-secure.iso (Linux-Secure-Remix | Free software downloads at SourceForge.net)

    boot not booting VM with the iso attached (boot from cd)

    Setup your networking / proxy once its booted (important)

    start boot-repair

    click advanced then go to the grub location tab

    untick separate /boot/efi partition option

    click apply then let it do its thing

    reboot and fingers crossed it should work fine

SHARE:
+ Post New Thread

Similar Threads

  1. boot problem
    By lionsl2005 in forum Windows
    Replies: 14
    Last Post: 28th January 2009, 11:02 AM
  2. Windows XP booting problem
    By JAW$ in forum Windows
    Replies: 12
    Last Post: 25th November 2008, 06:20 PM
  3. XP Boot problems.
    By boomam in forum Hardware
    Replies: 9
    Last Post: 22nd September 2008, 05:26 PM
  4. Thin Client booting problem - EdUbuntu
    By Disease in forum Thin Client and Virtual Machines
    Replies: 4
    Last Post: 25th February 2008, 02:58 PM
  5. New system boot problem.
    By laserblazer in forum Hardware
    Replies: 4
    Last Post: 20th December 2007, 09:52 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •