+ Post New Thread
Page 53 of 83 FirstFirst ... 34349505152535455565763 ... LastLast
Results 781 to 795 of 1233
Scripts Thread, FITS Compliant Web Based Helpdesk - ** RELEASED ** in Coding and Web Development; Originally Posted by ICTNUT This is the correct version number, we did the build late last night inorder to get ...
  1. #781

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,848
    Thank Post
    671
    Thanked 1,383 Times in 1,145 Posts
    Rep Power
    350
    Quote Originally Posted by ICTNUT View Post
    This is the correct version number, we did the build late last night inorder to get the release out this morning, had we done the build today the it would indeed be 2.0.4110.xyz
    Quote Originally Posted by Edu-IT View Post
    Ah, I was expecting to see v2.0.4110. Thanks!
    I think the confusion lies in the fact that the email notification from last night and the post earlier both say "release of OP SmartDesk v2.0.4110".
    If only you'd waited until midnight

  2. #782

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Everytime I try and create a new SLA Rule I get following error.

    Server Error in '/OPSD' Application.
    --------------------------------------------------------------------------------

    The state information is invalid for this page and might be corrupted.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: The state information is invalid for this page and might be corrupted.

    Source Error:

    The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

    1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

    <%@ Page Language="C#" Debug="true" %>

    or:

    2) Add the following section to the configuration file of your application:

    <configuration>
    <system.web>
    <compilation debug="true"/>
    </system.web>
    </configuration>

    Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

    Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

    Stack Trace:


    [FormatException: Invalid character in a Base-64 string.]
    System.Convert.FromBase64String(String s) +0
    System.Web.UI.ObjectStateFormatter.Deserialize(Str ing inputString) +102
    System.Web.UI.Util.DeserializeWithAssert(IStateFor matter formatter, String serializedState) +59
    System.Web.UI.HiddenFieldPageStatePersister.Load() +124

    [ViewStateException: Invalid viewstate.
    Client IP: 10.220.21.24
    Port: 6825
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; InfoPath.3; Tablet PC 2.0)
    ViewState: /wEPDwULLTE5OTQ5OTUzNTUPZBYCZg9kFgICAw9kFg4CAQ9kFgJ mDw8WAh4ISW1hZ2VVcmwFH34vQ29udGVudC9pbWFnZXMvc3RhZ mZfbG9nby5qcGdkZAIHDw8WAh4EVGV4dAUPdjIuMC40MTA5LjM zNjQyZGQCCQ8PFgIfAAUifi9wcm9maWxlX2ltYWdlcy9wcm9ma WxlX2ltYWdlLnBuZ2RkAgsPZBYCZg9kFgICBQ8PFgIfAQUqPGE gaHJlZj0uLi9TdGFmZi9wcmVmcy5hc3B4Pk15IEFjY291bnQ8L 2E+ZGQCDQ9kFggCAQ8WAh4LXyFJdGVtQ291bnQCARYCAgEPZBY GAgEPDxYCHwEFCDI0IEhvdXJzZGQCAg8VAQExZAIDDw8WBB4PQ 29tbWFuZEFyZ3VtZW50BQExHgdWaXNpYmxlaGRkAgcPEA8WAh4 LXyFEYXRhQm91bmRnZBAVBA08IE5PIENIQU5HRSA+BWFkbWluB 1NTYW11ZWwKZGZlcmd1c3NvbhUEATABMQEyATMUKwMEZ2dnZ2R kAgkPEA8WAh8FZ2QQFQoNPCBOTyBDSEFOR0UgPhRPdGhlci9HZ W5lcmFsIElzc3VlcxNMb2dvbi9Vc2VyIFByb2JsZW1zHUhhcmR 3YXJlIC0gV29ya3N0YXRpb24vTGFwdG9wFlByaW50ZXIvVG9uZ XIgUHJvYmxlbXMZTmV0d29yay9JbnRlcm5ldCBQcm9ibGVtcxF Tb2Z0...]

    [HttpException (0x80004005): The state information is invalid for this page and might be corrupted.]
    System.Web.UI.ViewStateException.ThrowError(Except ion inner, String persistedState, String errorPageMessage, Boolean macValidationError) +148
    System.Web.UI.HiddenFieldPageStatePersister.Load() +10962262
    System.Web.UI.Page.LoadPageStateFromPersistenceMed ium() +11045992
    System.Web.UI.Page.LoadAllState() +46
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041511
    System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041050
    System.Web.UI.Page.ProcessRequest() +91
    System.Web.UI.Page.ProcessRequest(HttpContext context) +240
    ASP.admin_slarules_aspx.ProcessRequest(HttpContext context) +9
    System.Web.CallHandlerExecutionStep.System.Web.Htt pApplication.IExecutionStep.Execute() +599
    System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously) +171




    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4927

  3. #783
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    Quote Originally Posted by dfergusson View Post
    Everytime I try and create a new SLA Rule I get following error.

    Server Error in '/OPSD' Application.
    --------------------------------------------------------------------------------

    The state information is invalid for this page and might be corrupted.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: The state information is invalid for this page and might be corrupted.

    Source Error:

    The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

    1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

    <%@ Page Language="C#" Debug="true" %>

    or:

    2) Add the following section to the configuration file of your application:

    <configuration>
    <system.web>
    <compilation debug="true"/>
    </system.web>
    </configuration>

    Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

    Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

    Stack Trace:


    [FormatException: Invalid character in a Base-64 string.]
    System.Convert.FromBase64String(String s) +0
    System.Web.UI.ObjectStateFormatter.Deserialize(Str ing inputString) +102
    System.Web.UI.Util.DeserializeWithAssert(IStateFor matter formatter, String serializedState) +59
    System.Web.UI.HiddenFieldPageStatePersister.Load() +124

    [ViewStateException: Invalid viewstate.
    Client IP: 10.220.21.24
    Port: 6825
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; InfoPath.3; Tablet PC 2.0)
    ViewState: /wEPDwULLTE5OTQ5OTUzNTUPZBYCZg9kFgICAw9kFg4CAQ9kFgJ mDw8WAh4ISW1hZ2VVcmwFH34vQ29udGVudC9pbWFnZXMvc3RhZ mZfbG9nby5qcGdkZAIHDw8WAh4EVGV4dAUPdjIuMC40MTA5LjM zNjQyZGQCCQ8PFgIfAAUifi9wcm9maWxlX2ltYWdlcy9wcm9ma WxlX2ltYWdlLnBuZ2RkAgsPZBYCZg9kFgICBQ8PFgIfAQUqPGE gaHJlZj0uLi9TdGFmZi9wcmVmcy5hc3B4Pk15IEFjY291bnQ8L 2E+ZGQCDQ9kFggCAQ8WAh4LXyFJdGVtQ291bnQCARYCAgEPZBY GAgEPDxYCHwEFCDI0IEhvdXJzZGQCAg8VAQExZAIDDw8WBB4PQ 29tbWFuZEFyZ3VtZW50BQExHgdWaXNpYmxlaGRkAgcPEA8WAh4 LXyFEYXRhQm91bmRnZBAVBA08IE5PIENIQU5HRSA+BWFkbWluB 1NTYW11ZWwKZGZlcmd1c3NvbhUEATABMQEyATMUKwMEZ2dnZ2R kAgkPEA8WAh8FZ2QQFQoNPCBOTyBDSEFOR0UgPhRPdGhlci9HZ W5lcmFsIElzc3VlcxNMb2dvbi9Vc2VyIFByb2JsZW1zHUhhcmR 3YXJlIC0gV29ya3N0YXRpb24vTGFwdG9wFlByaW50ZXIvVG9uZ XIgUHJvYmxlbXMZTmV0d29yay9JbnRlcm5ldCBQcm9ibGVtcxF Tb2Z0...]

    [HttpException (0x80004005): The state information is invalid for this page and might be corrupted.]
    System.Web.UI.ViewStateException.ThrowError(Except ion inner, String persistedState, String errorPageMessage, Boolean macValidationError) +148
    System.Web.UI.HiddenFieldPageStatePersister.Load() +10962262
    System.Web.UI.Page.LoadPageStateFromPersistenceMed ium() +11045992
    System.Web.UI.Page.LoadAllState() +46
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041511
    System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041050
    System.Web.UI.Page.ProcessRequest() +91
    System.Web.UI.Page.ProcessRequest(HttpContext context) +240
    ASP.admin_slarules_aspx.ProcessRequest(HttpContext context) +9
    System.Web.CallHandlerExecutionStep.System.Web.Htt pApplication.IExecutionStep.Execute() +599
    System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously) +171




    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4927
    This looks like a page caching issue: you can tell that from this line: The state information is invalid for this page and might be corrupted

    Firstly make sure you give the helpdesk website a quick restart.

    Secondly make sure that the local web cache files (IE & FF Temporary Internet Files) are deleted then try again.

  4. Thanks to ICTNUT from:

    dfergusson (4th April 2011)

  5. #784

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Is there any help files to get IMAP to work, Iv telnet into exchange server using IMAP that works.

    On testing I get following error.
    An error was returned by the polling service, the error was: The particular item of the response data cannot be parsed. The response string: *.

  6. #785
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    Quote Originally Posted by dfergusson View Post
    Is there any help files to get IMAP to work, Iv telnet into exchange server using IMAP that works.

    On testing I get following error.
    An error was returned by the polling service, the error was: The particular item of the response data cannot be parsed. The response string: *.
    That would be becouse IMAP is not yet supported, more info on this can be found here - 0000178: E-Mail Polling for non-POP3 protocols - OP Software Issue Tracker

    Is roadmapped for the 2.0.4200 release.

  7. #786

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Any information on getting POP3 to work. I have enabled that on our exchange, can telnet to that, and test on OPSD say connection succesful.
    Yet no test email I send seem to be being picked up.

    Update: Ignore this is working fine
    Last edited by dfergusson; 4th April 2011 at 01:58 PM.

  8. Thanks to dfergusson from:

    ICTNUT (4th April 2011)

  9. #787

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Ok so I’ve got the email pooler sort of working.

    Is there anywhere I can set how often it checks for new emails?

    Puller does not seem to remove original email from the account is that normal?

    Also support request created by puller does not email the support team as newly created support call.

    Thanks

  10. #788
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    Quote Originally Posted by dfergusson View Post
    Ok so I’ve got the email pooler sort of working.

    Is there anywhere I can set how often it checks for new emails?

    Puller does not seem to remove original email from the account is that normal?

    Also support request created by puller does not email the support team as newly created support call.

    Thanks
    Sounds like something is not running right there, can you check the application log in the event viewer of the webserver for any entries for the source OPSD.

    Could you PM me what you have, only the most recent needed, then I can tell you what you need to do.

  11. #789
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62

    OPSD v2.0.4111.31536 HOTFIX

    This hotfix has been released to resolve an issue that has been found with the email poller where the emails polled where not removed from POP3 inboxes causing the emails to be polled repeatedly.

    Self hosted customers can download the update from the customer area - https://www.opsoftware.net/customers/

    Hosted customers have already had the hotfix applied.

    If you do not use email polling then this is not an urgent fix however we advise that you should apply it when you can.

    Please follow the upgrade guide that can be found here when upgrading your software.

  12. Thanks to ICTNUT from:

    dfergusson (8th April 2011)

  13. #790

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Many Thanks for that Ozan

    Question, how can I increase the time between email pools, at the moment I believe it set to 10mins, anywhere of setting that to 1-2mins?

    Other question is when I have overdue jobs, I only receive email from system wants I log onto it, is this by design? Or has it to do that database goes to sleep?

    Beside all that I’m really impressed with how this helpdesk is looking now, and can finally put nail through old software.

  14. #791

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,114
    Thank Post
    403
    Thanked 619 Times in 566 Posts
    Rep Power
    180
    Quote Originally Posted by dfergusson View Post
    Many Thanks for that Ozan

    Question, how can I increase the time between email pools, at the moment I believe it set to 10mins, anywhere of setting that to 1-2mins?

    Other question is when I have overdue jobs, I only receive email from system wants I log onto it, is this by design? Or has it to do that database goes to sleep?

    Beside all that I’m really impressed with how this helpdesk is looking now, and can finally put nail through old software.
    At the moment the polling time is hard coded but there's something on the roadmap to make this user customizable.

  15. Thanks to Edu-IT from:

    ICTNUT (8th April 2011)

  16. #792
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    Quote Originally Posted by dfergusson View Post
    Many Thanks for that Ozan

    Question, how can I increase the time between email pools, at the moment I believe it set to 10mins, anywhere of setting that to 1-2mins?

    Other question is when I have overdue jobs, I only receive email from system wants I log onto it, is this by design? Or has it to do that database goes to sleep?

    Beside all that I’m really impressed with how this helpdesk is looking now, and can finally put nail through old software.
    Email polling is indeed hard coded to 10 mins as Edu-It has pointed out, we are going to make this user defineable within the Sept 2011 release however the minimum you will be able to select is 5 mins as some email server we have tested with if you go any lower will either overwhlem or block for a period.

    As far as you other question I believe you are talking about SLA's is that correct?

  17. #793

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Is there any known issue with a hyphen in a email address and the email puller. I have a member of staff that has hyphen in their email address and email does not get deleted after email puller picks it up.
    Not had any issue like that with any other members of staff.

    Will try and replicate the issue with newly created email address on Monday.

  18. #794
    ICTNUT's Avatar
    Join Date
    Jul 2005
    Location
    Hereford
    Posts
    1,419
    Thank Post
    196
    Thanked 249 Times in 122 Posts
    Rep Power
    62
    Quote Originally Posted by dfergusson View Post
    Is there any known issue with a hyphen in a email address and the email puller. I have a member of staff that has hyphen in their email address and email does not get deleted after email puller picks it up.
    Not had any issue like that with any other members of staff.

    Will try and replicate the issue with newly created email address on Monday.
    We have not seen any issues during development and testing, could you PM me the format and length of the email address so we do some testing for you.

  19. #795

    Join Date
    Jun 2008
    Location
    Cardiff
    Posts
    42
    Thank Post
    11
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Everytime I click on Track Incidents I getting the following error.

    What do I need todo to resolve?

    Invalid attempt to read when no data is present.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: Invalid attempt to read when no data is present.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [InvalidOperationException: Invalid attempt to read when no data is present.]
    System.Data.SqlClient.SqlDataReader.GetValue(Int32 i) +185
    OPSD.tracking1.rTracking_OnItemDatabound(Object sender, RepeaterItemEventArgs e) +6457
    System.Web.UI.WebControls.Repeater.CreateControlHi erarchy(Boolean useDataSource) +693
    System.Web.UI.WebControls.Repeater.OnDataBinding(E ventArgs e) +68
    OPSD.tracking1.Page_Load(Object sender, EventArgs e) +1307
    System.Web.UI.Control.OnLoad(EventArgs e) +132
    System.Web.UI.Control.LoadRecursive() +66
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2428

SHARE:
+ Post New Thread

Similar Threads

  1. Framework for ICT Technical Support (FITS)
    By FITS in forum School ICT Policies
    Replies: 32
    Last Post: 3rd March 2009, 09:38 AM
  2. very very urgent: FITS Your Experiences
    By russdev in forum General EduGeek News/Announcements
    Replies: 16
    Last Post: 23rd October 2007, 11:21 PM
  3. Is your school website DDA compliant?
    By bishopsgarthstockton in forum Web Development
    Replies: 5
    Last Post: 10th July 2007, 03:34 PM
  4. dda compliant website
    By Uraken in forum Web Development
    Replies: 5
    Last Post: 8th June 2007, 09:23 AM
  5. PHP based Helpdesk with IMAP or POP3 authentication?
    By wesleyw in forum How do you do....it?
    Replies: 5
    Last Post: 18th October 2006, 01:08 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •