+ Post New Thread
Results 1 to 6 of 6
Scripts Thread, Office 2010 uninstall script... in Coding and Web Development; We are starting to deploy office 2013, and using the Office Customization tools we run into a couple issues where ...
  1. #1

    Join Date
    May 2012
    Posts
    297
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Office 2010 uninstall script...

    We are starting to deploy office 2013, and using the Office Customization tools we run into a couple issues where certain parts of Office 2010 do not properly or completely uninstall.

    If we just push the office 2013 uninstall even with the .msp to uninstall office 2010, we notice that Sharepoint workgroup and MS Office Tools folder remains.

    MS has release a FixIt which do properly uninstall everything. Unfortunately I cannot get the FixIt to run silently. Ive extracted the .msi and have created a silent command to run:
    OffScrub10.vbs /ALL /Quiet

    This command works, but it will not go to the next line in the batch file I am pushing it from.

    We are using deepfreeze to push the .bat file to our lab machienes... Here are both scripts:

    Script 1: Copies office2013 install files and .vbs to local directory, then executes the .vbs with the silent commands, I'd like for the machine to reboot once the .vbs is finished to ensure the uninstall is complete. but it does not.
    xcopy "y:\Office2013" "C:\OfficeInstall\" /s
    c:\OfficeInstall\OffScrub10.vbs ALL /Quiet
    shutdown /r /t 10
    Script 2: Runs the seteup.exe which calls the .msp file and installs office 2013
    c:\OfficeInstall\setup.exe
    rmdir /q /s "C:\OfficeInstall\"
    shutdown /r /t 10
    both scripts work, but I have to manually tell deepfreeze to reboot the machiens (ive notice if i wait approx. 15mins the uninstall is complete, but I cant be sure, which is why i would like the script to reboot the machine once the vbs is finished)

    I don't know if its possible but can i tell the .vbs to just reboot when it has completed?

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,062
    Thank Post
    889
    Thanked 1,733 Times in 1,496 Posts
    Blog Entries
    12
    Rep Power
    454
    Try changing the reboot command to this

    shutdown -r -f -t 0

  3. #3

    Join Date
    May 2012
    Posts
    297
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    will do

  4. #4

    Join Date
    May 2012
    Posts
    297
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    doesnt seemed like the change made a difference... any other ideas? it seems like if i could jsut put a reboot command in the .vbs it would work, but i know nothin about vbs....

    here is the pastebin of the offscrub.vbs from the MS FixIt tool:
    '================================================= ============================== - Pastebin.com

  5. #5

    Join Date
    May 2012
    Posts
    297
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    No suggestions on how i can get the .vbs to either reboot when complete. or at least continue to the next part of the script...

  6. #6

    Join Date
    Nov 2013
    Location
    Chicago
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    another option is too dig through the reg and see if you can find the uninstall for the components left, use the msiexec /x to remove...
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall

    Just a thought.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 12
    Last Post: 12th August 2013, 09:10 AM
  2. Office 2010 Script to change Default File Location
    By talksr in forum Office Software
    Replies: 9
    Last Post: 11th March 2013, 03:03 PM
  3. office 2010 deploy script won't run?
    By chazzy2501 in forum Windows 7
    Replies: 13
    Last Post: 24th January 2012, 04:33 PM
  4. Uninstall Spell Check Office 2010
    By Frut02 in forum Office Software
    Replies: 7
    Last Post: 23rd November 2011, 12:16 PM
  5. [MS Office - 2010] Deploy Office 2010 - Startup Script
    By adamchapman in forum Office Software
    Replies: 8
    Last Post: 4th August 2011, 12:16 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •