+ Post New Thread
Results 1 to 4 of 4
Scripts Thread, Robocopy in Coding and Web Development; I'm new to Robocopy, but need to use it in a couple projects. This project is simply copying a remote ...
  1. #1

    Join Date
    May 2013
    Posts
    2
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Robocopy

    I'm new to Robocopy, but need to use it in a couple projects. This project is simply copying a remote site's daily activity onto our company serve. My script is:

    robocopy "E:\Local Data" \\servername\companypath /r:5
    pause

    As I understand it, everything in E\Local Data should be copied to the server in the file (companypath). This runs on a Server 2008 scheduled task to run automatically each evening. Before leaving yesterday I created a new file in E:\Local Data (A Test Folder) with a Text.txt file in the folder. Checking it this morning, A Test Folder did not get copied to \\servername\companypath. I named the command copy.bat. Double clicking on the executable and letting it run still does not copy the new folder/file. As the pause is there, I would also have expected to see the screen each morning with instructions to hit a key to close it. This does not occur either.

    What am I missing?

    Thank you in advance for any assistance!

    Dale

  2. #2
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    421
    Thank Post
    72
    Thanked 41 Times in 37 Posts
    Rep Power
    19
    You need to add the /s flag to copy subdirectories, or the /e flag to copy subdirectories including empty ones.

  3. Thanks to FishCustard from:

    DaleG (26th May 2013)

  4. #3

    Join Date
    May 2013
    Posts
    2
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Wow! Thank you for such a quick response, Richard! I have started a full copy, but will change my script to: robocopy "E:\Boston Stuff" \\lousrv01\companydata /s /r:5 and report back. Again, thank you!

    Dale

  5. #4
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    421
    Thank Post
    72
    Thanked 41 Times in 37 Posts
    Rep Power
    19
    No worries - got little to do until my LEA fix their VPN system, so am browsing Edugeek and the WS 2012 documentation! :P

SHARE:
+ Post New Thread

Similar Threads

  1. Robocopy
    By acrobson in forum How do you do....it?
    Replies: 16
    Last Post: 22nd December 2007, 01:41 PM
  2. Robocopy Gone Wrong
    By fawkers in forum Windows
    Replies: 2
    Last Post: 17th September 2007, 06:50 AM
  3. RoboCopy users.
    By tosca925 in forum Windows
    Replies: 3
    Last Post: 20th May 2007, 11:58 AM
  4. Robocopy questions...............!
    By Kyle in forum Windows
    Replies: 3
    Last Post: 28th January 2006, 07:20 PM
  5. Backup Script for NT backup and Robocopy
    By ChrisH in forum Scripts
    Replies: 12
    Last Post: 20th October 2005, 01:01 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •