+ Post New Thread
Results 1 to 4 of 4
Promethean Direct Support Thread, Windows 7 32 bit - Activdriver 5.7 via usb to serial cable in Direct Support; Windows 7 32 bit - Activdriver 5.7 via usb to serial cable Trying the above setup with the latest drivers ...
  1. #1

    Join Date
    Jan 2010
    Location
    United Kingdom
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry Windows 7 32 bit - Activdriver 5.7 via usb to serial cable

    Windows 7 32 bit - Activdriver 5.7 via usb to serial cable

    Trying the above setup with the latest drivers and software. We're using Keyspan USB to serial adapters as the machines don't have serial ports.

    Device manager shows the Promethean Serial driver and Serial board, the USB COM port is listed in ActivManager but it will not find/connect to the board itself. I've selected serial support in the activdriver installation.

    The keyspan adapter is working and shows up fine in device manager. When I get Activmanager to search for the board, the light on the USB2COM goes nuts, so it's "barking up the right tree" so to speak.

    We have this issue on 40 whiteboards with the same setup!

    Tried the usual uninstall, reinstall, reimage etc.

    I'm now short of ideas! Anyone have a fix or a workaround?

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    If these machines are desktops, I would highly recommend a PCI Serial port instead of using a USB > Serial adapter. This does solve a lot of problems, but I appreciate there is a small cost in doing this.

    Although the USB > Serial adapter shows up in Device Manager, I would still install the driver that came on the disc or search for a driver online. Microsoft's built in drivers are not always the best

    I suspect this is what is 'blocking' communication between the computer and whiteboard. Of course the other thing to remember is to switch on power to the whiteboard.

  3. #3

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,207
    Thank Post
    372
    Thanked 378 Times in 336 Posts
    Rep Power
    148
    I come across this issue yesterday - thankfully we don't have as many Keyspans as you.

    For some reason I couldn't get the Belkin ones we had to work (2 of them) but the Keyspans were fine. I seem to remember after picking initially plugging the board in and installing the driver the machine required a restart before it worked - it was using COM4 as well if that helps, but if your doing a Find - it should still pick it up.

    Good luck.

  4. #4

    TRobinson's Avatar
    Join Date
    May 2009
    Posts
    83
    Thank Post
    1
    Thanked 22 Times in 19 Posts
    Rep Power
    14
    Hi Steve,

    Most likely cause is that the wrong drivers are installed for the Keyspan adapter, one way to check would be to attach another serial device to see if this works with the keyspan. You need to check that there is a Win 7 driver out there or try the one off the CD.

    This may sound like a silly question but do you need the kepspan adapters, are your ActivBoards the serial only model (early 1st generation) or are you running long cable runs (if so makes sense why you are) but I tend to find that people started to use these when the boards had previously been attached to serial only PCs and then moved to USB models. If you have our second generation of boards you can leave the serial cable in place to deliver power to the board electronics and then simply attach a 5m USB lead to the USB socket on the board electronics. Let me know your product codes and I can confirm.

SHARE:
+ Post New Thread

Similar Threads

  1. USB to Serial Converter
    By the_one_that_cant in forum AV and Multimedia Related
    Replies: 8
    Last Post: 14th September 2013, 09:57 PM
  2. Free Keyspan USA-19HS usb to serial adaptor
    By plexer in forum General Chat
    Replies: 1
    Last Post: 5th April 2011, 04:23 PM
  3. Replies: 12
    Last Post: 27th April 2010, 08:28 AM
  4. Data Harvest EasySense USB to Serial
    By Cache in forum Educational Software
    Replies: 3
    Last Post: 11th November 2009, 07:18 PM
  5. USB TO SERIAL CONNECTION ISSUE!!!
    By dtakias in forum Windows
    Replies: 17
    Last Post: 18th February 2008, 04:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •