+ Post New Thread
Results 1 to 3 of 3
Promethean Direct Support Thread, Prometheon ActivBoard won't calibrate - Solution in Direct Support; I spent some time yesterday with an old activboard which wouldn't calibrate properly - I could run calibration and it ...
  1. #1

    Join Date
    Nov 2010
    Posts
    401
    Thank Post
    56
    Thanked 58 Times in 52 Posts
    Rep Power
    25

    Prometheon ActivBoard won't calibrate - Solution

    I spent some time yesterday with an old activboard which wouldn't calibrate properly - I could run calibration and it completed but the cursor just moved randomly when the pen was on the board.

    Promethean tech support suggested a driver update (didn't work), change the usb cable (didn't work), swap the pc for another one with new drivers (didn't work) and eventually suggested updating the firmware in the board. I was fairly sure the board electronics had a problem so was pretty skeptical that this would work but - blow me down - it did. The tech also said that a firmware update provokes a scan of the boards hardware which I can only guess sorted the problem.

    For future reference, prometheon tech can be reached from 01254 676 921 and the article describing how to update the firmware is at

    Article Details *-*Promethean KB - UK

    Hope this is of help to somebody.

    Mat

  2. Thanks to mats from:

    elsiegee40 (2nd March 2011)

  3. #2

    elsiegee40's Avatar
    Join Date
    Jan 2007
    Location
    Kent
    Posts
    10,082
    Thank Post
    1,683
    Thanked 2,029 Times in 1,501 Posts
    Rep Power
    674
    Not happened here - yet - but thread bookmarked to gie me some hope of finding it when it does!

  4. #3

    Join Date
    Mar 2009
    Location
    w.yorks
    Posts
    30
    Thank Post
    9
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Hi, I've had a board previously that did just that, pen spikes all over the place and a firmware update sorted it immediately. On the other had though just sorted a board today with the same symptoms & firmware made no difference or driver update or restarting it or reconnecting the usb .......in the end had to take it down and reconnected the power & usb cables from the electronics box on the back, hey presto works fine. Perhaps connection was loose or something (don't see how) but its a new one on me.

SHARE:
+ Post New Thread

Similar Threads

  1. Prometheon short throw flashing red light help
    By TonyMiles in forum Promethean Direct Support
    Replies: 8
    Last Post: 14th February 2011, 05:52 PM
  2. Sleepy ActivBoard
    By garethedmondson in forum Promethean Direct Support
    Replies: 13
    Last Post: 12th November 2010, 10:51 AM
  3. Activprimary can't find Prometheon board
    By TonyMiles in forum Promethean Direct Support
    Replies: 4
    Last Post: 2nd August 2010, 05:39 PM
  4. TDS Activboard
    By einstein_a_go_go in forum AV and Multimedia Related
    Replies: 2
    Last Post: 12th November 2009, 10:48 AM
  5. ActivBoard +2
    By HMCTech in forum Hardware
    Replies: 13
    Last Post: 8th December 2008, 01:59 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •