+ Post New Thread
Results 1 to 7 of 7
Office Software Thread, Issues appending Excel data to Access Table in Technical; I can import excel data to a new table with no issues. I cant however import the same data to ...
  1. #1

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,489
    Thank Post
    1,575
    Thanked 479 Times in 302 Posts
    Rep Power
    215

    Issues appending Excel data to Access Table

    I can import excel data to a new table with no issues.

    I cant however import the same data to an existing table.

    I exported the original table to excel as a template so I know my column headings are correct and I formatted the excel columns to the same data type as the table.

    I have no primary key in the excel spreadsheet

    When I import and append I get the following error -

    Microsoft Office Access was unable to append all of the data to the table.
    The contents of fields in 0 records(s) were deleted, and 0 record(s) were lost due to key
    violations.
    There are no further errors but no data what so ever is imported to the table. If I trim my import file to anything, 1 record, 1 record with 1 column tc etc I still get no import.

    Am I missing something?

  2. #2

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,710
    Thank Post
    3,246
    Thanked 1,048 Times in 970 Posts
    Rep Power
    364
    Not that it will help much but 32 bit or 64 bit OS and also what version of Office ( excel / Access ) 2010 / 2007 or what exactly ?

  3. Thanks to mac_shinobi from:

    CHR1S (6th August 2012)

  4. #3

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,710
    Thank Post
    3,246
    Thanked 1,048 Times in 970 Posts
    Rep Power
    364

  5. Thanks to mac_shinobi from:

    CHR1S (6th August 2012)

  6. #4

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,489
    Thank Post
    1,575
    Thanked 479 Times in 302 Posts
    Rep Power
    215
    64bit 2010

    I checked every bit of data, some dates were corrupt, I also found a required text column that was missing.

    Strangely I now get
    subscript out of range
    do the columns have to be in the same order or as long as the headers match it should be ok?

  7. #5

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,710
    Thank Post
    3,246
    Thanked 1,048 Times in 970 Posts
    Rep Power
    364
    Quote Originally Posted by CHR1S View Post
    64bit 2010

    I checked every bit of data, some dates were corrupt, I also found a required text column that was missing.

    Strangely I now get do the columns have to be in the same order or as long as the headers match it should be ok?
    As per last post in 2nd link

    Same data types, if you have a primary key etc than auto number, same order etc etc

  8. Thanks to mac_shinobi from:

    CHR1S (6th August 2012)

  9. #6

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,489
    Thank Post
    1,575
    Thanked 479 Times in 302 Posts
    Rep Power
    215
    I checked, EVERYTHING and nothing was different!

    For the sake of it, I renamed tblAssets to tblAssetsOLD imported the file into tblAssets, recreated my relationships and checked my required fields and its working perfectly!

    Weird, thanks for the help tho!

  10. Thanks to CHR1S from:

    mac_shinobi (7th August 2012)

  11. #7

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,710
    Thank Post
    3,246
    Thanked 1,048 Times in 970 Posts
    Rep Power
    364
    I didn't really help , just a bit of googling which is easy enough anyway

SHARE:
+ Post New Thread

Similar Threads

  1. Outlook 2010 rule to export data to Excel?
    By themightymrp in forum Office Software
    Replies: 2
    Last Post: 27th April 2012, 11:02 AM
  2. MS Access: listbox selection data to label caption
    By fafster in forum How do you do....it?
    Replies: 2
    Last Post: 12th November 2008, 01:49 PM
  3. Licensing issues associated with student remote access to terminal servers
    By meastaugh1 in forum Thin Client and Virtual Machines
    Replies: 2
    Last Post: 24th October 2008, 11:56 AM
  4. Importing data to Active Directory
    By fooby in forum Wireless Networks
    Replies: 3
    Last Post: 16th February 2006, 05:08 PM
  5. pupils able to access c drive via word 2000 web toolbar
    By projector1 in forum Office Software
    Replies: 22
    Last Post: 8th December 2005, 08:44 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •