+ Post New Thread
Results 1 to 11 of 11
Office Software Thread, MSACCESS 2007. DLL error in Technical; Please help.. When using access 2007 Reporting Wizard i get an error that reads 'error in loading dll' I have ...
  1. #1

    Join Date
    Feb 2007
    Posts
    187
    Thank Post
    6
    Thanked 8 Times in 8 Posts
    Rep Power
    16

    MSACCESS 2007. DLL error

    Please help..

    When using access 2007 Reporting Wizard i get an error that reads 'error in loading dll'

    I have tried everything from manually registering dll's

    Uninstall and reinstalling the office suite.

    Copying working dll's from another machine.

    I have the correct Jet version and MDAC Version

    Please help ...

  2. #2

    Join Date
    Jul 2009
    Posts
    250
    Thank Post
    6
    Thanked 40 Times in 35 Posts
    Rep Power
    14

  3. #3

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    Been having that problem for a while, here is the fix

    make a reg file from this below

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\TypeLib\{00025E01-0000-0000-C000-000000000046}\5.0\0\win32]

    @=hex(2):25,00,43,00,6f,00,6d,00,6d,00,6f,00,6e,00 ,50,00,72,00,6f,00,67,00,72, 00,61,00,6d,00,46,00,69,00,6c

    you can apply in to each station or run it over group policy

  4. #4

    Join Date
    Feb 2007
    Posts
    187
    Thank Post
    6
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    I have already tried the advice of registering the dll's with no luck, also the reg key didnt work for me too..

    I am using server 2008 r2 and it works on all my other clients. Just this one server.

    Any other advice would really help.

  5. #5

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    Quote Originally Posted by Liam View Post
    I have already tried the advice of registering the dll's with no luck, also the reg key didnt work for me too..

    I am using server 2008 r2 and it works on all my other clients. Just this one server.

    Any other advice would really help.
    Sorry i thought you meant a workstation not a server, i imagine the reg key is different

  6. #6

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    Which version of access?

    Also check the reg key manually

    @=hex(2):25,00,43,00,6f,00,6d,00,6d,00,6f,00,6e,00 ,50,00,72,00,6f,00,67,00,72, 00,61,00,6d,00,46,00,69,00,6c

    shoudl be in

    [HKEY_CLASSES_ROOT\TypeLib\{00025E01-0000-0000-C000-000000000046}\5.0\0\win32]

    just checked my server and its the same

  7. #7

    Join Date
    Feb 2007
    Posts
    187
    Thank Post
    6
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    I am using access 2007.

    So what should i have? Its not created that key for whatever reason..

    Could you export your key and email it to me please?

  8. #8

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    ac.txt

    see above file, change the file extension to .reg

    thats exported straight from my server

  9. #9

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    ac.7z

    sorry see zip file

  10. #10

    Join Date
    Feb 2007
    Posts
    187
    Thank Post
    6
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    Quote Originally Posted by mtdmitchell View Post
    ac.txt

    see above file, change the file extension to .reg

    thats exported straight from my server

    That reg key just creates %CommonProgramFi for the value.

    On my working server is says %CommonProgramFiles%\Microsoft Shared\DAO\dao360.dll

    Is there something else i need to do.. Its so frustrating isnt it.

  11. #11

    Join Date
    Feb 2007
    Location
    Four Oaks
    Posts
    283
    Thank Post
    37
    Thanked 10 Times in 9 Posts
    Rep Power
    20
    Sorry mate, i had the same frustrations with this error for a while, but that reg file fixed it for me.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS - FMS] GDI32.DLL error [Solved]
    By jamesloker in forum MIS Systems
    Replies: 36
    Last Post: 14th July 2010, 11:04 PM
  2. [MS Office - 2003] Strange MSAccess printing problem with .vbs
    By RabbieBurns in forum Office Software
    Replies: 1
    Last Post: 31st January 2009, 07:36 PM
  3. Exchange 2007 SpamAgent Install Error
    By mickeyh080 in forum Windows
    Replies: 1
    Last Post: 28th October 2008, 11:04 PM
  4. Sims Error during/after Nov 2007 Upgrade
    By Frazer in forum MIS Systems
    Replies: 10
    Last Post: 24th January 2008, 10:36 AM
  5. liberum - cdonts.dll error
    By Scotmk in forum Web Development
    Replies: 3
    Last Post: 17th January 2008, 09:02 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •