+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
Office Software Thread, Word GPO - disabling check spelling as you type in Technical; I am probably looking right past it but... after a good while googling, scouring microsoft tech net and searching through ...
  1. #1
    capncrunch's Avatar
    Join Date
    Apr 2009
    Posts
    118
    Thank Post
    6
    Thanked 10 Times in 8 Posts
    Rep Power
    13

    Word GPO - disabling check spelling as you type

    I am probably looking right past it but... after a good while googling, scouring microsoft tech net and searching through every conceivable option in the Word GPO I just cannot find where to turn off "check spelling as you type". I have turned off most of the other spell checking elements but that one still eludes me so I am still getting the red squigly underline.

    Please could somebody point me in the right direction?

  2. #2
    theeldergeek's Avatar
    Join Date
    Jul 2010
    Location
    Eastbourne, East Sussex
    Posts
    161
    Thank Post
    30
    Thanked 22 Times in 6 Posts
    Rep Power
    29
    Quote Originally Posted by capncrunch View Post
    I am probably looking right past it but... after a good while googling, scouring microsoft tech net and searching through every conceivable option in the Word GPO I just cannot find where to turn off "check spelling as you type". I have turned off most of the other spell checking elements but that one still eludes me so I am still getting the red squigly underline.

    Please could somebody point me in the right direction?
    Blimey, you haven't been let loose in AD have you?!? Which version of Office, 2010?

  3. #3
    theeldergeek's Avatar
    Join Date
    Jul 2010
    Location
    Eastbourne, East Sussex
    Posts
    161
    Thank Post
    30
    Thanked 22 Times in 6 Posts
    Rep Power
    29
    Office 2010 Resource Kit maybe?

    Office 2010 Resource Kit

  4. #4
    theeldergeek's Avatar
    Join Date
    Jul 2010
    Location
    Eastbourne, East Sussex
    Posts
    161
    Thank Post
    30
    Thanked 22 Times in 6 Posts
    Rep Power
    29

  5. #5
    capncrunch's Avatar
    Join Date
    Apr 2009
    Posts
    118
    Thank Post
    6
    Thanked 10 Times in 8 Posts
    Rep Power
    13
    I have already disabled "Check grammar with spelling" and i have trawled through a lot of microsoft documentation regarding the policy settings for office but unlike, powerpoint, one note, publisher and outlook it seems Word does not have a "check spelling as you type" option like the they do. I suppose I could set start background checker to a mahoosive number but I would have much preffered a definate "off" option...

  6. #6
    capncrunch's Avatar
    Join Date
    Apr 2009
    Posts
    118
    Thank Post
    6
    Thanked 10 Times in 8 Posts
    Rep Power
    13
    A quick read of the Policy shows that spell checking delay only effects terminal server sessions, so I still have no way of disabling spell checker!?

  7. #7
    theeldergeek's Avatar
    Join Date
    Jul 2010
    Location
    Eastbourne, East Sussex
    Posts
    161
    Thank Post
    30
    Thanked 22 Times in 6 Posts
    Rep Power
    29
    Quote Originally Posted by capncrunch View Post
    A quick read of the Policy shows that spell checking delay only effects terminal server sessions, so I still have no way of disabling spell checker!?
    Can't help you much more than I already have tried to unfortunately, or even investigate solutions from this end as we have a completely different desktop delivery to our client machines than you do, so I can't even begin to replicate the problem. I'll keep looking, but it sounds as if you have explored most avenues anyway.

  8. #8
    Poco's Avatar
    Join Date
    Nov 2010
    Location
    Northamptonshire
    Posts
    36
    Thank Post
    2
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    might be a long shot but have you looked at Autocorrect options that is in Word Options? just untick all of them if you haven't and will probably solve the issue. apologies if you have checked this.

  9. #9
    capncrunch's Avatar
    Join Date
    Apr 2009
    Posts
    118
    Thank Post
    6
    Thanked 10 Times in 8 Posts
    Rep Power
    13
    Quote Originally Posted by Poco View Post
    might be a long shot but have you looked at Autocorrect options that is in Word Options? just untick all of them if you haven't and will probably solve the issue. apologies if you have checked this.
    Yes that does work, and it is what I am currently having to do but with 160 accounts that need spell check disabled I was rather hoping I could do it centrally rather than logging on as every single account.

  10. #10
    Poco's Avatar
    Join Date
    Nov 2010
    Location
    Northamptonshire
    Posts
    36
    Thank Post
    2
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    ahh i see. i didnt realise you was doing it over multiple's.

    i think our Microsoft account manager is in later today so i will see if he can get me an answer for you

  11. #11
    capncrunch's Avatar
    Join Date
    Apr 2009
    Posts
    118
    Thank Post
    6
    Thanked 10 Times in 8 Posts
    Rep Power
    13
    Quote Originally Posted by Poco View Post
    ahh i see. i didnt realise you was doing it over multiple's.

    i think our Microsoft account manager is in later today so i will see if he can get me an answer for you
    That would be great, thanks!

  12. #12
    Poco's Avatar
    Join Date
    Nov 2010
    Location
    Northamptonshire
    Posts
    36
    Thank Post
    2
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    spoke with him and he reckons the only real way would be to do it once and image it then roll it out. failing that a customised script i would suppose.

    Not the greatest answer in the world but it was worth a try

    i hope it goes some way to helping at least

  13. #13
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,488
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Okay, I've got it folks - I've managed to disable the spell checker in Office 2010!!

    Go to disable proofing, spell checker, using GPO., follow Rex Zhang's instructions and then scroll down a bit for my comment and add the registry keys.

    Job done.

  14. 2 Thanks to enjay:

    Kanin (2nd December 2011), OverWorked (24th November 2011)

  15. #14
    OverWorked's Avatar
    Join Date
    Jul 2005
    Location
    N. Yorks
    Posts
    1,014
    Thank Post
    198
    Thanked 42 Times in 34 Posts
    Rep Power
    30
    Enjay, you're a star! It won't work without the reg edits you've added.

    To update links for Office 2010
    Disable user interface items and shortcut keys in Office 2010
    Office 2010 Help Files: Office Fluent User Interface Control Identifiers

    The Control Identifiers need to be added as numbers one per line, not separated by commas as the GPO help says. Like this:-

    control identifiers.png

    This took some doing. MS must *really* not want admins to disable the proofing.
    Last edited by OverWorked; 24th November 2011 at 04:32 PM.

  16. #15
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,488
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    I've just found that this isn't as fool-proof as we had hoped. Even with all these changes, users can still Alt+Click a word to open the thesaurus (looks like all we've done is disabled the toolbar button, not the thesaurus itself) and also right-click | synonyms.

    Anyone know of a way to prevent these?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [MS Office - 2007] Disabling Spell Check via GPO
    By jonathanhaddock in forum Office Software
    Replies: 8
    Last Post: 21st August 2012, 05:54 PM
  2. [MS Office - XP] Disabling spell checker in Word??????
    By rusty155 in forum Office Software
    Replies: 43
    Last Post: 21st October 2011, 03:25 PM
  3. [MS Office - 2007] Check Spelling as you type not working.
    By Stuart_C in forum Office Software
    Replies: 1
    Last Post: 4th October 2010, 11:53 AM
  4. [MS Office - 2003] Word error, file type blocked because written in earlier version of word, registry?
    By Darryl_Wilcox in forum Office Software
    Replies: 3
    Last Post: 20th May 2010, 08:09 AM
  5. Replies: 6
    Last Post: 26th March 2007, 08:35 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •