+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
Office Software Thread, Enabling Macro's in Technical; Right, ive been messing with a word doc adding text boxes and whatever to stop the teachers writing essays. I ...
  1. #1

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541

    Enabling Macro's

    Right, ive been messing with a word doc adding text boxes and whatever to stop the teachers writing essays. I was told i also needed a way for them to be able to add a tick in a box without faffing with fonts. So i created a really simple macro so when a button is pressed a tick is placed.
    Now i did this on my laptop which isnt part of the domain. Now i've tried to add it to a networked pc its shouting at me about security and wont let me run it.
    I've used selfcert to sign it but that didnt make a difference.

    Is the certificate a file somewhere that has to be kept with the doc?
    How do i get around this? Do i have to change something in the policys?

    Grrr....me trying to be clever...tut

  2. #2

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,377
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    There's prob a option in GP, I think if you go into macro security, you want to set it to low or something.

    If you want to sign them, it's best to use a certificate from your domain's CA (which you might need to install).

  3. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    Depending on the version of Office you're using (but I will presume Office 2003), navigate to: Tools > Options > Security > Macro Security. Set it to 'Medium'.

    When you open a document, Word will always prompt you what to do. Choose 'Enable' and the document should work as intended. I wouldn't recommend you set it to 'Low' as this is a great way for macro viruses to run undetected.

    If you need to set this network wide, you need Ork Tools or Office Resource Kit. This is essentially ADM templates (Group Policy Objects) which allow you to tweak Office as you would Windows.

    Add the Word11 template, then navigate to:

    User Config > Admin Templates > Microsoft Office Word 2003 > Tools | Macro > Security

    Set the policy 'Security Level' to Medium. Job done.

  4. Thanks to Michael from:

    Little-Miss (20th March 2009)

  5. #4

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    Right, i've done as you've suggested Michael (thank you for given me the opportunity to delve into the unknown! ).

    Not worked as of yet. Going to try it again on a machine i havent messed with. I'll be back if it doesnt work.

  6. #5

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    It didnt work

    Still getting the error when i try to run it. Even if i've chosen to enable the macro...

  7. #6

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,154
    Thank Post
    114
    Thanked 527 Times in 450 Posts
    Blog Entries
    2
    Rep Power
    123
    Why don't you just put a check box form field on the page?

    I don't have Word 2003 at the moment but this looks like the right info for doing it

    No macros to worry about and it just works as users (hopefully!!) expect.

  8. #7

    Domino's Avatar
    Join Date
    Oct 2006
    Location
    Bromley
    Posts
    4,126
    Thank Post
    215
    Thanked 1,255 Times in 786 Posts
    Blog Entries
    4
    Rep Power
    505
    Quote Originally Posted by Little-Miss View Post
    It didnt work

    Still getting the error when i try to run it. Even if i've chosen to enable the macro...
    Ah, you do need to close and reopen word after making that change...

    and also if you've not used roaming profiles for each machine you'll need to do it.

  9. #8

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    Domino: Did all that, still same error. I would've thought that the changes i made in AD would have done that automatically anyway. Somethings not quite right.

    srochford: Did think about that, but its something that's going out to the parents so i dont know how its going to look printed. Might try it and see.

  10. #9

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    It sounds as though you've done everything correctly. Word should always prompt you whenever a macro enabled document is detected. The problem you have does appear to be related to the document specifically.

    The reason I know all the above is primarily to do with an application called 'Nelson Handwriting' which uses macros. Office 2003's default macro setting is high, which is pretty useless as only trusted sources will work.

  11. #10

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    So you think its the document?

    Might start from scratch and try again. Though i have just deleted and recreated the macro because i'd had a dur moment with the original and its still not working

  12. #11

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,154
    Thank Post
    114
    Thanked 527 Times in 450 Posts
    Blog Entries
    2
    Rep Power
    123
    Quote Originally Posted by Michael View Post
    Office 2003's default macro setting is high, which is pretty useless as only trusted sources will work.
    Err; that's kind of the idea! You might as well say [insert name of virus scanner] is useless because it blocks bad programs!!

  13. #12

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    Right, I created a blank test document with the same macro (which i have started from scratch). All the macro is " Letter P > change font to wingdings 2> adjustment of size and that creates the tick.
    Tried to open it on a networked w/s. Got the choice to enable the macro, ok fine. Try to run the macro by clicking on the toolbar button i created and get

    "The macro cannot be found or has been disabled becayse of your macro security settings."

    Grrr

    All this for a tick!

  14. #13

    Join Date
    May 2007
    Location
    Birmingham
    Posts
    169
    Thank Post
    9
    Thanked 45 Times in 36 Posts
    Rep Power
    27
    Little Miss go to Insert > symbols. then change the font to windings 2 >select the tick then click on shortcut key, then press on the keys you want to use a the shortcut. to finish make sure you save the changes in the document and not normal.dot then you don't need to use macros.


  15. Thanks to JOrdan01070 from:

    Little-Miss (23rd March 2009)

  16. #14

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    OMG Jordan you may have saved me so much work!! Going to try it now!

  17. #15

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,514
    Thank Post
    2,374
    Thanked 742 Times in 455 Posts
    Blog Entries
    2
    Rep Power
    541
    Right, that works perfectly. But when i open the document on another computer the shortcut key isnt working, i was kinda hoping if i save it to the doc it would follow it...

    Is it just me!!! lol

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 6
    Last Post: 24th February 2008, 07:37 PM
  2. Replies: 8
    Last Post: 20th February 2007, 07:00 PM
  3. Replies: 4
    Last Post: 29th June 2005, 12:43 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •