+ Post New Thread
Results 1 to 3 of 3
Office Software Thread, Access - Combo Box not populating table in Technical; I have two identical tables (A & B), populated by two identical forms. A) I select an asset category from ...
  1. #1

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212

    Access - Combo Box not populating table

    I have two identical tables (A & B), populated by two identical forms.

    A) I select an asset category from a combobox populated from another table (two columns, one bound) click save and it populates the table with the selection.

    B) I select an asset category from a combobox populated from another table (two columns, one bound) click save and it errors with "You must enter a value in 'Assets.AssetCategory' field.

    Both use the following to populate -

    Code:
    SELECT DISTINCTROW [Asset Categories].*
    FROM [Asset Categories]
    ORDER BY [Asset Categories].AssetCategory;
    Why would one work and the other not?

  2. #2

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    If I change the Control source of table B's combobox to the non-linked source it works, but it changes the wrong info.

    I realise my table has a few quirks, like the primary key and its secondary value in the same table instead of it being joined.

    work to do.

  3. #3

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    So, why would it refuse to populate the correct entry in the table?
    I need it to work as its breaking other things.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 4
    Last Post: 10th March 2010, 09:11 AM
  2. Creating query based on multiple combo boxes
    By Shrimpersfan in forum Coding
    Replies: 8
    Last Post: 23rd December 2008, 06:38 PM
  3. Can access intranet but not WWW
    By speckytecky in forum General Chat
    Replies: 4
    Last Post: 16th December 2008, 09:41 AM
  4. Printing Access Reports... or not!
    By Frazer in forum Windows
    Replies: 0
    Last Post: 20th October 2005, 11:03 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •